Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

eXpli

Anfänger

  • »eXpli« ist der Autor dieses Themas

Beiträge: 13

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

1

Samstag, 18. Juli 2009, 14:45

Mounten der 2 Platte

Hallo zusammen,

ich habe eine 1 TB große Platte partitioniert und versuche diese jetzt an der Slug zu laufen zu bringen. ICh bekomme es aber nicht hin das er die automatisch mountet. Wenn ich testweise

Quellcode

1
mount /dev/sdb9/ /unterlagen
eingebe dann bekomme ich die Meldung:

Quellcode

1
mount: you must specify the filesystem type
.

mit

Quellcode

1
cfdisk /dev/sdb
bekomme ich die partitionen bereits richtig angezeigt... Was mache ich falsch ?

Anzeigen

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

2

Samstag, 18. Juli 2009, 20:40

AW: Mounten der 2 Platte

Wäre es nicht hübsch, nach dem partitionieren noch zu formatieren?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Anzeigen

eXpli

Anfänger

  • »eXpli« ist der Autor dieses Themas

Beiträge: 13

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

3

Sonntag, 19. Juli 2009, 13:20

AW: Mounten der 2 Platte

Hallo nochmal,

wenn ich

Quellcode

1
cfdsik /dev/sdb
eingebe, bekomme ich diese Ausgabe:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
                        cfdisk (util-linux-ng 2.13.1.1)

                              Disk Drive: /dev/sdb
                      Size: 1000204886016 bytes, 1000.2 GB
             Heads: 255   Sectors per Track: 63   Cylinders: 121601

    Name        Flags      Part Type  FS Type          [Label]        Size (MB)
 ------------------------------------------------------------------------------
    sdb5                    Logical   W95 FAT32 (LBA)                 300206.24*
    sdb6                    Logical   W95 FAT32 (LBA)                 249999.17
    sdb7                    Logical   W95 FAT32 (LBA)                 149996.21
    sdb8                    Logical   W95 FAT32 (LBA)                 249999.17
    sdb9                    Logical   W95 FAT32 (LBA)                  50001.48


FS Type W95 FAT32 (LBA) sollte eigentlich heißen das die Platte bereits formatiert ist, oder?

sindbad

Schüler

Beiträge: 65

Verwendetes NAS-Device: debian lenny@NSLU und sheeva

Firmwareversion / your current Firmware: Debian

Wohnort: zwischen Berlin und Leipzig

  • Nachricht senden

4

Sonntag, 19. Juli 2009, 17:00

AW: Mounten der 2 Platte

Hi,

nö, ist bloss die Nummer, die da beim Partitioniren abgefragt wird.

mkfs -t ext3 /dev/?db?

sindbad

eXpli

Anfänger

  • »eXpli« ist der Autor dieses Themas

Beiträge: 13

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

5

Sonntag, 19. Juli 2009, 17:44

AW: Mounten der 2 Platte

Habe folgendes versucht:

Quellcode

1
2
3
NSLU2:~# mkfs.vfat -F 32 /dev/sda9
-bash: mkfs.vfat: command not found
NSLU2:~#


Muss ich noch was nachinstallieren ?

m2000

Anfänger

Beiträge: 26

Verwendetes NAS-Device: NSLU2/Guruplug

Firmwareversion / your current Firmware: Debian

Wohnort: Berlin

  • Nachricht senden

6

Montag, 20. Juli 2009, 07:22

AW: Mounten der 2 Platte

Ich glaube, da brauchst Du noch "dosfstools".

Hast Du denn keinen anderen Rechner um die Platte zu formatieren. Mit der NSLU2 dürfte es ziemlich lange dauern.

sindbad

Schüler

Beiträge: 65

Verwendetes NAS-Device: debian lenny@NSLU und sheeva

Firmwareversion / your current Firmware: Debian

Wohnort: zwischen Berlin und Leipzig

  • Nachricht senden

7

Montag, 20. Juli 2009, 14:04

AW: Mounten der 2 Platte

mkfs.vfat ist glaub ich mkdosfs , was vermutlich noch installiert werden muß.

bischen googlen könntest du aber auch!

aber die nslu würde ich zum formatieren wirklich nicht nehmen, da gibts zu viel probleme mit swap und ausreichend speicher usw.

grüße

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

8

Montag, 20. Juli 2009, 18:48

AW: Mounten der 2 Platte

Quellcode

1
2
3
4
[1846][JrB@debr4vm:~]$ apt-cache search mkfs.vfat
dosfstools-dbg - utilities for making and checking MS-DOS FAT filesystems (debug)
dosfstools - Programme zum Anlegen und Überprüfen von MS-DOS-FAT-Dateisystemen
[1846][JrB@debr4vm:~]$


bye
JrB
"Supporting joe users worldwide" <- that's our motto


eXpli

Anfänger

  • »eXpli« ist der Autor dieses Themas

Beiträge: 13

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

9

Sonntag, 22. November 2009, 14:51

Hallo Jungs,

ich habe leider immernoch nicht geschafft die Platte einzubinden. Konnte mich jetzt einige Zeit lang aber nicht weiter damit beschäftigen... muss ich zugeben :(

Formatiert habe ich Partitionen bereits auf meinem WinRechner. Habe folgende Einträge in die /etc/fstab geschrieben:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
NSLU2:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda2       /               ext3    errors=remount-ro 0       1
/dev/sda1       /boot           ext2    defaults        0       2
/dev/sda6       /home           ext3    defaults        0       2
/dev/sda5       none            swap    sw              0       0
/dev/sdb5       /unterlagen     fat32   defaults        0       2
/dev/sdb6       /musik          fat32   defaults        0       2
/dev/sdb7       /backup         fat32   defaults        0       2
/dev/sdb8       /bilder         fat32   defaults        0       2
/dev/sdb9       /others         fat32   defaults        0       2


hab ich was falsch gemacht ?

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
                        cfdisk (util-linux-ng 2.13.1.1)

                              Disk Drive: /dev/sdb
                      Size: 1000204886016 bytes, 1000.2 GB
             Heads: 255   Sectors per Track: 63   Cylinders: 121601

    Name        Flags      Part Type  FS Type          [Label]        Size (MB)
 ------------------------------------------------------------------------------
                            Pri/Log   Free Space                           8.23
    sdb5                    Logical   W95 FAT32                        53694.63
    sdb6                    Logical   W95 FAT32                       268440.24
    sdb7                    Logical   W95 FAT32                       322126.65
    sdb8                    Logical   W95 FAT32                       161067.44
    sdb9                    Logical   W95 FAT32                       194865.11

?(

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

10

Sonntag, 22. November 2009, 15:03

Moin,

nachdem Du nicht wirklich mitteilsam bist, was das befolgen von Ratschlägen angeht, oder das Vorgehen Deinerseits, greife ich zur Kristallkugel...

Die rät, erst eine extended Partition anzulegen, bevor man mit suspekten Werkzeugen logical Partitions in selbiger anlegt....

bye
JrB

PS: Welche Fehlermeldung ist das Resultat eines "mount /dev/sdbx /mnt -o vfat"?
"Supporting joe users worldwide" <- that's our motto


eXpli

Anfänger

  • »eXpli« ist der Autor dieses Themas

Beiträge: 13

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

11

Sonntag, 22. November 2009, 15:52

Quellcode

1
2
3
4
5
NSLU2:~# mount /dev/sdb5 /mnt -o vfat
mount: wrong fs type, bad option, bad superblock on /dev/sdb5,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


Tut mir sehr leid... aber ich bin halt kein profi in solchen linux-geschichten...

Quellcode

1
2
3
4
5
6
7
8
9
10
11
NSLU2:~# dmesg | tail
[42949415.360000] firmware: requesting NPE-B
[42949415.530000] NPE-B: firmware functionality 0x0, revision 0x2:1
[42949415.540000] eth0: link down
[42949418.550000] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[42949420.800000] NET: Registered protocol family 10
[42949420.810000] lo: Disabled Privacy Extensions
[42949431.300000] eth0: no IPv6 routers present
[42950026.050000] FAT: Unrecognized mount option "vfat" or missing value
[42950054.420000] FAT: Unrecognized mount option "fat32" or missing value
[42950433.370000] FAT: Unrecognized mount option "vfat" or missing value


Ich habe mit cfdisk die Partitionen erstellt. Das müssen doch logische sein oder ?

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »eXpli« (22. November 2009, 18:23) aus folgendem Grund: zusatz


sindbad

Schüler

Beiträge: 65

Verwendetes NAS-Device: debian lenny@NSLU und sheeva

Firmwareversion / your current Firmware: Debian

Wohnort: zwischen Berlin und Leipzig

  • Nachricht senden

12

Sonntag, 22. November 2009, 17:49

muß das nicht "vfat" statt fat32 heißen?

grüße

eXpli

Anfänger

  • »eXpli« ist der Autor dieses Themas

Beiträge: 13

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

13

Sonntag, 22. November 2009, 18:24

Habe ich beides schon probiert... dann startet aber die slug nicht mehr richtig... ;(

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

14

Sonntag, 22. November 2009, 20:04

Moin,

Ich geißel mich selbst ein wenig...

mount /dev/sdbx /mnt -t vfat

bye
JrB
"Supporting joe users worldwide" <- that's our motto


Social Bookmarks