Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 22. Januar 2009, 23:39

RaLink RT73 auf Debian Etch And A Half

Hallo,
ich habe den USB-Stick TP-Link TL-WN321G. Der hat den Chipsatz RT73 von Ralink. Folgendes Problem habe ich dabei: Direkt nach dem booten bzw. bei der aktivieren mit ifup assoziiert sich der Stick nicht mit dem AP. Erst nach mehrmaligen änderungen mittels iwconfig oder scans mit iwlist klappt die Verbindung. Mit dem Treiber rt73usb liefert dmesg die Meldung

Quellcode

1
ADDRCONF(NETDEV_UP): wlan0: link is not ready
Später wenn nach einigem versuchen dann endlich eine Verbindung besteht bekomme ich die Meldung

Quellcode

1
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mit dem selbst kompilierten Treiber rt73 von serialmonkey bekomme ich keine Fehlermeldung bei dmesg, das Problem bleibt jedoch gleich. Ich hatte dieses Problem auch früher mit dem PC. Dort habe ich eine RT2500 Karte. Gelöst hat sich das dann irgendwann durch die Anschaffung einer WLAN-Bridge mit AP die in der nähe des PCs steht. Schlechter empfang kann es bei dem USB-Stick aber nicht sein, das sind nur ein paar cm zwischen den Antennen. Die Bridge hat aber nur einen Anschluss und da hängt das IP-Telefon dran.
Jemand eine idee woran das liegen kann? Im gegensatz zum PC löst beim NSLU2 keineinfaches script das Problem, da sich das verhalten nicht vorraussagen lässt.

Hier meine interfaces:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
LKG9B4047:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interfacep

auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet static
    address 192.168.1.4
    netmask 255.255.255.0
    gateway 192.168.1.1
    wireless-mode managed
    wireless-essid Christian
    wireless-key open [...]
#    post-up route del default
#    post-up route add default gw 192.168.1.1 wlan0
#    post-up iwlist wlan0 scan
    post-up /usr/bin/beep beep -f 10 -l 150 -r 1 -d 10
Hier mal ein paar Auzüge bei verwendung des rt73usb-Moduls:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
LKG9B4047:~# ifup wlan0
FATAL: Module p80211 not found.
Failed to load p80211.o.
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
LKG9B4047:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0_rename  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"Christian"
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B
          Encryption key:****-****-****-****-****-****-**
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Quellcode

1
2
3
4
5
6
7
8
LKG9B4047:~# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:21:27:CC:0C:96
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
LKG9B4047:~# lsmod|grep rt
rt73usb                23168  0
ledtrig_heartbeat       3104  0
rt2500usb              20800  0
rt2x00usb              11168  2 rt73usb,rt2500usb
rt2x00lib              21472  3 rt73usb,rt2500usb,rt2x00usb
rfkill                  7824  1 rt2x00lib
input_polldev           5256  1 rt2x00lib
crc_itu_t               2080  1 rt2x00lib
firmware_class         10208  2 rt2x00lib,ixp4xx_npe
mac80211              133002  2 rt2x00usb,rt2x00lib
usbcore               139512  7 rt73usb,rt2500usb,rt2x00usb,usb_storage,ohci_hcd,ehci_hcd
Hier mit dem rt73 Modul:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
LKG9B4047:~# ifup wlan0
FATAL: Module p80211 not found.
Failed to load p80211.o.
run-parts: /etc/network/if-pre-up.d/linux-wlan-ng-pre-up exited with return code 1
LKG9B4047:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     RT73 WLAN  ESSID:"Christian"
          Mode:Managed  Frequency=2.412 GHz  Bit Rate=54 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-**
          Link Quality=0/100  Signal level:-121 dBm  Noise level:-115 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Quellcode

1
2
3
4
5
6
7
8
9
LKG9B4047:~# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:21:27:CC:0C:96
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::221:27ff:fecc:c96/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:2080 (2.0 KiB)

Quellcode

1
2
3
4
5
LKG9B4047:~# lsmod|grep rt
rt73                  241016  1
ledtrig_heartbeat       3104  0
firmware_class         10208  2 rt73,ixp4xx_npe
usbcore               139512  5 rt73,usb_storage,ohci_hcd,ehci_hcd

Anzeigen

warti

Forensupporter

Beiträge: 244

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

2

Freitag, 23. Januar 2009, 15:42

AW: RaLink RT73 auf Debian Etch And a Half

Schon http://www.nslu2-info.de/forum/showthread.php?t=6795 gesehen?

Ich glaub die Lösung ist/war eth0 und wlan0 zu vertauschen.
Hier mal meine "/etc/network/interfaces". Auch ich benutze den Treiber von serialmonkey.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet static
        pre-up ifconfig wlan0 up

        pre-up iwconfig wlan0 essid "APC"
        pre-up iwconfig wlan0 mode managed
        pre-up iwconfig wlan0 channel 4

        pre-up iwpriv wlan0 set AuthMode=WPAPSK
        pre-up iwpriv wlan0 set EncrypType=TKIP
        pre-up iwpriv wlan0 set WPAPSK="????????????????"
        pre-up iwpriv wlan0 set SSID="APC"

        address 192.168.1.123
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.1.1
        dns-search example.org

        post-up ifdown eth0


allow-hotplug eth0
iface eth0 inet static
        address 192.168.1.177
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.1.1
        dns-search example.org
~

Anzeigen

3

Freitag, 23. Januar 2009, 17:21

AW: RaLink RT73 auf Debian Etch And a Half

Hallo,
ja hab ich gelesen und auch so gemacht. Bin dann allerdings gar nicht mehr auf den NSLU2 gekommen. Ich hab dann erst mal nach dem booten die Ausgabe von ifconfig, iwconfig und route in eine Datei schreiben lassen. Bei ifconfig und route war alles ok, nur bei iwconfig das übliche Problem. Bei mir liegt es also nicht an der Routing-Tabelle sondern an der WLAN-Einrichtung.

Übrigens werden der rt73usb-Treiber geladen obwohl dieser in der blacklist ist. Auch rt2500, rt2500usb, rt2570, rt2x00usb und rt2x00lib sind in der blacklist. Und alle werden geladen. Ich muss sie erst per Hand entladen und danach den rt73 neu laden.

4

Samstag, 24. Januar 2009, 01:38

AW: RaLink RT73 auf Debian Etch And a Half

Ich hab mal das Packet firmware-ralink gelöscht. Danach musste ich dass Modul von serialmonkey neu bauen (habe dazu make arm benutzt) da ich sonst beim laden einen Segmention fault bekam. Jetzt geht das WLAN-Netz mit dem rt73 Modul sofort. Problem ist nur noch das beim booten standardmäßig die Module rt73usb, rt2500usb und rt73 geladen werden. Benutzt wird wohl rt73usb. Dabei sind wie gesagt alle Module außer rt73 in /etc/modprobe.d/blacklist eingetragen. Wie bekomm ich das geregelt?

EDIT:
Problem gelöst mittels Holzhammer:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
LKG9B4047:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interfacep

auto wlan0
iface wlan0 inet static
    pre-up modprobe -r rt73usb rt2500usb rt73
    pre-up modprobe rt73
    address 192.168.1.4
    netmask 255.255.255.0
    gateway 192.168.1.1
    wireless-mode managed
    wireless-essid Christian
    wireless-key open ***
    post-up route del default
    post-up route add default gw 192.168.1.1 wlan0

auto eth0
iface eth0 inet dhcp

Social Bookmarks