Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 30. Dezember 2008, 21:15

Streß mit Digitemp

Hallo Forum, ich habe Digittemp auf meiner Slaug mit Debian installiert. Wenn ich Digitemp aufrufe kommt die Fehlermeldung: You dont have +rw permisions to access. Ich habe schon die Berchtigungen mit chmod 777 gesetzt, aber kein Erfolg. Angemeldet als Root. Was kann ich tun?:confused:

Danke für Eure Hilfen
Uncle Det

Anzeigen

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

2

Dienstag, 30. Dezember 2008, 22:06

AW: Streß mit Digitemp

Nabend,

hast Du die digitemprc initialisiert und den Port gesetzt der benutzt werden soll?
Geht beispielsweise so:
digitemp_DS9097 -i -s /dev/ttyUSB0

Hat auch die .digitemprc die entsprechenden Berechtigungen?
In die .digitemprc werden die Initialisierungsdaten geschrieben beim Aufruf von digitemp.

Grüße
ToMa

Anzeigen

3

Donnerstag, 1. Januar 2009, 19:07

AW: Streß mit Digitemp

Also, irgenwie habe ich eine Digitempstreß Konfiguration. Im Verzeichnis /dev habe ich folgende USB Einträge:
usbdev1.1_ep00 usbdev2.11_ep81 usbdev3.1_ep00 usbdev3.2_ep81
usbdev1.1_ep81 usbdev2.11_ep83 usbdev3.1_ep81
usbdev2.11_ep00 usbdev2.1_ep00 usbdev3.2_ep00
usbdev2.11_ep02 usbdev2.1_ep81 usbdev3.2_ep02

Damit kann ich nichts anfangen. Ich habe eine 1Wire USB Adapter DS9490R
Der Adapter und der Sensor laufen definitiv unter Windows. Ich bin schon froh, das ich Hardwarefehler ausschließen kann.
Hier mein Aufruf:
digitemp_DS9097U -i -s /dev/ttyUSB0 -a -d 30 -n 0 -o 2
DigiTemp v3.3.2 Copyright 1996-2004 by Brian C. Lane
GNU Public License v2.0 - http://www.brianlane.com
Error, you don't have +rw permission to access /dev/ttyUSB0

Wie soll ich die USB Schnittstelle ( die obere der Slug) ansprechen?

Es existieren im System 3 Digitemp Treiber ( ich nenn es mal so):
digitemp_DS9097
digitemp_DS2490
digitemp_DS9097U

Ich weiß nicht was ich falsch mache. Vielleicht weiß jemand Rat.:confused:

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

4

Donnerstag, 1. Januar 2009, 22:37

AW: Streß mit Digitemp

Zitat von »Uncle Det;34056«

Also, irgenwie habe ich eine Digitempstreß Konfiguration. Im Verzeichnis /dev habe ich folgende USB Einträge:
usbdev1.1_ep00 usbdev2.11_ep81 usbdev3.1_ep00 usbdev3.2_ep81
usbdev1.1_ep81 usbdev2.11_ep83 usbdev3.1_ep81
usbdev2.11_ep00 usbdev2.1_ep00 usbdev3.2_ep00
usbdev2.11_ep02 usbdev2.1_ep81 usbdev3.2_ep02


Das ist ok.

Existiert denn auch /dev/ttyUSB0 ?
Wurde der Adapter von Debian erkannt?
Probier mal ein

Quellcode

1
dmesg | grep usb/serial


ToMa

5

Freitag, 2. Januar 2009, 13:44

AW: Streß mit Digitemp

Der Aufruf von dmesg... bringt keien Anzeige. Der Befehl wird ausgeführt das wars. In /dev ist kein USB Eintrag vorhanden, ( außer die oben genannten).
An einem USB Port der Slug hängt eine 2,5" USb Platte ( der untere Port).
Ich habe keine blassen Schimmer wie ich das Problem lösen kann. Was bewirkt denn der Befehl: dmesg | grep usb/serial ?
Uncle Det

Ich habe noch mal ein wenig gespielt, hier der AAufruf und das Ergebnis:

serverdet:/usr/bin# digitemp_DS9097 -i -s /dev/tty0
DigiTemp v3.3.2 Copyright 1996-2004 by Brian C. Lane
GNU Public License v2.0 - http://www.brianlane.com
Turning off all DS2409 Couplers

Searching the 1-Wire LAN
serverdet:/usr/bin#

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

6

Freitag, 2. Januar 2009, 17:03

AW: Streß mit Digitemp

Hallo,

das macht für mich ja den Eindruck, als ob der Adapter von Debian gar nicht erkannt wurde.

Probier mal:

Quellcode

1
dmesg | grep usb


Es sollte dir alles angezeigt werden, was an deinem USB Anschlüssen so gefunden wird.
Vielleicht fehlt noch ein Modul.

ToMa

7

Freitag, 2. Januar 2009, 20:23

AW: Streß mit Digitemp

Hier das Ergebnis Deines Befehls:
serverdet:~# dmesg | grep usb
usb 2-1: USB disconnect, address 5
usb 2-1: new full speed USB device using ohci_hcd and address 6
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: pl2303 converter now attached to ttyUSB0
usb 2-1: USB disconnect, address 6
usb 2-1: new full speed USB device using ohci_hcd and address 7
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: USB disconnect, address 7
usb 2-1: new full speed USB device using ohci_hcd and address 8
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: pl2303 converter now attached to ttyUSB0
usb 2-1: USB disconnect, address 8
usb 2-1: new full speed USB device using ohci_hcd and address 9
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: USB disconnect, address 9
usb 2-1: new full speed USB device using ohci_hcd and address 10
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: pl2303 converter now attached to ttyUSB0
usb 2-1: USB disconnect, address 10
usb 2-1: new full speed USB device using ohci_hcd and address 11
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: USB disconnect, address 11
usb 2-1: new full speed USB device using ohci_hcd and address 12
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: usbfs: interface 0 claimed by DS9490R while 'digitemp_DS2490' sets conf ig #1

Gibt es denn ein Treiber für Debian für den DS9490R ?
Modprobe ds9490r ergibt folgendes:
serverdet:~# modprobe ds9490r
FATAL: Module ds9490r not found.

Wie komme ich an das Modul?
Gibt es eine neuere Kernelversion? hier mein Stand:
2.6.18-6-ixp4xx #1 Thu Oct 16 01:45:43 UTC 2008 armv5tel

Uncle Det

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

8

Freitag, 2. Januar 2009, 21:03

AW: Streß mit Digitemp

Hallo,

das Modul heisst pl2303.
Mach doch mal ein
lsmod
oder ein:
cat /proc/modules
Falls pl2303 dort bei den geladenen Modulen nicht auftaucht mach mal ein:
depmod -a
modprobe -v pl2303

Sollte eigentlich sowas erscheinen:
insmod /lib/modules/2.6.18-6/kernel/drivers/usb/serial/usbserial.ko
insmod /lib/modules/2.6.18-6/kernel/drivers/usb/serial/pl2303.ko

ToMa

9

Freitag, 2. Januar 2009, 21:12

AW: Streß mit Digitemp

Danke erst mal für die geduldige Betreuung, hier die Ergebnisse:

serverdet:/usr/bin# cat /proc/modules
pl2303 19876 0 - Live 0xbf135000
usbserial 32688 1 pl2303, Live 0xbf12c000
ledtrig_heartbeat 3040 0 - Live 0xbf0a7000
ipv6 269672 12 - Live 0xbf0e9000
dm_snapshot 17180 0 - Live 0xbf0e3000
dm_mirror 20948 0 - Live 0xbf0dc000
dm_mod 59120 2 dm_snapshot,dm_mirror, Live 0xbf0cc000
rtc_dev 7432 0 - Live 0xbf0c9000
ixp4xx_mac 19572 0 - Live 0xbf0c3000
ds2490 8928 0 - Live 0xbf0bf000
wire 25320 1 ds2490, Live 0xbf0b7000
evdev 10400 0 - Live 0xbf0b3000
cn 9536 1 wire, Live 0xbf0af000
ixp4xx_qmgr 8652 5 ixp4xx_mac, Live 0xbf0a9000
ixp4xx_npe 14368 2 ixp4xx_mac, Live 0xbf0a2000
firmware_class 10656 1 ixp4xx_npe, Live 0xbf09e000
ixp4xx_beeper 3616 0 - Live 0xbf026000
ext3 137704 1 - Live 0xbf07b000
jbd 59368 1 ext3, Live 0xbf06b000
mbcache 9188 1 ext3, Live 0xbf067000
sd_mod 19248 3 - Live 0xbf061000
usb_storage 77899 2 - Live 0xbf04c000
scsi_mod 102800 2 sd_mod,usb_storage, Live 0xbf031000
ehci_hcd 31240 0 - Live 0xbf028000
ohci_hcd 17156 0 - Live 0xbf020000
usbcore 126920 7 pl2303,usbserial,ds2490,usb_storage,ehci_hcd,ohci_hcd, Live 0xbf000000
serverdet:/usr/bin# modprobe -v pl2303
Der Modprobe scheint nichts zu bewirken. Es ist zumindest nichts zu sehen.
Ich muß noch dazusagen, das ich zu Testzwecken eine USB-Serial Wandler am System hatte. Vielleicht deswegen die Anzeige des pl2303.

Uncle Det

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

10

Freitag, 2. Januar 2009, 21:34

AW: Streß mit Digitemp

Genau, hast Recht - Dein 1-wire Adapter braucht scheinbar den DS9490R.
Ich glaub aber der wird so direkt vom Kernel nicht unterstützt.

Kennst Du das schon?

ToMa

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

11

Freitag, 2. Januar 2009, 21:39

AW: Streß mit Digitemp

Aber warum bleibst Du nicht bei dem usb2serial - Adapter, wenn du sowieso mit digitemp messen willst?
Der usb2serial - Adapter mit pl2303 läuft problemlos.
Oder willst du auf owfs umsteigen und bevorzugst deshalb den 1-wire Adapter?
ToMa

12

Dienstag, 6. Januar 2009, 21:12

AW: Streß mit Digitemp

Hallo Forum und besonderen Dank an ToMa. Problem ist gelöst. :)
Ich habe mir von der Firma Fuchs einen anderen USB 1Wire Adapter geholt, der problemlos unterstützt wird. Treiberaufruf: digitemp_DS9097U.... mit entsprechenden Optionen..
Und hier noch der Link für Kaufinteressenten:
http://www.fuchs-shop.com/de/shop/18/

Nochmals besten Dank für die Hilfe. Ich werde bestimmt noch öfter nerven. Da tut gleich die nächste Frage auf, wie die gemessen Temperaturen verarbeiten und z. Bsp. eine Pumpe ( Solarsteuerung ) schalten?
Aber ich glaube das sollte dann ein neues Thema werden.:rolleyes:

Uncle Det

ToMa

Fortgeschrittener

Beiträge: 253

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Ostwestfalen

Beruf: FISI

  • Nachricht senden

13

Mittwoch, 7. Januar 2009, 10:57

AW: Streß mit Digitemp

Hallo,

guck Dir doch diesen Beitrag mal an.

Ganz unten wird die Verwendung einer Steckdosenleiste beschrieben.

ToMa

14

Mittwoch, 7. Januar 2009, 20:44

AW: Streß mit Digitemp

Alle Vorschläge haben leider nicht zum Erfolg geführt. Ich wollte endlich mal was messen, was mir dann kit dem "neuen" Adapter auch gelungen ist. Der andere Adapter ist definitv in Ordnung ( unter Windows und sicherlich auch unter Linux) Hätte jemand Interesse daran? Er ist erst ein paar Wochen alt und zu schade zum Verstauben.

Uncle Det

Social Bookmarks