Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

kandie

Schüler

  • »kandie« ist der Autor dieses Themas

Beiträge: 51

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

1

Montag, 13. Oktober 2008, 08:38

Umlaute bei Apache2, Samba, Mediatomb

Hi.

Musste mein Mediatomb neu Aufsetzen, leider habe ich seitdem ein Umlaute Problem bei Apache2 und Samba. Wenn ich über Total Commander (Netzlaufwerk) auf dem Server einen Umlaut setze zeigt er mir nur Müll über FTP an. Wenn ich allerdings über FTP einen Umlaut setze zeigt er ihn mir auch an aber dann nicht über Total Commander. Ein Verzeichniss mit Umlauten ändert er nie auch wenn er es mir über FTP mit ä ö ü anzeigt, sobald ich in das Verz. möchte bringt er mir sowas: ä als Verzeichnissnamen und zeigt mir keine Dateien im Ordner an. Wie bekomme ich es hin das ich egal von wo ich was ändere er die Umlaute auch ordentlich anzeigt? Habe bis jetzt in der smb.conf und /etc/apache2/conf.d/charset diverse Einstellungen probiert.
Mit sudo dpkg-reconfigure locales habe ich iso8859-1, iso8859-15@euro und utf-8 "installiert". Kann mir das irgendjemand helfen?


mfg matse

Nachtrag: Habe es jetzt hinbekommen das er mir über jedes Programm die Umlaute anzeigt, für Dateien und Ordner. Das einzige Problem was ich immernoch habe ist das wenn ich in den Ordner "1ä" rein möchte er auf "1ä" zugreifen möchte. Sind Ordner und Datei Umlaute etwas anderes?

Anzeigen

kandie

Schüler

  • »kandie« ist der Autor dieses Themas

Beiträge: 51

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

2

Montag, 13. Oktober 2008, 20:01

AW: Umlaute bei Apache2, Samba, Mediatomb

hat den keiner eine Idee?

Anzeigen

3

Mittwoch, 15. Oktober 2008, 09:09

AW: Umlaute bei Apache2, Samba, Mediatomb

Mach dich mal schlau über den Befehl convmv - http://linuxwiki.de/convmv (mit Konvertier-alles-auf-einmal-Skript). Nie probiert, nie getestet. Aber dennoch mal viel Erfolg. :)

kandie

Schüler

  • »kandie« ist der Autor dieses Themas

Beiträge: 51

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

4

Mittwoch, 15. Oktober 2008, 11:42

AW: Umlaute bei Apache2, Samba, Mediatomb

Ja mit convmv hatte ich auch schon gespielt.
Da ich durch die ganzen Charset Änderungen in Apache1+2, Samba3 und Mediatomb dann doch meine Codierung der Dateien verloren hatte und er mir egal was ich einstellte nur noch Schrott angezeigt hat.

Aber ich glaube das Problem ist gelöst. Wie ich ja schon geschrieben hatte zeigte er mir über Apache, Samba und SFTP (WinSCP) die Codierung richtig an nur leider das mit dem Verz.-wechsel nicht. Da Firefox mein Standartbrowser ist habe ich mir auch nie Gedanken gemacht, bis mir eingefallen ist das ich letztens ein Update auf 3.0.3 gemacht habe. Also habe ich mir das mal mit dem Internet Explorer angeschaut, siehe da ich komme in das Verz. und er zeigt mir auch die Dateien darin an. Oben steht zwar als Info in welchem Verz. ich mich befinde und da zeigt er es mir immernoch falsch an, aber das stört mich nicht. Hauptsache ich sehe die Dateien im Verz. Hab mal alle die ein FTP Zugang zu meinem Server haben drauf geschickt...alle die ein FTP Programm benutzen oder es über Windows Netzwerk machen hatten keine Probleme.

Jetzt werde ich mich mal dran machen meine ganzen Mediendateien und Playlisten mit Umlauten neu in Mediatomb einzulesen. Das Fragezeichen im Interpret bzw. Titel sollte mich nicht stören.

mfg matthias

Social Bookmarks