Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

1

Mittwoch, 2. April 2008, 15:13

Swap auf zweite PLatte?

Hallo zusammen,

ist es eigentlich möglich, die Swap-Partition auf einer zweiten Platte zu betreiben.
Hintergrund:
1. Wenn das OS auf dem Stick sitzt, könnten die Zugfriffe reduziert werden.
2. Wenn die SWAP auf einer anderen Platte sitzt, könnten die Zugriffszeiten verbessert werden.

Lieg ich hier ganz falsch? Geht das?

Viele Grüße,
Dremus.

Anzeigen

2

Mittwoch, 2. April 2008, 20:21

Ich habe den swap auf einem anderen Stick, den die Slug von mir aus mit der Zeit kaputtflashen kann. Das ist kein Problem. Festplatten mit Datenpartitionen kann man dann gut mit hd_idle schlafen legen. Bis auf den Stick mit dem rootfs hängen alle anderen an einem gepowerten usb-hub.
Damit man beim mounten nicht durcheinander kommt, empfehle ich Dir mounten mit LABELs. Dazu gibt es hier im Forum eine Diskussion / Anleitung. Benütze die Suche!

Anzeigen

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

3

Donnerstag, 3. April 2008, 21:15

Hallo heinrichh
Wie hast Du das mit der SWAP gemacht?
In meiner fstab hat gestanden:

Quellcode

1
2
3
4
5
...
/dev/sda2    none        swap    sw        0    0
...
/dev/sda2    /media/usb1    auto    rw,user,noauto    0    0
...
Für die Platte sagt dmesg:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
...
SCSI device sdc: 625142448 512-byte hdwr sectors (320073 MB)
sdc: Write Protect is off
sdc: Mode Sense: 00 00 00 00
sdc: assuming drive cache: write through
SCSI device sdc: 625142448 512-byte hdwr sectors (320073 MB)
sdc: Write Protect is off
sdc: Mode Sense: 00 00 00 00
sdc: assuming drive cache: write through
 sdc: [COLOR=Red]sdc1[/COLOR] [COLOR=Red]sdc2
...[/COLOR]
Also habe ich in der fstab entsprechend geändert:

Quellcode

1
2
3
4
5
...
/dev/sdc2    none        swap    sw        0    0
...
/dev/sdc2    /media/usb1    auto    rw,user,noauto    0    0
...
Hast Du das auch so gemacht? Oder habe ich hier was nicht begriffen?

Viele Grüße,
Dremus.

Nachtrag:
Wenn ich 'fdisk -l' eingebe, zeigt mir das System an:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Disk /dev/sda: 1007 MB, 1007681536 bytes
255 heads, 63 sectors/track, 122 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         106      851413+  83  Linux
/dev/sda2             107         122      128520   82  Linux swap / Solaris

Disk /dev/sdc: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1       38848   312046528+  83  Linux
/dev/sdc2           38849       38913      522112+  82  Linux swap / Solaris

Also scheint doch nach wie vor die SWAP auf dem Stick zu laufen, oder?
Viele Grüße,
Dremus.
__________
Debian 5.0.10 auf Kingston Data Traveler 2 GB; CUPS 1.3.8; SAMBA 3.2.5; TWONKY 6.0.39;
MEDION 1 TB;
Samsung CLX-3175; Samsung ML-1660; LG GSA-5120D

4

Freitag, 4. April 2008, 11:06

Hallo Dremus,

fdisk -l zeigt Dir nur die Partitionen auf den angeschlossenen Laufwerken an, aber nicht, ob und wie sie vom System verwendet werden. Das zeigt Dir der Befehl 'mount' an, wobei das Ergebnis von mount dem in der /etc/fstab eingetragenen Einstellungen entsprechen sollte (außer es hat beim mounten Probleme gegeben).

Wenn ich das richtig verstehe, möchtest Du, daß der swap auf der sdc benutzt wird, richtig? Dann stimmen Deine Eintragungen in der fstab, vorausgesetzt Du hast den Eintrag für /dev/sda2 gelöscht oder auskommentiert.

Wenn Du die sda1 allerdings als ext3-Filesystem gemountet hast, sehe ich keinen Sinn in Deinem Vorhaben, im Gegenteil: Wegen der ständigen Aktualisierung des Journals läuft die sda ständig und die sdc wegen der Nutzung als swap. Da brauchst Du hd_idle garnicht erst installieren.

Wenn es beides Sticks sind, würde ich auf sdc keine anderen Daten 'lagern', weil der hält bestimmt nicht ewig. Also nur die swap-Parition nutzen. Und sda1 als ext2 (ohne Journal) mounten.

So sieht meine fstab aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
LABEL=rootfs    /               ext2    noatime,errors=remount-ro 0     1
# /dev/sda6     /               ext2    noatime         0       1
# /dev/sda1     /boot           ext2    noatime         0       2
LABEL=bootfs    /boot           ext2    noatime         0       2
LABEL=bigswap   none            swap    sw              0       0
/dev/sda1       /media/usb0     auto    rw,user,noauto  0       0
/dev/sda2       /media/usb1     auto    rw,user,noauto  0       0
/dev/sda5       /media/usb2     auto    rw,user,noauto  0       0
/dev/sda6       /media/usb3     auto    rw,user,noauto  0       0
LABEL=backup    /backup         ext2    noatime         0       2
LABEL=home      /home           ext2    noatime         0       2


sda war ursprünglich mal ohne Label gemountet, hab das einfach mal drin gelassen. Wenn Du mehrere Laufwerke verwendest, ist das mounten mit Labels wirklich empfehlenswert. Die Nummerierung sda sdb sdc usw. hängt nach meiner Erfahrung davon ab, wann ein Laufwerk zu Verfügung steht nach dem booten, also davon, wann ein Laufwerk hochgefahren und bereit ist.

Ich habe 2 Sticks und zwei Platten im System und mir ist es tatsächlich schon mal passiert, daß die Slug nicht hochgefahren ist, weil Sie auf der Backup-Platte nach den Systemdateien gesucht hatte. In dem Fall muß man alle anderen Platten abstecken, neu booten und per Hand mounten. Spätestens dann wird man gerne per Label monten ;)

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

5

Freitag, 4. April 2008, 18:05

Hallo heinrichh,
also, jetzt, wo Du's sagst, fällt mir das mit dem Journal auf ext3-Partitionen auch wieder ein. Dann werd' ich mal auf ext2 umändern (gut, daß ich mir ein Abbild der Installation angelegt habe ...). Und sdc ist eine ext. Platte mit 320 GB.
Es würde dann bei mir verbleiben:
Ein Stick (derzeit sda1) mit dem OS
Ein Platte mit zwei Partitionen (derzeit noch sdc1 und sdc2) für
- Daten und
- SWAP.
Das ist doch eigentlich ganz überschaubar. Aber ich werde mich mit dem Thema Labels mal auseinandersetzen. Melde mich ggf. demnächst noch mal (Jetzt kommt ein gaanz laanges Wochenende ..)

Danke und viele Grüße,
Dremus.
Viele Grüße,
Dremus.
__________
Debian 5.0.10 auf Kingston Data Traveler 2 GB; CUPS 1.3.8; SAMBA 3.2.5; TWONKY 6.0.39;
MEDION 1 TB;
Samsung CLX-3175; Samsung ML-1660; LG GSA-5120D

6

Freitag, 4. April 2008, 22:58

Hi,

Quellcode

1
cat /proc/swaps
-> Zeigt die Swap Nutzung an

in der fstab sollte man die Swap-Partition nur als Swap eintragen, warum der Debian Installer (nehme ich mal an) die Swap-Partition zusätzlich noch nach /media/sdXn mounten will, kann ich nicht nachvollziehen.

Die ext3 Partition musst du nicht neu formatieren, es reicht völlig aus, wenn du sie in der /etc/fstab als ext2 statt ext3 angibst. Dadurch wird das journaling deaktiviert - der Rückwärtskompatibilität von ext3 zu ext2 sei Dank.

Deinen Stick kannst du übrigens ohne Datenverlust umpartitionieren(Linux-Live CD oder Linux Installation am PC vorrausgesetzt):
Backup vorher anlegen(Der Stick kann u.U. statt sda auch sdb oder ähnlich heissen, dmesg sollte dir den Namen nennen)

Quellcode

1
dd if=/dev/sda of=/pfad/zur/sicherung/sda.img

(Restore würde so gehen):

Quellcode

1
dd if=/pfad/zur/sicherung/sda.img of=/dev/sda


Dann umpartitionieren: (fdisk / cfdisk)
1. Die Swap-Partition (sda2) löschen
2. Die ext3-Partition (sda1) löschen
3. Eine neue Partition anlegen (über den kompletten Stick)
4. Änderungen speichern

Quellcode

1
resize2fs /dev/sda1

Fertig.

Gruss,
EvilDevil

7

Sonntag, 6. April 2008, 22:43

Zitat von »EvilDevil;31681«


in der fstab sollte man die Swap-Partition nur als Swap eintragen, warum der Debian Installer (nehme ich mal an) die Swap-Partition zusätzlich noch nach /media/sdXn mounten will, kann ich nicht nachvollziehen.



Stimmt, da habe ich eigentlich noch nie drauf geachtet. Ist total überflüssig. Und ich meine, das war der Debian-Installer, ich habe das bestimmt nicht extra in die fstab eingefügt!

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

8

Donnerstag, 10. April 2008, 18:56

Hallo zusammen,
danke für Eure Hilfe. Bin wieder zurück und eifrig am testen. Habe jetzt also den Stick auf ext2 laufen und die SWAP in der fstab für sdc2 eingetragen.'mount' zeigt an:

Quellcode

1
2
3
4
5
6
7
8
9
/dev/sda1 on / type ext2 (rw,noatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/sdc1 on /home type ext2 (rw,noatime)
Das mit den LABELS lass ich erst noch.

BTW: Ich habe einen externen Brenner angeschlossen und möchte sichergehen, daß CD's und DVD's auch gemountet werden, wenn ich welche einlege. Dazu hatte ich mir meine SuSE-fstab angesehen und nach udev u.ä. gesucht. Ich sehe jetzt bei 'mount', daß eine ganze Menge (sysfs, udev, devpts, procbususb und tmpfs) mitgemountet wird, ohne daß es in der fstab eingetragen ist. Wird denn also mein externes Laufwerk auch antsprechend bei Bedarf mitgemountet??

EvilDevil, ich habe danach mal 'cat /proc/swaps' eingegeben. Ergebnis:

Quellcode

1
2
Filename                                Type            Size    Used    Priority
/dev/sdc2                               partition       522104  0       -1
Bedeutet [used 0], daß die SWAP-Partition nicht in Benutzung ist?

Viele Grüße,
Dremus.
Viele Grüße,
Dremus.
__________
Debian 5.0.10 auf Kingston Data Traveler 2 GB; CUPS 1.3.8; SAMBA 3.2.5; TWONKY 6.0.39;
MEDION 1 TB;
Samsung CLX-3175; Samsung ML-1660; LG GSA-5120D

djk1o

Fortgeschrittener

Beiträge: 332

Wohnort: Berlin

Beruf: Programmierer/Designer

  • Nachricht senden

9

Freitag, 11. April 2008, 10:35

sieht ganz danach aus als ob dein swap nicht aktiv ist. eine zeile wie "LABEL=swapspace none swap sw 0 0" sollte in deiner fstab vorhanden sein, dann ist swap auch aktiv, vorrausgesetzt du hast den 'mkswap /dev/sdXx -L=swapspace' vorher richtig benutzt
NSLU2 (Debian Etch) 266MHz - fantec LD-U35U2 (160GB Maxtor) - 2,5" Samsung 100GB - Canon iP5200 - Acer Bluetooth - gLCD - NFS (dbox2) - Samba (2x Notebook; 1 PC) - CUPS - rTorrent (xmlrpc) - ntp - lighttp + php

10

Freitag, 11. April 2008, 14:17

Schließe mich djk1o an, used = 0 ist doch etwas ungewöhnlich. Selbst wenn das System aktuell keinen Swap benötigt, weil der physikalische Speicher ausreicht, ist bei mir immer was im Swap - und wenns nur 900 kBytes sind. Mount hilft hier nicht weiter, weil dieser Befehl nicht den Swap angibt.

Was djk1o für das mounten von Swap in der fstab schreibt, gilt natürlich auch für ohne Labels. Da heißts halt dann statt dessen z.B. /dev/sda2 usw.

Vielleicht schaust Du auch mal in das Boot-Log. Da steht vielleicht drin, warum dein Swap nicht aktiviert ist.

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

11

Samstag, 12. April 2008, 18:29

Hallo, Ihr beiden,
habe jetzt in der Datei /var/log/messages folgende Einträge gefunden:

Quellcode

1
2
3
4
5
6
7
8
...
Apr 12 19:33:23 LKG8A7174 kernel: [COLOR=Red]swapped image found[/COLOR]
Apr 12 19:33:23 LKG8A7174 kernel: Image loaded to NPE-B Func:0, Rel: 2:1, Status: 82c00000
Apr 12 19:33:23 LKG8A7174 kernel: IXP4XX NPE driver Version 0.3.0 initialized
Apr 12 19:33:23 LKG8A7174 kernel: IXP4XX Q Manager 0.2.1 initialized.
Apr 12 19:33:23 LKG8A7174 kernel: ixp4xx_mac driver 0.3.1: eth0 on NPE-B with PHY[1] initialized
Apr 12 19:33:23 LKG8A7174 kernel: [COLOR=Red]Adding 522104k swap on /dev/sdc2[/COLOR].  Priority:-1 extents:1 across:522104k
...
Dann scheint doch die SWAP-Partition erkannt und eingebunden - aber eben z.Zt. nicht genutzt zu sein, oder?

Viele Grüße,
Dremus.
Viele Grüße,
Dremus.
__________
Debian 5.0.10 auf Kingston Data Traveler 2 GB; CUPS 1.3.8; SAMBA 3.2.5; TWONKY 6.0.39;
MEDION 1 TB;
Samsung CLX-3175; Samsung ML-1660; LG GSA-5120D

12

Samstag, 12. April 2008, 20:28

Hi,

meine /proc/swaps (Compaq Evo N620c, Pentium M 1,6 GHz, 2GB RAM, komplett AES verschlüsselte Platte mit LVM Partitionierung, 3 GB Swap):

Quellcode

1
2
3
ps@evo:~$ cat /proc/swaps 
Filename                Type        Size    Used    Priority
/dev/mapper/evo-swap_1                  partition    3219448    0    -1
Swap ist aktiv, wird aber nicht genutzt, hier deaktiviere ich den Swap:

Zitat

ps@evo:~$ sudo swapoff /dev/mapper/evo-swap_1
Und meine /proc/swaps danach:

Quellcode

1
2
ps@evo:~$ cat /proc/swaps 
Filename                Type        Size    Used    Priority
Und Swap wieder aktivieren:

Quellcode

1
2
3
4
5
6
ps@evo:~$ sudo swapon /dev/mapper/evo-swap_1 
ps@evo:~$ cat /proc/swaps 
Filename                Type        Size    Used    Priority
/dev/mapper/evo-swap_1                  partition    3219448    0    -2
ps@evo:~$ dmesg |tail -n 1
[ 1859.200603] Adding 3219448k swap on /dev/mapper/evo-swap_1.  Priority:-2 extents:1 across:3219448k
Also ist mit deinem Swap alles in Ordnung, die NSLU2 benutzt ihn einfach (noch) nicht, weil alles in den RAM passt.

Gruß,
EvilDevil

PS: Mein Netgear WGT634U Router (mit USB) benutzt seinen Swap auch nicht:

Quellcode

1
2
3
4
5
6
7
8
root@wgt:~# free
              total         used         free       shared      buffers
  Mem:        29992         9492        20500            0          260
 Swap:        31240            0        31240
Total:        61232         9492        51740
root@wgt:~# cat /proc/swaps 
Filename                Type        Size    Used    Priority
/jffs/dev/sda2                          partition    31240    0    -1

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

13

Montag, 14. April 2008, 13:43

Hallo EvilDevil,
habe jetzt hin und wieder mal hingeschaut: SWAP wird genutzt, wenn auch selten und in erstaunlich geringer Größe.

z.Thema umpartitionieren:
Ich habe verschiedenes ausprobiert: Wenn ich den Stick (eine Partition) mit ext2 formatiere und anschließend mein Sicherungsimage (das ja unter mal auf einer ext3-Partition entstanden ist) zurückspiele, dann hat der Stick wieder eine ext3-Partition (die natürlich über die fstab als ext2 eingebunden ist). Die Dateien einfach auf eine ext2-Partition &quot;rüber-&quot;kopieren geht auch nicht, weil sich die Dateien in /dev/... nicht kopieren lassen.
Und wenn ich meine Sicherungskopie (ca. 750 MB Daten auf einem 1GB-Stick; erzeugt mit partimage) auf einen 2GB-Stick zurückspiele, dann sind dort plötzlich ca 1,5GB belegt. Komisch, oder ...?

@alle
was ich letztens mit meiner Frage nach der Erkennung des externen Brenners bezweckt hatte, ist mittlerweile erledigt. Das Gerät war ja grundsätzlich erkannt worden und der Konfigurationsdialog des Brennprogramms (webCDwriter) hat einen Eintrag für die fstab vorgeschlagen:

Quellcode

1
/dev/scd0    /media/cdrom0    udf,iso9660    noauto,utf8    0     0
Damit ist das Gerät so eingebunden, daß ich CD's übers Netz brennen kann.

Viele Grüße,
Dremus
Viele Grüße,
Dremus.
__________
Debian 5.0.10 auf Kingston Data Traveler 2 GB; CUPS 1.3.8; SAMBA 3.2.5; TWONKY 6.0.39;
MEDION 1 TB;
Samsung CLX-3175; Samsung ML-1660; LG GSA-5120D

14

Dienstag, 15. April 2008, 11:40

Zitat von »Dremus;31944«


z.Thema umpartitionieren:
Ich habe verschiedenes ausprobiert: Wenn ich den Stick (eine Partition) mit ext2 formatiere und anschließend mein Sicherungsimage (das ja unter mal auf einer ext3-Partition entstanden ist) zurückspiele, dann hat der Stick wieder eine ext3-Partition (die natürlich über die fstab als ext2 eingebunden ist).

Wenn die ext3 Partition als ext2 gemountet wird, ist das alles kein Problem, es sei denn, du störst dich daran, dass da ext3 statt ext2 dransteht... ;)

Zitat

Die Dateien einfach auf eine ext2-Partition &quot;rüber-&quot;kopieren geht auch nicht, weil sich die Dateien in /dev/... nicht kopieren lassen.
Das ist richtig, /dev/ ist bei modernen Linux-Systemen ein Dateisystem im RAM, das von udev und co verwaltet wird und bei jeden Systemstart neu gefüllt wird, genauso wie /sys und /proc
Wenn du trotzdem die Dateien kopieren möchtest, sei dir http://www.tldp.org/HOWTO/Hard-Disk-Upgrade/index.html ans Herz gelegt :cool:

Zitat

Und wenn ich meine Sicherungskopie (ca. 750 MB Daten auf einem 1GB-Stick; erzeugt mit partimage) auf einen 2GB-Stick zurückspiele, dann sind dort plötzlich ca 1,5GB belegt. Komisch, oder ...?
Sind die Daten nach dem sichern mit partimage 750 MB groß, oder waren sie vorher schon so groß? Wenn unter Linux (bzw ext2/3) ein Programm 1GB Speicherplatz für eine Datei anfragt, wird die Datei in der "Dateisystemstabelle" mit 1 GB Größe eingetragen, aber nur der Speicherplatz, der wirklich belegt wird, wird auch benutzt... also wenn das Programm 1GB Speicher haben will, aber nur 500 MB nutzt, werden die anderen 500 MB als frei markiert und werden von partimage sinnvollerweise nicht kopiert.

Gruss,
EvilDevil

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

15

Dienstag, 15. April 2008, 20:29

Hallo EvilDevil,

Zitat von »EvilDevil;31962«

Wenn die ext3 Partition als ext2 gemountet wird, ist das alles kein Problem, es sei denn, du störst dich daran, dass da ext3 statt ext2 dransteht... ;)

Tja, manchmal ...
Also, ich habe mich umgetan und mußte feststellen, daß es zwar auch ein Tool für solche Operationen gibt (http://tzukanov.narod.ru/convertfs/), aber daß dessen Anwendung durchaus kritisch gesehen werden muß. Andererseits habe ich dann noch den Hinweis auf eine entsprechende Nutzung von tune2fs gefunden (http://www.linux-fuer-alle.de/doc_show.php?docid=121), und damit hatte ich dann, was ich wollte.

Zitat von »EvilDevil;31962«

Wenn du trotzdem die Dateien kopieren möchtest, sei dir http://www.tldp.org/HOWTO/Hard-Disk-Upgrade/index.html ans Herz gelegt :cool:
Danke, sowas kann man immer brauchen ... und die Erklärung davor war für mich auch mal bitter nötig.

Zitat von »EvilDevil;31962«

Sind die Daten nach dem sichern mit partimage 750 MB groß, oder waren sie vorher schon so groß?

Ich hatte partimage mit gzip-Kompression eingesetzt; der Stick (1GB) hatte zu dem Zeitpunkt etwa 590 MB Daten; nachdem ich diese Sicherungskopie (komprimiert waren das dann ca. 294 MB) mit partimage auf einen 2GB-Stick rückgespielt habe, waren daraus ca. 1,3GB an Daten geworden (und eben auch nur ca. 700 MB frei).
Jetzt habe ich mal die Partition (unkomprimiert, vom 1GB-Stick) mit dem Copy-Befehl in gparted auf einen freien Bereich meiner Festplatte gesichert; von dort aus habe ich diese dann widerum mit gparted auf den (leeren unpartitionierten) 2GB-Stick zurückgespielt und dann die dort erhaltene 1GB-Partition auf 2GB vergrößert. Jetzt habe ich auf dem Stick ca. 1,4GB frei. So sollte es sein.


Viele Grüße,
Dremus.
Viele Grüße,
Dremus.
__________
Debian 5.0.10 auf Kingston Data Traveler 2 GB; CUPS 1.3.8; SAMBA 3.2.5; TWONKY 6.0.39;
MEDION 1 TB;
Samsung CLX-3175; Samsung ML-1660; LG GSA-5120D

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

16

Mittwoch, 23. April 2008, 15:52

Hallo EvilDevil, hallo alle,
habe nach allerlei Neuinstallationen, 'fis erase ..' und 'kernelcommandline..' festgestellt, mein System fährt immer dann nicht hoch, wenn ich eine gelabelte SWAP-Partition auf zweiter PLatte dabei habe. Sobald ich die SWAP in der fstab wieder über ihr /dev/sdXx hochlade, läuft die Chause wieder.
Kann es sein, EvilDevil, daß Deine freundlichen Hinweise auf

Quellcode

1
2
3
swapoff -a
mkswap -L swapspace /dev/sdXx
swapon LABEL=swapspace
an irgendeiner Stelle noch um

Quellcode

1
sync; sync; sync
ergänzt werden müssen?
Wenn ich die ext. Platte direkt an einen Linux-PC anschließe und mir dort die Partitionen anzeigen lasse, dann haben alle Part. ein Label, nur die SWAP hat keins.
Viele Grüße,
Dremus.
Viele Grüße,
Dremus.
__________
Debian 5.0.10 auf Kingston Data Traveler 2 GB; CUPS 1.3.8; SAMBA 3.2.5; TWONKY 6.0.39;
MEDION 1 TB;
Samsung CLX-3175; Samsung ML-1660; LG GSA-5120D

Dremus

Schüler

  • »Dremus« ist der Autor dieses Themas

Beiträge: 60

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

17

Donnerstag, 24. April 2008, 14:48

Hallo zusammen,
jetzt geht's (auch noch mal gepostet hier): Die swap-Partition auf externer Platte kann ich zwar nach der von EvilDevil benannten Methode von Hand labeln, das Label ist aber nicht von Dauer (ggf. fehlendes sync.-Kommando??) Insofern sucht sich das System nach einem Reboot ein Hörnchen nach seinem 'swapspace'. Also habe ich für alle beteiligten Partitionen die UUID rausgesucht

Quellcode

1
ls -l /dev/disk/by-uuid
und für die SWAP entsprechend in die fstab eingetragen:

Quellcode

1
/dev/disk/by-uuid/833ec7a3-7f35-4c7e-9dc1-7b1608fe5fea    none    swap    sw        0    0
Wenn alle anderen Umstände günstig sind, geht's jetzt.

Viele Grüße,
Dremus.
Viele Grüße,
Dremus.
__________
Debian 5.0.10 auf Kingston Data Traveler 2 GB; CUPS 1.3.8; SAMBA 3.2.5; TWONKY 6.0.39;
MEDION 1 TB;
Samsung CLX-3175; Samsung ML-1660; LG GSA-5120D

Social Bookmarks