Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 31. März 2008, 00:04

Zydas USB WLAN mit Debian Lenny

Hallo!

Ich bekomme einfach einen TP-Link USB Stick (Zydas Chip) nicht zum laufen.
Ich habe zuerst auf Debian Etch mit selber kompilieren des Treibers (zd1211b) versucht, ohne Erfolg. :confused:

Nach einem Update auf Lenny kann ich den Stick erkennen und konfigurieren, allerdings klappt das mit WPA anscheinend noch nicht. Ich bekomme im wpa_cli folgenden Status:

<2>Authentication with 00:1c:10:12:6b:7a timed out.
<2>CTRL-EVENT-SCAN-RESULTS
<2>Trying to associate with 00:1c:10:12:6b:7a (SSID='meineID' freq=2462 MHz)
<2>Association request to the driver failed
<2>CTRL-EVENT-SCAN-RESULTS

Ich habe gelesen, dass der wpa_supplicant nicht mit dem Zydas zurechtkommt - aber alle Links zu diesem Thema bzw zu einer angepassten wpa_supplicant führen ins Leere.

Kann mir jemand helfen? Ich weiß nicht weiter...

Vielen Dank!

Hanno


Die Suche schon benuzt?: ja

Art der Firmware: Debian

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: USB-Stick 4GB

Anzeigen

2

Donnerstag, 3. April 2008, 20:59

versuche mal iwpriv direkt in der /etc/network/interfaces
so ähnlich sieht meine aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
auto wlan0 
iface wlan0 inet static
    #pre-up rmmod rt73
    pre-up iwpriv wlan0 set NetworkType=Infra
    pre-up iwpriv wlan0 set AuthMode=WPAPSK
    pre-up iwpriv wlan0 set EncrypType=TKIP
    pre-up iwpriv wlan0 set SSID="yyyyyyyy"
    pre-up iwpriv wlan0 set WPAPSK=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    pre-up iwpriv wlan0 set SSID="yyyyyyyy"
    address 192.168.0.50
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-search domus
    post-up route del default
    post-up route add default gw 192.168.0.1 wlan0
    post-up /usr/bin/beep -l 100 -f 12
Scovery xS - 1002MHz - RAM 512MB - HD 160GB - Debian Etch
In Planung: CarNSLU - 266MHz - RAM 32MB - Flash 2GB - USB-Extra-Ports - WLAN - USBAudio - GPS - Debian Etch

Anzeigen

3

Freitag, 4. April 2008, 11:11

Hallo!

Vielen Dank für den Tipp! Das habe ich auch schon versucht, allerdings erhalte ich dann die Meldung von iwpriv, dass das set wegen unbekanntem Kommando fehlschlägt. Bin leider gerade nicht zu Hause und habe den genauen Text nicht zur Hand.

Gruß
Hanno

djk1o

Fortgeschrittener

Beiträge: 332

Wohnort: Berlin

Beruf: Programmierer/Designer

  • Nachricht senden

4

Sonntag, 6. April 2008, 13:22

dann tausch doch mal das 'iwpriv' gegen ein 'iwconfig' aus...so wars bei mir jedenfalls beim rt2500 chipsatz erfolgreich :)
NSLU2 (Debian Etch) 266MHz - fantec LD-U35U2 (160GB Maxtor) - 2,5" Samsung 100GB - Canon iP5200 - Acer Bluetooth - gLCD - NFS (dbox2) - Samba (2x Notebook; 1 PC) - CUPS - rTorrent (xmlrpc) - ntp - lighttp + php

Social Bookmarks