Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Mittwoch, 20. Februar 2008, 17:42

Kann mich mit XP Prof nicht bei Samba anmelden, mit W98SE schon!

Hallo,

zunächst mal ein Lob auf diese Distribution. Läßt sich gut installieren, läuft zuverlässig und vor allem spürbar schneller als Unslug. Vor allem sind keine diversion-scripts nötig - das ist ja krank, wenn einem alle Änderungen (wie z.B. die smb.conf) beim Neustart zerschossen werden. Nun aber zum Problem:

An Samba bin ich am verzeifeln. Ich habe seit vielen Jahren ein Samba 2.2.0 auf einer Suse Distri laufen ohne Probleme. Er dient als Datei- und Druckerserver. Jetzt möchte ich auf das neue 3.0.? auf der Nlsu wechseln.
Alle Daten schon synchronisiert, Benutzer angelegt usw. und von den W98 Clients aus funktioniert alles wie früher, nur mit dem einzigen XP Prof. Client komme ich nun nicht mehr ins Samba rein. Beim alten Server war das ohne Problem.

Anfangs hatte ich auch Ärger mit den W98 Clients, was aber offensichtich an der Voreinstellungen in der Beispieldatei lag. Beim Aufruf von smbpasswd wurden die Benutzerkonten ich weiß nicht wo gespeichert, jedenfalls nicht in der Datei /etc/samba/smbpasswd. Hat einige Zeit gedauert, bis ich auf die Idee kam, nachzusehen, ob es die Datei überhaupt gibt - da war nur Leere. Aber das geht jetzt wie früher.

Ich poste hier mal den Base - Teil meiner smb.conf:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
[global]
        workgroup = PRIVAT
        interfaces = eth0 192.168.128.0/24
        bind interfaces only = yes
        server string = %h server
        unix charset = iso8859-15
        display charset = iso8859-15
        dos charset = cp850
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spa
        smb passwd file = /etc/samba/smbpasswd
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 100
        name resolve order = host wins bcast
        load printers = no
        dns proxy = no
        ldap ssl = no
        panic action = /usr/share/samba/panic-action %d
        invalid users = root
        hosts deny = 192.168.128.129, 192.168.128.130
        default case = upper
        case sensitive = no
        create mask = 0755
        socket options = TCP_NODELAY  IPTOS_LOWDELAY SO_SNDBUF=65535 SO_RCVBUF=
        preferred master = yes
        domain master = yes
        encrypt passwords = yes
        update encrypted = Yes
        bind interfaces only = yes
        domain logons = yes
        wins support = yes
        comment = /%S auf %h
        path = %S
        read only = no
        map archive = no
        auth methods = guest sam ntdomain trustdomain
Die war ursprünglich mal kürzer, aber ist mit der Zeit des Probierens immer länger geworden.

Wie gesagt, mit den W98SE-Clients kein Problem, nur Win XP Prof meldet mir: Auf \\ATT3 kann nicht zugegriffen werden. Sie haben eventuell keine Berechtigung usw.
Der Server wird aber in der Netzwerkumgebung mit dem in der base angegebenen server string angezeigt.

In den logs finde ich nix über den fehlgeschlagenen Versuch, sich anzumelden. Nur in winbindd.log wird überhaupt was fehlermäßig relevantes gemeldet:

Quellcode

1
2
3
4
5
6
[2008/02/20 17:30:49, 0] nsswitch/winbindd_util.c:winbindd_param_init(787)
  winbindd: idmap uid range missing or invalid
[2008/02/20 17:30:49, 0] nsswitch/winbindd_util.c:winbindd_param_init(788)
  winbindd: cannot continue, exiting.
[2008/02/20 17:30:49, 1] nsswitch/winbindd.c:main(986)
  Could not init idmap -- netlogon proxy only
Damit kann ich nix anfangen. Winbindd gab's vorher nicht.

Vielleicht kann mir ja jemand hier helfen!



was hast Du bereits probiert?: Zwei Tage das Net + usenet abgegoogelt, man-pages gelesen

Die Suche schon benuzt?: ja

Art der Firmware: Debian 2.6.18-6-ixp4xx

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: 2 * 160 GB Festplatten

Anzeigen

djk1o

Fortgeschrittener

Beiträge: 332

Wohnort: Berlin

Beruf: Programmierer/Designer

  • Nachricht senden

2

Mittwoch, 20. Februar 2008, 22:49

hey!
also ich würde mal sachen wie "hosts deny" und "bindings/interfaces" rausnehmen, vielleicht hilft es dir ja schon!? "auth methods" hab ich auch noch nicht benutzt...vielleicht soltest du das auch mal auskommentieren.
NSLU2 (Debian Etch) 266MHz - fantec LD-U35U2 (160GB Maxtor) - 2,5" Samsung 100GB - Canon iP5200 - Acer Bluetooth - gLCD - NFS (dbox2) - Samba (2x Notebook; 1 PC) - CUPS - rTorrent (xmlrpc) - ntp - lighttp + php

Anzeigen

3

Donnerstag, 21. Februar 2008, 11:10

Vielen Dank für Deine Hinweise. Hab ich probiert, aber hat nicht geklappt. Ich hab die global-Sektion dann auf das allernötigste zusammengeschrumpft.

Quellcode

1
2
3
4
5
6
7
8
        workgroup = PRIVAT
        netbios name = ATT3
        server string = %h server Samba 3.0.24
        unix charset = iso8859-15
        display charset = iso8859-15
        dos charset = cp850
        syslog = 4
        max log size = 100
Aber das half auch nix.


Spät in der Nacht hab ich dann den Fehler gefunden:

Samba agiert als WINS - Server (was ist das überhaupt?), auch wenn das nicht explizit angegeben ist. Bei allen Rechnern hatte ich zu Samba-2.2.0-Zeiten die IP des Samba-Rechners auch so in allen Clients bei den Netzwerkeinstellungen eingegeben. Beim Wechsel auf die NSLU hab ich für sie eine neue IP-Adresse verwendet, da Alt und Neu eine Zeit lang parallel laufen sollen. Diese neue Adresse hab ich aber leider nicht als neuen WINS-Server bei den Clients eigetragen. Und den W98-Clients war's irgendwie egal, aber WIN XP Prof nicht. Habe das dort nachgeholt und auf einmal gings!!

Hatte also nix mit Samba zu tun - so gesehen. Was ist das mit WINS überhaupt?

4

Freitag, 22. Februar 2008, 00:36

Hi,

WINS("Windows Internet Name Service") ist ein Service, der Rechnernamen zu IP-Adressen auflöst, ähnlich dem DNS. Sobald ein Rechner hochgefahren wird, meldet er sich beim WINS-Server mit seiner IP-Adresse und seinem Netbios (Computername unter der Windows-Systemeinstellung) Namen an. Falls dann ein anderer Rechner auf den neuen Rechner zugreifen will, fragt er den WINS-Rechner nach der IP-Adresse und bekommt sie zurückgeliefert. So ungefähr denke ich mal. Näheres weiss wohl auch nur Google oder Wikipedia ;)

Gruss,
EvilDevil

Social Bookmarks