Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 14. Oktober 2007, 17:43

Debian auf NSLU2 - gehtnicht?

Hallo alle zusammen!

Heute wollte ich Debian auf meine NSLU2 spielen.
Firmware habe ich schon vor einiger Zeit runtergeladen.

Aber zuerst meine Situation:
Die NSLU2 hängt an einem D-Linkrouter, andem noch 2 weitere PCs angeschlossen sind. Der Router lässt sie ins WWW passierne, und erkennt sie als PC. Dann wollte ich über meinen PC (einer von den beiden anderen am Router) mit upslug2 (nutze Debian) das .bin File draufspielen, erhalte jedoch immer die Meldung, das keine NSLU2 "In upgradmode" wäre.
Ich habe sie jedoch zuvor geflasht, und die Oberste Diode blinkt auch, wie in den Tutorials beschrieben.

Nun meine Fragen:

1) Was habe ich falsch gemacht (NSLU2 kann ins Netz, und ist in upgrademode, Firmware aktuell)?

2) was kann ich tun, um das Problem zu lösen, und ich endlich die neue Firmware draufpsielen kann?

3) Liegt es vielleicht daran, dass die NSLU2 am Router hängt, und ich an meinem PC, also dass sie nicht direkt mit meinem PC verbunden ist (PC ist ebenfalls mit Router verbunden)?

Dankeschön,
chris





Die Suche schon benuzt?: ja

Art der Firmware: momentan keine

Anzeigen

2

Sonntag, 14. Oktober 2007, 19:05

Hast du auch einen Windows Rechner. Dann könntest du es ja mal darüber mit dem Upgrade Tool probieren.

Zu deiner dirtten Frage kann ich nur sagen das ich es genau so mache habe meine Kiste schon X-mal geflasht und ich immer die PC-Router-SLUG kombi genutzt habe. Hat jedesmal wunderbar geklappt. Allerdings nutze ich Windows...


MFG

Anzeigen

3

Montag, 15. Oktober 2007, 00:27

Das Problem hatte ich damals auch - es lag' bei mir am Router (="SMC - Barricade").
Ich habe dann ein X-Over Kabel genommen (ca. 2,50 EUR) - und dann ging es. Eine andere Alternative wäre den Router für den Vorgang durch einen ganz einfache Hub zu ersetzen.
Das Problem ist m.E. nicht das verwendete OS sondern das manche Router da was an den gesendeten IP-Paketen verändern (NAT?) ...
Es verunsichert mich nur ein wenig, dass Du (wenn ich es richtig verstehe) bereits schon mal mit dieser Konstellation erfolgreich geflasht hast; und es jetzt nicht mehr geht.
Vielleicht hast Du zwischenzeitlich irgendwas an dem Router geändert?

Am besten das X-Over Kabel nehmen - dann hast Du auf jeden Fall schon mal eine Fehlerquelle mehr ausgeschaltet :)

4

Montag, 15. Oktober 2007, 06:21

@moo: Ja, ich hab auch Windows XP in Reserve, hab gestern schon probiert(!!) mit dem Windowstool zu arbeiten, aber der erkennt a) die NSLU nicht und b) Mag der meine Firmware(di-nslu2.bin) nicht.


@topgear: Ja, ich habe schonmal geflasht, allerdings war da die NSLU direkt mit meinem Notebook verbunden (Notebook benutzt WLAN, greift auf den gleichen Router zurück!, deshalb war eine Lanbuchse frei), was dann auch wunderbar ging. Ist dann nur am Installer gescheitert.

S]oll ich die NSLU mal an die Lanbuchse meines Notebooks (Ubuntu Feisty Fawn verwendet) stecken und dann nochmal per upslug?
(Wenn mein Notebook denn mal wieder booten könnte...Hab mir GRUB (den Bootloader) zerschossen, und war bis jetzt zufaul ^^ das zu reparieren. Männo! Ich hasse Grubconf Dateien!)

Dann soeit erstmal Vielen Dank,
chris

5

Montag, 15. Oktober 2007, 07:55

Ah! Du hast also damals das Notebook mit der NSLU2 über ein X-Over Kabel verbunden - das könnte ein Hinweis sein, dass Dein Router wirklich schuld ist.

Es gibt ja keinen Grund, dass Du während des Flashvorgangs unbedingt mit dem Internet verbunden sein musst. Schließ' die NSLU2 doch einfach direkt an Deinen Windows PC ...
Obwohl: Was bedeutet: "Mag der meine Firmware(di-nslu2.bin) nicht." Ist vielleicht nur das Image korrupt?

Wenn Du lieber mit einem "richtigen" Betriebssystem arbeiten willst -und- Du Dir lieber die Heilung von grub für lange Wintertage aufheben willst (diese Art der Faulheit kenne ich gut und ist mir sehr sympathisch :)) nimmt doch einfach ein Knoppix (o.ä.) ...

6

Montag, 15. Oktober 2007, 13:42

Ähm no. Ich hab einfach dasgenommen, was in der Packung war, also ein ganz normales LAN-Kabel.

Glaub nicht das es am Image liegt, ich konnte ja schonmal damit flashen.

Jetz bin ich wieder unter Debian, und ich müsste jetzt win booten. Schon komisch, seitdem Debian drauf ist, bootet manWin sogut wie nichtmehr :D

7

Montag, 15. Oktober 2007, 17:10

Ich kann mir zwar nicht vorstellen wie das mit einem normalen LAN Kabel funktionieren soll, aber egal: wenn's funktioniert ist doch alles gut.

Mit "das Image korrupt" habe ich mich etwas lax ausgedrückt: Ich meinte das File-Image der neuen "draufzuflashenden" Firmware (=di-nslu2.bin).
Da wo Du sie runtergeladen hast wird auch meist eine Prüfsumme (MD5, o.ä.) angegeben. Ich wollte Dich nur motivieren diese Prüfsummen miteinander zu vergleichen und so sicher zu stellen, dass das File "di-nslu2.bin" korrekt und heile ist.

Also ich würde es jetzt so machen:
Nimm' den Laptop; weil es damit schon mal funktioniert hat.
Laptop mit der NSLU2 verbinden und Laptop mit Knoppix booten. Wenn das mit dem WLAN nicht funktioniert kannst Du ja auch die nötigen Daten "von Hand" (sprich: USB-Stick, Diskette, o.ä.) übertragen - also das Firmware-Image und das Programm zum Flashen.

Und dann mal berichten ob Du flashen konntest ... Viel Glück!

Social Bookmarks