Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

banjo

Anfänger

  • »banjo« ist der Autor dieses Themas

Beiträge: 7

Firmwareversion / your current Firmware: Unslung 6.8

  • Nachricht senden

1

Dienstag, 9. Oktober 2007, 14:38

eaccelerator will nicht so recht beim installieren

Hallo Leute,

habe auch meiner Slug Debian mit Apache2 + PHP5 + MySQL. Wollte nun gerne eaccelerator installieren.
Habe es nach dieser Anleitung: http://rikman.mtb-news.de/archives/2005/…r-installieren/
kompiliert.
Hat auch scheinbar alles wunderbar geklappt.

nun bei 'make install' bekomme ich zum schluss folgende fehlermeldungen:

Quellcode

1
2
3
4
5
6
7
8
nslu2:/usr/src/eaccelerator-0.9.5-beta2# make install
/bin/sh /usr/src/eaccelerator-0.9.5-beta2/libtool --mode=compile gcc  -I. -I/usr/src/eaccelerator-0.9.5-beta2 -DPHP_ATOM_INC -I/usr/src/eaccelerator-0.9.5-beta2/include -I/usr/src/eaccelerator-0.9.5-beta2/main -I/usr/src/eaccelerator-0.9.5-beta2 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2   -c /usr/src/eaccelerator-0.9.5-beta2/eaccelerator.c -o eaccelerator.lo
 gcc -I. -I/usr/src/eaccelerator-0.9.5-beta2 -DPHP_ATOM_INC -I/usr/src/eaccelerator-0.9.5-beta2/include -I/usr/src/eaccelerator-0.9.5-beta2/main -I/usr/src/eaccelerator-0.9.5-beta2 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -c /usr/src/eaccelerator-0.9.5-beta2/eaccelerator.c  -fPIC -DPIC -o .libs/eaccelerator.o
/usr/src/eaccelerator-0.9.5-beta2/eaccelerator.c: In function 'eaccelerator_store_int':
/usr/src/eaccelerator-0.9.5-beta2/eaccelerator.c:768: error: 'align_test' undeclared (first use in this function)
/usr/src/eaccelerator-0.9.5-beta2/eaccelerator.c:768: error: (Each undeclared identifier is reported only once
/usr/src/eaccelerator-0.9.5-beta2/eaccelerator.c:768: error: for each function it appears in.)
make: *** [eaccelerator.lo] Error 1


hat jemand eine ahnung wie ich das rätsel lösen kann und den eaccelerator ordnungsgemäß installiert und zum laufen kriege?

danke im voraus.


gruß banjo


was hast Du bereits probiert?: nach den fehlern gegoogled, leider erfolglos :(

Die Suche schon benuzt?: ja

Art der Firmware: debian 4.0rc1

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: disk2 sandisk usb-stick 2GB / disk1 maxtor personal storage 3200 500GB

Anzeigen

2

Dienstag, 9. Oktober 2007, 17:36

Hi,

ich schätze mal, dass es einfach nicht auf ARM portiert ist. Falls es auf ner x86 Box so läuft, ist es nicht portiert.
Da hilft es nur, den Author der Software zu kontaktieren oder selbst entsprechende Patches zu schreiben.

Gruss,
EvilDevil

Anzeigen

Social Bookmarks