Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

21

Samstag, 6. Oktober 2007, 15:05

Tach,

192.168.1.77, wenn die Adresse nicht geändert wurde.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


comlar

Anfänger

  • »comlar« ist der Autor dieses Themas

Beiträge: 24

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

22

Samstag, 6. Oktober 2007, 18:19

Zitat von »caplink811;27496«

Tach,

192.168.1.77, wenn die Adresse nicht geändert wurde.

bye
JrB

Richtig!

Aber ich kann sie über diese IP nicht anpingen, geschweige denn mich per ssh anmelden. Auch über die Adresse, die ich ursprünglich über die Weboberfläche der original Firmware zugewiesen habe, erreiche ich sie nicht (was bei manchen wohl möglich sein soll).

23

Sonntag, 7. Oktober 2007, 00:02

Hast du die NSLU mal neu geflasht?

comlar

Anfänger

  • »comlar« ist der Autor dieses Themas

Beiträge: 24

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

24

Sonntag, 7. Oktober 2007, 06:36

Ich habe die schon hin und her geflasht zwischen Originalfirmware und Debian. Sobald ich die Originalfirmware aufspiele läuft alles und wenn ich Debian installieren will, geht es nicht.

comlar

Anfänger

  • »comlar« ist der Autor dieses Themas

Beiträge: 24

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

25

Dienstag, 9. Oktober 2007, 20:29

Keiner mehr eine Idee? Oder sollte ich besser warten, bis es wieder eine Debian-Install-Version gibt, die läuft?

26

Dienstag, 9. Oktober 2007, 22:13

Naja ich würde warscheinlich weiter rumprobieren. Aber ich kann nur für mich sprechen ;-)

Ich weiß nicht ob auf eine neue Version eine Lösung darstellt. Ich denke da wird dann das gleiche Problem auftauchen.
Ich habe das bisher sonst noch nirgends gehört das die Slug absolut nicht erreichbar war/ist.

Scheint ja irgendwas mit dem Netzwerk oder so zu tun zu haben.

Hast du die Slug mal direkt per Corss-Over an den PC gehangen?


Hast du vielleicht im Router einen bestimmten Adressbereich eingestellt 192.168.1.1 - 192.168.1.6?
Und sind vielleicht alle besetzt? Vielleicht mal 1-77 Freischalten.
SSH Port offen? Sonstige Firewalls?
Vielleicht ein MAC-Filter im Router aktiviert?

Das warn jetzt alles noch Punkte die mir
spontan eingefallen sind.
Hoffe ich kann dir damit helfen...

mfg

27

Mittwoch, 10. Oktober 2007, 09:35

Welche IP und Netzmaske hat der Rechner, von dem aus du die NSLU erreichen willst?
Scovery xS - 1002MHz - RAM 512MB - HD 160GB - Debian Etch
In Planung: CarNSLU - 266MHz - RAM 32MB - Flash 2GB - USB-Extra-Ports - WLAN - USBAudio - GPS - Debian Etch

mulder

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

28

Mittwoch, 10. Oktober 2007, 14:39

Hi,

ich hatte ein ähnliches Problem.

Am Router hatte ich eingestellt, dass er ab IP 192.168.2.100 den Rechnern im Netzwerk eine IP zuweisen soll.

Die Slug hatte dann 192.168.2.101 zugewiesen bekommen, obwohl im Webinterface 192.168.2.77 von mir eingestellt wurde.

Also, versuch mal in dem Webinterface Deines Routers eine Liste der angeschlossenen Rechner aufzurufen ('DHCP').

Lg,
mulder

comlar

Anfänger

  • »comlar« ist der Autor dieses Themas

Beiträge: 24

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

29

Mittwoch, 10. Oktober 2007, 20:18

Zitat von »moo;27561«

Naja ich würde warscheinlich weiter rumprobieren. Aber ich kann nur für mich sprechen ;-)

Das werde ich auch machen. Das Teil soll schließlich nicht nur in der Gegend rumstehen.

Zitat von »moo;27561«

Hast du die Slug mal direkt per Corss-Over an den PC gehangen?

Das noch nicht. Aber kann ich mal testen.

Zitat von »moo;27561«

Hast du vielleicht im Router einen bestimmten Adressbereich eingestellt 192.168.1.1 - 192.168.1.6?

Nein.

Zitat von »moo;27561«

Und sind vielleicht alle besetzt?
Nein.

Zitat von »moo;27561«

SSH Port offen?
Welcher ist das genau?

Zitat von »moo;27561«

Sonstige Firewalls?
Nein

Zitat von »moo;27561«

Vielleicht ein MAC-Filter im Router aktiviert?
Ja, aber nur für die W-Lan-Geräte.

Zitat von »VooChee;27567«

Welche IP und Netzmaske hat der Rechner, von dem aus du die NSLU erreichen willst?

IP des Rechners: 192.168.178.20
Subnetzmaske: 255.255.255.0

Zitat von »mulder;27575«

Also, versuch mal in dem Webinterface Deines Routers eine Liste der angeschlossenen Rechner aufzurufen ('DHCP').

DHCP ist bei mir aus Sicherheitsgründen deaktiviert. Also müsste der NSLU2 entweder seine Standard-IP haben oder eben die, die ich ihm über die Weboberfläche zugewiesen habe.

mulder

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

30

Mittwoch, 10. Oktober 2007, 20:23

Um es abzukürzen....

a) Crossoverkabel

b) Separates Hub, an dem der Rechner und die NSLU hängt

Lg,
mulder

SSH-Port ist übrigens 22

mulder

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

31

Mittwoch, 10. Oktober 2007, 20:34

Nochwas...

Ich hatte die SLUG nach der Methode "upslug2" unter http://www.cyrius.com/debian/nslu2/install.html erfolgreich zum Laufen gebracht.

Dann unter http://www.slug-firmware.net/d-dls.php das "debian-4.0r0.zip" entpackt und mit "upslug2" drauf bekommen.

Danach konnte ich auch nicht auf die SLUG!

Erst als ich das las: http://svn.debian.org/wsvn/pkg-nslu2-uti….Debian?op=file

Wenn man den Installer laufen läßt und wenn der Screen am Schluss mit dem Hinweis kommt, dass die SLUG rebootet wird (_nicht_ weitergehen und stehen lassen), dann eine zweite Shell öffnen und wieder an der SLUG anmelden und folgenden Part auf der SLUG machen:

If you want openslug's behavior of coming up on address 192.168.1.77 if
there is no dhcp server, edit /etc/dhclient.conf and add a default
lease, such as this:

# Prdefined default lease for networks w/o dhcp.
lease {
interface "eth0";
fixed-address 192.168.1.77;
option broadcast-address 192.168.1.255;
option routers 192.168.1.1;
}

Dann klappt's auch!

Den Part mit den Startsequenzen sind auch sehr sinnvoll!

Versuch's mal...

mulder

32

Mittwoch, 10. Oktober 2007, 21:26

Hmm ich weiß ned genau ist es möglich in das andere Netz zu "sprechen" wenn bei 192.168.178.20 der Hostanteil auf 8 Bit beschränkt ist? Die nslu sitzt ja in nem ganz anderen subnet 192.168.1.77.



Der SSH Port ist 22

mulder

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

33

Mittwoch, 10. Oktober 2007, 22:15

Nein. Nur mit Proxy.

Lg,
mulder

34

Donnerstag, 11. Oktober 2007, 00:21

Daran könnte das Prob von comlar ja vielleicht liegen...

35

Donnerstag, 11. Oktober 2007, 11:24

Hi

du versuchst also von einem Rechner mit
IP 192.168.178.20/255.255.255.0 die NSLU mit der vermuteten
IP 192.168.1.77 zu erreichen.
Das kann nicht gehen weil es ein anderes Netz ist.
Ändere mal die IP deines Rechners auf eine in dem Netz wo die NSLu ist
z.B. 192.168.1.100 oder so...
und versuche es nochmal

Gruß
VooChee
Scovery xS - 1002MHz - RAM 512MB - HD 160GB - Debian Etch
In Planung: CarNSLU - 266MHz - RAM 32MB - Flash 2GB - USB-Extra-Ports - WLAN - USBAudio - GPS - Debian Etch

comlar

Anfänger

  • »comlar« ist der Autor dieses Themas

Beiträge: 24

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

36

Freitag, 12. Oktober 2007, 14:38

Ich werde es mal mit einem Cross-Over-Kabel versuchen. Vielleicht gelingt es damit.

Danke für die ganzen Hinweise.

37

Freitag, 12. Oktober 2007, 15:03

Zitat von »moo;27482«

Es gibt tools womit man das ganze Netzwerk nach Clients abscannen kann. Sowas wäre vielleicht mal interessant für dich. Stichwort: google Languard.


Languard wird nicht funktionieren ... Debian beantwortet meines Wissens nach in der default Konfiguration keine Broadcastpings.

Lässt sich aber ganz leicht festellen ...

Quellcode

1
2
cat /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
cat /proc/sys/net/ipv4/icmp_echo_ignore_all

wenn da min. eine 1 steht dann wird Languard schon nicht mehr funktionieren außerdem bekommst die anderen Info's auch nicht weil Languard auf Windows-Netzwerke ausgelegt ist ;)

38

Freitag, 12. Oktober 2007, 15:16

Achso, wusste ich nicht sorry ^^

Naja jetzt weiß ich das ja ;)

Gruß, Moritz

39

Sonntag, 14. Oktober 2007, 21:22

Sorry falsches Forum -.-

comlar

Anfänger

  • »comlar« ist der Autor dieses Themas

Beiträge: 24

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

40

Montag, 15. Oktober 2007, 14:48

Neuer Zwischenstand (leider immer noch keine Erfolgsmeldung):

  1. Ich habe die NSLU2 an meinen Linux-PC mittels Cross-Over-KAbel angeschlossen.
  2. Ich habe dem Linux-PC die IP 192.168.1.1 zugewiesen.
  3. Ich gelange mittels http://192.168.1.77 auf die Weboberfläche des NSLU2
  4. Ich habe den NSLU2 entsprechend mit "http://cyrius.com/debian/nslu2/files/sda1-2.6.18.dfsg.1-13etch2" geflasht. Das funktioniert ohne Probleme.
  5. Dann wird rebootet.
  6. Die NSLU2 erkennt die angeschlossene USB-Platte
  7. Es passiert nichts weiter...
Die Platte ist gem. "http://www.cyrius.com/debian/nslu2/unpack.html" partitioniert und das Debian-Basis-System aufgespielt.

Die NSLU zeigt nun nach dem ersten Reboot die Netzwerkverbindung grün an, ebenso die erkannte USB-Platte.

Die "Ready/Status"-LED blinkt grün und jeweils zweimal kurz orange.

Mehr passiert nicht.

Quellcode

1
ping 192.168.1.77

führt zu der Meldung:

Quellcode

1
Destination Host Unreachable


Der zweite Reboot findet nicht statt und somit startet auch kein Debian-Installer.

Woran kann das noch liegen?

Social Bookmarks