Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

beholder

Anfänger

  • »beholder« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

1

Donnerstag, 27. September 2007, 22:47

root PW?

Hallo, ich habe gerade frisch Debian auf meiner USB Platte installiert. Hat auch alles wunderbar funktioniert. Während der Installation waren die Zugangsdaten ja: installer/install. Ich habe leider keine eigenen Zugangsdaten festgelegt und würde jetzt gerne wissen wie diese lauten? Per Putty komm ich auf die Kiste drauf, aber ich habe halt keine Zugangsdaten...


Die Suche schon benuzt?: nein

Art der Firmware: debian-4.0r0

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: Maxtor USB

Anzeigen

2

Donnerstag, 27. September 2007, 23:55

Einfach Festplatte abziehen und auf einem Unix-System mounten (z.B. Knoppix).
Dann auf der Slug-Platte(!) die Datei etc/shadow editieren. Da steht dann sowas drin wie:

Quellcode

1
2
...
root:[B]![/B]:13652:0:99999:7:::

Lösche alle Zeichen zwischen den ersten beiden Doppelpunkten (hier also das Ausrufezeichen) und lösche somit das root Passwort.
Festplatte wieder an die Slug anschließen und Du kannst Dich wieder als root anmelden.
Nicht vergessen neues root-Passwort zu setzen ... :)

Anzeigen

beholder

Anfänger

  • »beholder« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

3

Freitag, 28. September 2007, 23:43

hallo, leider funktioniert das nicht... ich kann mich immer noch nicht einloggen! zwischen den ersten beiden : stand ein *. den habe ich herausgelöscht und es ging nicht. dann habe ich in einem erneuten versuch dort irgendwas eingetragen und es ging auch nicht.
bin echt verzweifelt. die kiste läuft einwandfrei, aber ich bekomme einfach keinen zugriff!!

4

Samstag, 29. September 2007, 00:59

Mein Fehler: Die beschriebene Prozedur musst Du auf etc/shadow und etc/passwd anwenden.

Quelle: debian Admin.

beholder

Anfänger

  • »beholder« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

5

Samstag, 29. September 2007, 01:35

hallo,
ich habe jetzt beide files editiert:

/etc/shadow: inhalt zwischen den ersten beiden doppelpunkten gelöscht (hier stand ein: *)

/etc/passwd: inhalt zwischen den ersten beiden doppelpunkten gelöscht (hier stand ein: x)

danach habe ich die usb platte neu angeschlossen und neugestartet und wollte mich über putty einloggen. unter root und ohne passwort, schlug leider wieder fehl "access denied".
was mach ich falsch? muss ich das passwort irgendwo ändern oder neu anlegen bevor ich mich anmelde?

beholder

Anfänger

  • »beholder« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

6

Samstag, 29. September 2007, 23:13

so, es hat leider kein weg an einer neuinstallation vorbei geführt... jetzt geht es aber!

7

Samstag, 29. September 2007, 23:46

Hallo beholder,

War heute leider nicht am Rechner (sondern den ganzen Tag draußen im Regen) - daher leider erst jetzt die späte Antwort. Die zu Späte, wie ich sehe :)

Das Problem war offensichtlich, dass Linux nicht erlaubte, dass Du Dich "remote" als root anmeldest, wenn root kein Passwort hat. Ok - an sich ein sicherheitsbewusstes Verhalten des OS. In unserem Fall nervt es. Du hast nix falsch gemacht - mein angedachter Weg war einfach falsch :)

Aber falls in Zukunft jemand anders auch mal das Problem haben sollte, dann hätte ich noch einen Weg auf Lager: Einloggen mit ssh-Schlüssel.

Auf Deinen Hauptrechner erzeugst Du ein ssh-Schlüsselpaar für einen User. Z.B. mit:

Quellcode

1
ssh-keygen -b 1024 -t dsa


Anschließend stellst Du den "root" Deiner Slug so ein, dass er dem "Besitzer" dieses Schlüssels Zugang gewährt. Das macht man indem man im Heimatverzeichnis von root der Slug (also auf der Slug-Platte) das Unterverzeichnis .ssh erstellt und den öffentlichen ssh-Schlüssel (z.B. /home/beholder/.ssh/id_dsa.pub) in diesem Verzeichnis ablegt - allerdings unter dem Namen "authorized_keys". Jetzt noch die Zugriffs- und Besitzrechte des erstellen Verzeichnisses (chmod 700 .ssh) und des Files authorized_keys (chmod 644 .ssh/authorized_keys) setzen. Jetzt Platte wieder in die slug und slug starten. Und jetzt kann man sich vom Hauptrechner auf der slug einloggen mit:

Quellcode

1
beholder@Hauptrechner $> ssh root@slug -v

Und jetzt wird kein Passwort mehr abgefragt ... sondern nur nach der ssh Passphrase.

Naja - aber Neuinstallation war bestimmt auch nicht so schwer ...:)

Viele Grüße,
topgear

beholder

Anfänger

  • »beholder« ist der Autor dieses Themas

Beiträge: 10

Firmwareversion / your current Firmware: Debian

  • Nachricht senden

8

Sonntag, 30. September 2007, 14:59

alles klar, schade - zu spät :), aber egal, hauptsache nun funktioniert es. vielen dank für deine hilfe! solltest du nun damit anderen weiterhelfen, na dann ist doch alles super :)

Social Bookmarks