Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 8. September 2007, 12:04

build-essential kann nicht installiert werden

Servus,

irgendwie scheint das Repository nicht richtig auf einander abgestimmt. Ich krieg konflikte wenn ich versuche build-essential zu installieren.

Ich wollte eigentlich p910d einrichten damit ich meinen Drucker (Canon PIXMA iP4000) im Netz zugänglich machen kann.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
nslu2:/usr/src/p910nd-0.9# aptitude install build-essential
Reading package lists... Done
Building dependency tree
         Reading state information... Done
Reading extended state information
        Initializing package states... Done
Reading task descriptions... Done
   Building tag database... Done
     The following packages are BROKEN:
  libc6-dev
  The following NEW packages will be automatically installed:
  binutils cpp cpp-4.1 dpkg-dev g++ g++-4.1 gcc gcc-4.1 libmudflap0 libmudflap0-dev
    libssp0 libstdc++6-4.1-dev linux-kernel-headers
  The following NEW packages will be installed:
  binutils build-essential cpp cpp-4.1 dpkg-dev g++ g++-4.1 gcc gcc-4.1 libmudflap0
    libmudflap0-dev libssp0 libstdc++6-4.1-dev linux-kernel-headers
  0 packages upgraded, 15 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.7MB of archives. After unpacking 45.0MB will be used.
The following packages have unmet dependencies:
  libc6-dev: Depends: libc6 (= 2.3.6.ds1-13etch2) but 2.6.1-1 is installed.
Resolving dependencies...
open: 4; closed: 3; defer: 0; conflict: 1                                               o
The following actions will resolve these dependencies:

 Keep the following packages at their current version:
build-essential [Not Installed]
dpkg-dev [Not Installed]
g++ [Not Installed]
g++-4.1 [Not Installed]
gcc [Not Installed]
gcc-4.1 [Not Installed]
libc6-dev [Not Installed]
libmudflap0-dev [Not Installed]
libstdc++6-4.1-dev [Not Installed]

 Score is -9809

 Accept this solution? [Y/n/q/?]
 
Die Konflikte lassen sich leider auch nicht auflösen.
Meine sources.list

Quellcode

1
2
3
4
5
6
deb http://ftp.de.debian.org/debian etch contrib
deb http://ftp.de.debian.org/debian etch main
deb http://ftp.de.debian.org/debian etch non-free
deb-src http://ftp.de.debian.org/debian etch main
deb-src http://ftp.de.debian.org/debian etch contrib
deb-src http://ftp.de.debian.org/debian etch non-free
Hat jemand eine Idee?

Anzeigen

Social Bookmarks