Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 7. September 2007, 14:35

Debian Firmware 4.0rc2

Hi...

ich habe vergeblich versucht meine NSLU erneut zu Flashen. Bei "Installing Base System" kommt ein Fehler da ein alter Kernel gesucht wird dieser aber nicht mehr vorhanden ist.

Hat jemand vielleicht noch ein älteres Image der Firmware zu hand und würde mir dies zukommen lassen? Oder kann mir jemand einen Link nennen? Ich habe schon google genutzt und leider nichts gefunden.
(Vielleicht den rc1 oder 3.x)

Würde die Box gerne heute wieder zum laufen bringen :)


Danke, Moritz


Die Suche schon benuzt?: ja

Art der Firmware: Keine ^^

Anzeigen

2

Samstag, 8. September 2007, 06:34

Hallo,

habe die Versin debian-4.0r0 vom 11.03.2007.
Ca 4,3MB groß. Würde die helfen?

Gruß GerBer
Server-NSLU2
DNS / DHCP-Server / Samba / nfs / ntp / ftp - Server / Intranetserver / Mailgateway / Pop3-Server / MP3-Server

Backup-Server
nfs / ftp - Server / MP3-Server

Beide Geräte (266Mhz) mit 2 GB USB-Stick (Betriebssystem Debian 4.0) und einer weiteren 3,5" Festplatte (Daten)
MP3-Server für Rokku Soundbridge und iTunes

2 Testgeräte mit 166Mhz und 266Mhz sowie 1GB USB-Stick bzw. 30GB 2,5" Platte

Anzeigen

3

Mittwoch, 19. September 2007, 21:53

hat vielleicht noch jemand diese version oder eine andere?

Wäre nett wenn mir die jemand per email senden könnte da ich mir GerBer kein Kontakt bekomme.

Email Adresse: Moritz.z@web.de

MFG

MADMAX84

Schüler

Beiträge: 60

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

4

Montag, 24. September 2007, 20:12

Hallo moo,

Kannst du mir Vielleicht helfen habe ein Problem mit der Partitionierung. Kannst du mir bitte mal schrieben wie du das gemacht hast?

Schreibe dir hier mal meinen Problem.

Habe jetzt die Festplatte mit QTpartition Partitioniert wie in der Anleitung. Dann habe ich die Festplatte angeschlossen. Wenn ich nun:

CD /dev/sda1/

würd keine Platte gefunden.

Dann habe ich nochmal alle Partitionen gelöscht und versucht über die NSLU2 zu Partitionieren.
Leider geht das gar nicht. Sobald ich FDISK /DEV/SDA gegebe kommt die Meldung:


fdisk: /dev/sda: option ignored - please reopen the device

weis jetzt nicht mehr weiter kann mir jemand sagen was ich falsch mache?

MfG

MADMAX84

5

Montag, 24. September 2007, 22:41

Hi MADMAX,

lass doch den installer einfach die partitionierung übernehmen. Der macht das wunderbar. habe es auch so gemacht...

mfg

MADMAX84

Schüler

Beiträge: 60

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

6

Dienstag, 25. September 2007, 09:37

Danke für die schnelle antwort.
Kann leider die Festplatte nicht mit dem Installer Partitionieren. Welche Installer Components muss ich runterladen?

autopartkit: ...
.
.
.
usw.

Welchen Installer ahst du benutz debian-etch-beta2-20060311 oder debian-4.0r0?

Ich hab jetzt debian-4.0r0 benutz.

7

Dienstag, 25. September 2007, 21:54

Hallo MADMAX84,

Dein Problem ist nicht die Partitionen sondern wie Du darauf zugreifen möchtest.
"/dev/sda1" ist ein Device. Dieses muß erst gemountet werden.
z.B. "mount /dev/sda1 /mnt" danach kannst Du mit "cd /mnt" Dir den Inhalt ansehen.

Meine Festplatten bereite ich immer wie folgt an einem laufenden System (PC / Test-NSLU2) vor:
1) fdisk /dev/sda
Dort 1. Partition - root (ca 2 GB) 2. Partition - swap ( ca. 512 MB - partition's system id auf 82 einstellen) optional 3. Partition - daten ( Rest für z.B. home, data oder musik)
2) formatieren mit "mkfs.ext3 /dev/sda1", den Swapbereich "mkswap /dev/sda2"
Danach können die neuen Partitionen verwendet werden.

Dabei solltest Du beachten welcher Devicename benutzt wird. Es kann sein das einmal sda und bei einem anderen Computer sdb eingegeben werden muss. Diese Info findest Du unter "/var/log/syslog". Diese kannst Du bequem mit "tail -f /var/log/syslog" - danach das Gerät einschalten! ansehen.

Welche Anleitung hast Du verwendet?!? Ich kenne noch keine die ein bestimmtes Programm vorgibt.

Zitat

fdisk: /dev/sda: option ignored - please reopen the device

Wahrscheinlich war auf der Partition die gesamten Programme und Du hast Dir mit dem löschen der Partitionen den Boden unter den Füßen weggezogen. Daher geht dann nichts mehr.

Gruß GerBer
Server-NSLU2
DNS / DHCP-Server / Samba / nfs / ntp / ftp - Server / Intranetserver / Mailgateway / Pop3-Server / MP3-Server

Backup-Server
nfs / ftp - Server / MP3-Server

Beide Geräte (266Mhz) mit 2 GB USB-Stick (Betriebssystem Debian 4.0) und einer weiteren 3,5" Festplatte (Daten)
MP3-Server für Rokku Soundbridge und iTunes

2 Testgeräte mit 166Mhz und 266Mhz sowie 1GB USB-Stick bzw. 30GB 2,5" Platte

8

Mittwoch, 26. September 2007, 09:29

Hallo,

ich habe ein Problem bei der Installation von debian-4.0r0,
und zwar bricht die installation immer bei der linux..kernel.. installation ab, genauen wortlaut weiß ich nicht mehr, werde ich aber noch mal posten.

versuche debian auf einem 1GB USB stick zu installieren, habe die swap-Partition auf ~400MB gesetzt und den rest für root genommen.

habe mich nach dieser Anleitung:
http://www.cyrius.com/debian/nslu2/install.html
gerichtet.

lief auch ganz gut, nur das immer an der selben stelle abgebrochen wird.
kann mir da jemand weiterhelfen?
Gruß
Julian

MADMAX84

Schüler

Beiträge: 60

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

9

Mittwoch, 26. September 2007, 09:42

Hi, postet mal meine tail -f /var/log/syslog aus der NSLU2.

Sep 26 09:28:44 main-menu[2253]: INFO: Falling back to the package description for auto-install
Sep 26 09:28:44 main-menu[2253]: INFO: Falling back to the package description for ai-choosers
Sep 26 09:28:44 main-menu[2253]: INFO: Menu item 'partman-base' selected
Sep 26 09:28:56 main-menu[2253]: INFO: Menu item 'partman-base' succeeded but requested to be left unconfigured.
Sep 26 09:28:56 main-menu[2253]: INFO: Modifying debconf priority limit from 'high' to 'medium'
Sep 26 09:28:56 debconf: Setting debconf/priority to medium
Sep 26 09:28:56 main-menu[2253]: DEBUG: resolver (ext2-modules): package doesn't exist (ignored)
Sep 26 09:29:01 main-menu[2253]: INFO: Falling back to the package description for auto-install
Sep 26 09:29:01 main-menu[2253]: INFO: Falling back to the package description for ai-choosers
Sep 26 09:29:01 main-menu[2253]: INFO: Menu item 'di-utils-shell' selected
Sep 26 09:28:44 main-menu[2253]: INFO: Falling back to the package description for auto-install
Sep 26 09:28:44 main-menu[2253]: INFO: Falling back to the package description for ai-choosers
Sep 26 09:28:44 main-menu[2253]: INFO: Menu item 'partman-base' selected
Sep 26 09:28:56 main-menu[2253]: INFO: Menu item 'partman-base' succeeded but requested to be left unconfigured.
Sep 26 09:28:56 main-menu[2253]: INFO: Modifying debconf priority limit from 'high' to 'medium'
Sep 26 09:28:56 debconf: Setting debconf/priority to medium
Sep 26 09:28:56 main-menu[2253]: DEBUG: resolver (ext2-modules): package doesn't exist (ignored)
Sep 26 09:29:01 main-menu[2253]: INFO: Falling back to the package description for auto-install
Sep 26 09:29:01 main-menu[2253]: INFO: Falling back to the package description for ai-choosers
Sep 26 09:29:01 main-menu[2253]: INFO: Menu item 'di-utils-shell' selected

Die platte habe ich erst mit einer Boot CD von Kubuntu gemountet.
Genau wie in der beschreibung. (http://www.cyrius.com/debian/nslu2/unpack.html)

10

Donnerstag, 27. September 2007, 07:20

Hallo HobbyStudent,

in dieser Anleitung steht das man mit einem 1GB Stick nicht weit kommt:

Zitat

If you have a USB stick with only 1 GB the current version of the installer will by default create a swap partition that is too small and your system will run out of memory during the installation and fail

Wenn 400 MB für Swap bleibt dem System nicht genug um die temporären Dateien anzulegen und die "richtigen" Files zu schreiben.

Gruß GerBer
Server-NSLU2
DNS / DHCP-Server / Samba / nfs / ntp / ftp - Server / Intranetserver / Mailgateway / Pop3-Server / MP3-Server

Backup-Server
nfs / ftp - Server / MP3-Server

Beide Geräte (266Mhz) mit 2 GB USB-Stick (Betriebssystem Debian 4.0) und einer weiteren 3,5" Festplatte (Daten)
MP3-Server für Rokku Soundbridge und iTunes

2 Testgeräte mit 166Mhz und 266Mhz sowie 1GB USB-Stick bzw. 30GB 2,5" Platte

11

Donnerstag, 27. September 2007, 09:40

Danke @GerBer

habe aber das Problem gefunden und behoben:

http://lists.debian.org/debian-arm/2007/09/msg00000.html

jetzt lief die Installation durch musste anderen Kernel wählen dann gings.
muss nur noch schauen ob meine Slug auch noch neu bootet soweit bin ich noch nicht gekommen, so wenig zeit für so schöne dinge (:

MADMAX84

Schüler

Beiträge: 60

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

12

Freitag, 28. September 2007, 11:11

Kennt eigentlich jemand das root PW von Deban4.0 beim Installer?

13

Samstag, 29. September 2007, 09:15

so wie gesagt bei mi funzzt debian jetzt, nur habe ich jetzt folgendes problem immer wenn ich mich über ssh bei der slug anmelde muss ich gleich danach das pw ändern, weiß jemand wie ich das ausstellen kann?
zu dem kann ich mich nur als root über ssh anmelden, als normaler user geht das nicht da wir die verbindung gleich nach eingabe des neuen pw (wie eben schon beschrieben) getrennt



@madmax84

wenn du debian installierts musst du das root pw selber vergeben

14

Samstag, 29. September 2007, 11:42

muss mich korrigieren, läuft jetzt alles soweit, nur das meine slug beim booten mehr als eine stunde!!! braucht :(
woher kann das kommen?

upD8R

Schüler

Beiträge: 94

Firmwareversion / your current Firmware: Debian

Wohnort: SRB, Germany

  • Nachricht senden

15

Sonntag, 30. September 2007, 17:26

Zitat von »HobbyStudent;27350«

muss mich korrigieren, läuft jetzt alles soweit, nur das meine slug beim booten mehr als eine stunde!!! braucht :(
woher kann das kommen?

Könnte daran liegen, dass die hardwareclock nicht richtig geht.

Stell die Uhr mal mittels date und dann machst Du ein

Quellcode

1
hwclock -w


Könnte helfen. Ist auch irgendwo so in der FAQ ...

MADMAX84

Schüler

Beiträge: 60

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

16

Dienstag, 2. Oktober 2007, 11:23

HI,

leider klappt es bei mir immer noch nicht. Ich habe die Platte nochmal Partitioniert.

Device Boot Start End Blocks Id System
/dev/sda1 * 1 120 963868+ 83 Linux
/dev/sda2 121 311 1534207+ 5 Extended
/dev/sda5 121 132 96358+ 82 Linux swap
/dev/sda6 133 311 1437786 83 Linux

wenn ich nun die Platte mounten will kommt diese Fehler Meldung:

mount /dev/sda1 /mnt
mount: Mounting /dev/sda1 on /mnt failed: No such file or directory.

kann mir jemand weiter helfen?

MfG

MADMAX84

17

Samstag, 6. Oktober 2007, 14:05

mach mal:

Quellcode

1
2
3
4
5
ls /dev/

[I]und [/I]

ls /


Und schau ob sda1 beim ersten befehl und mnt beim zweiten existiert.

Irgendeins der beiden "verzeichnisse" is laut deiner Fehlerausgabe nicht vorhanden!

Social Bookmarks