Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 14. Juni 2007, 21:15

Debian etch bootet ca. 40 min bis ping möglich ist

Hallo Leute,

Ich habe mir meine NSLU2 mit debian etch aufgerüstet und es läuft auch alles perfekt, bis auf eine ewig lange Bootzeit (so ca. 40 min.) Vorher lässt sich die box nicht anpingen. Ist sie einmal erreichbar funktioniert alles wunderbar. Dieses Problem tritt nach jedem Neustart auf.

Ich hoffe Ihr könnt mir weiterhelfen. Bin für jeden Tip dankbar.

Meine dmesg ist hier:
http://sellout.se.funpic.de/dmesg.txt




was hast Du bereits probiert?: habe keine rechte Ahnung wo Ich ansetzen soll, aber Ich habe den Verdacht es hat etwas mit folgendem Abschnitt aus der dmesg zu tun:

sd 0:0:0:0: Attached scsi disk sda
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting. Commit interval 5 seconds
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.

Die Suche schon benuzt?: ja

Art der Firmware: di-nslu2.bin (debian etch 4.0)

wird ein externer Datenträger genutzt, wenn ja, was für eine Art: FUJITSU MHW2080AT 80GB 1GB SWAP 79GB /

Anzeigen

soj

Schüler

Beiträge: 68

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

2

Freitag, 15. Juni 2007, 16:38

Hallo,

mmh 40 min sind schon lange. so 10 min würde ich sagen sind ok.
Hast du die Festplatte schon mal überprüft?

Welche Dienste startest du mit dem Boot?

Gruß SOJ :)

Anzeigen

3

Freitag, 15. Juni 2007, 17:29

Hallo soj,
Danke erstmal für Deine Antwort...

die Dienste:
# sysv-rc-conf --list
atd 0_off 1_off 2_on 3_on 4_on 5_on 6_off
beep 0_off 1_off 2_on 3_on 4_on 5_on 6_off
bootclean
bootlogd S_on
cron 0_off 1_off 2_on 3_on 4_on 5_on 6_off
exim4 0_off 1_off 2_on 3_on 4_on 5_on 6_off
gmediaserver 0_off 1_off 2_on 3_on 4_on 5_on 6_off
halt 0_on
ifupdown 0_on 6_on S_on
ifupdown-cle S_on
killprocs 1_on
klogd 0_off 1_off 2_on 3_on 4_on 5_on 6_off
leds_startup 1_on 2_on 3_on 4_on 5_on
libdevmapper S_on
makedev 0_off 1_off 2_on 3_on 4_on 5_on 6_off
module-init- S_on
networking 0_on 6_on S_on
nfs-common 0_off 1_off 2_on 3_on 4_on 5_on 6_off
nfs-kernel-s 0_off 1_off 2_on 3_on 4_on 5_on 6_off
nslu2-rtc S_on
ntp 0_off 1_off 2_on 3_on 4_on 5_on 6_off
openbsd-inet 0_off 1_off 2_on 3_on 4_on 5_on 6_off
portmap 0_on 1_off 2_on 3_on 4_on 5_on 6_on S_on
rc.local 2_on 3_on 4_on 5_on
reboot 6_on
rmnologin 2_on 3_on 4_on 5_on
rmrecovery 1_on 2_on 3_on 4_on 5_on
screen-clean S_on
sendsigs 0_on 6_on
single 1_on
ssh 0_off 1_off 2_on 3_on 4_on 5_on 6_off
stop-bootlog 2_on 3_on 4_on 5_on
stop-bootlog S_on
sysklogd 0_off 1_off 2_on 3_on 4_on 5_on 6_off
thttpd 0_off 1_off 2_on 3_on 4_on 5_on 6_off
udev S_on
udev-mtab S_on
umountfs 0_on 6_on
umountroot 0_on 6_on
urandom 0_on 6_on S_on
vsftpd 0_off 1_off 2_on 3_on 4_on 5_on 6_off
zleds 0_off 1_on 2_on 3_on 4_on 5_on 6_off S_on


die zusätzlichen Dienste wie vsftpd,httpd,usw können nichts damit zu tun haben, da die Box sich von der jungfräulichen Installation an so verhalten hat. Ich habe auch bei der Installation nur das Basissystem ohne zusätzliche Serverdienste ausgewählt.
Mein Verdacht ist, das immer wieder ein Filesystemcheck durchgeführt wird (siehe dmesg), aber Ich habe keine Ahnung, wie Ich Dieses beeinflussen oder abstellen kann. Vielleicht irre Ich mich aber auch und es liegt an etwas Anderem.

Die Festplatte ist neu und ein Hardware defekt scheidet aus, (hatte Sie auch schon kurz an einem anderen Rechner vor der DebianInstallation)

soj

Schüler

Beiträge: 68

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

4

Freitag, 15. Juni 2007, 20:23

Hallo,

zum vergleich meine log datei

EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on sda1, internal journal
EXT3 FS on sda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.

mmh kann dir da leider nicht nicht direkt weiter helfen.
Ich müsste auch raten.

Ich würde mal schau ob 100% Festplatte ok ist mit testtool.
Auch wenn sie neu ist!

Hast du DHCP oder Static IP?

Gruß SOJ :)

5

Samstag, 16. Juni 2007, 14:00

Hallo,

seit ein paar Tagen läuft auf meiner NSLU2 ebenfalls Debian 4.0. Nach der Installation dauerte das Booten bei mir ca. 1h.
Grund für diese lange Bootzeit ist bei mir die Hardwareuhr.

/var/log/boot gibt bei mir folgendes aus.

Quellcode

1
2
3
4
5
6
Thu Jan  1 01:00:48 1970: /dev/sda1: clean, 19949/30523392 files, 1102560/61026910 blocks
Thu Jan  1 01:00:48 1970: done.
Thu Jan  1 01:00:49 1970: Setting the system clock..
Thu Jan  1 01:59:16 1970: Timed out waiting for time change.
Thu Jan  1 01:59:18 1970: Cleaning up ifupdown....
Thu Jan  1 01:59:19 1970: Loading kernel modules...done.
Sollte es bei dir auch an der Hardwareuhr hängen hilft es S11hwclock.sh aus /etc/rcS.d zu löschen.

Das Problem scheint bekannt zu sein und wird auch in den FAQ beschrieben: http://www.nslu2-linux.org/wiki/Debian/FAQ

Gruß Levi

6

Samstag, 16. Juni 2007, 19:55

(gelöst)

Hallo Levi,

Vielen Dank für den Super Tip. Jetzt dauert der Bootvorgang nur noch ca. 2 min. Nun habe Ich es auch in der FAQ gefunden.
Du hast mir damit sehr weitergeholfen.

Gruß BerndB

Social Bookmarks