Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

jannes

Anfänger

  • »jannes« ist der Autor dieses Themas

Beiträge: 14

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

1

Donnerstag, 7. Juni 2007, 22:37

I-O-Error noch Spindown

Hallo Leute,

ich habe für meine NSLU eine neue Festplatte (500 GB) gekauft. Es ist nun schon die 3 HDD (1x 300 GB+ 500 GB). Die 300 GB von Seagate macht von alleine einen Spindown nach scheinbar Minuten ohne IO. Die andere 500 GB macht durch ein Script nach 30 Mins ein Spindown. Beide drehen bei IO die Platten wieder ohne Probleme an.

Nun das Problem: Bei der neuen Platte handelt es sich auch um eine Seagate mit 500 GB aber um ein neueres Modell. Sie macht auch einen automatischen Spindown nach gewisser Zeit: Wenn ich nun aber ein ls auf das Verzeichnis machen in dem die Platte gemountet ist erhalte ich:

Quellcode

1
ls: reading directory .: Input/output error
Wenn die Platte wieder andreht (in dem ich ein cd /mountordner/ *nun tab drücke* mache) ist die sie schreibgeschützt:

Quellcode

1
touch: cannot touch `test': Read-only file system
Und einige Ordner (immer wieder andere) sind korrupt:

Quellcode

1
?---------  ? ?    ?        ?            ? Folder
Nach einem Remount der Platte ist alles wieder in Ordnung, bis zum nächsten Spindown...

Kann mir jemand helfen?

Die Schwierigkeit ist: Ich kann die NSLU nicht neustarten :) immer wenn ich das getan habe, habe ich 2 Tage gebraucht um die NSLU neu einzurichten und dazu habe ich momentan keinen Nerv. (Wie schon seit 128 Tagen ;) )

Quellcode

1
2
nslu2:/# uptime
 22:31:30 up 128 days,  3:16,
Greets Jannes


Die Suche schon benuzt?: ja

Art der Firmware: Debian

Anzeigen

2

Donnerstag, 7. Juni 2007, 22:56

Das die Platte wenn sie wieder hochfährt schreibgeschütz ist kann daran liegen, das du die inder /etc/fstab einen Eintrag errors=remount-ro hast, was bedeutet, das wenn Fehler auftraten die Platte ReadOnly gemountet wird.

Die Frage ist aber warum kommt es zu den Fehlern.
Du sagst, das die Platte 'von selber' in den SpinDown geht. Vermutlich bekommt der Kernel davon nichts mit, da dies nicht von ihm gesteuert wurde.

Versuche doch mal die HD gesteurt in den SpinDown zu fahren, das heißt mit einem Script oder ähnlich. D.H dem automatischen Abschalten der Platte zuvorkommen.
Ich verwende dafür hd-idle, das funktioniert super.
Scovery xS - 1002MHz - RAM 512MB - HD 160GB - Debian Etch
In Planung: CarNSLU - 266MHz - RAM 32MB - Flash 2GB - USB-Extra-Ports - WLAN - USBAudio - GPS - Debian Etch

Anzeigen

jannes

Anfänger

  • »jannes« ist der Autor dieses Themas

Beiträge: 14

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

3

Freitag, 8. Juni 2007, 00:08

Hi VooChee,

vielen dank für deine antwort.

das hatte ich auch schon vermutet:

auch wenn ich die Platte mit scsi-stop schlafen schicke (wie es bei der anderen 500 GB klappt) habe ich das selbe problem.

Das mit der fstab ist nicht der fall. ich habe aber probiert die platte mit der option errors=remount-rw. das klappt aber leider auch nicht.

trotzdem danke....

jannes

4

Freitag, 8. Juni 2007, 08:10

also scsi-stop kenne ich jetzt nicht.
meinst du folgendes (falls nicht, probier es doch mal)?

sdparm -C stop /dev/sda
Scovery xS - 1002MHz - RAM 512MB - HD 160GB - Debian Etch
In Planung: CarNSLU - 266MHz - RAM 32MB - Flash 2GB - USB-Extra-Ports - WLAN - USBAudio - GPS - Debian Etch

jannes

Anfänger

  • »jannes« ist der Autor dieses Themas

Beiträge: 14

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

5

Montag, 11. Juni 2007, 11:41

hallo leute,

ich habe die antwort für mein problem gefunden. Es handelt sich um ein Kernel-Parameter, der geändert werden muss.

http://www.nslu2-linux.org/wiki/FAQ/Deal…eagateFreeAgent

jannes

Social Bookmarks