Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 6. März 2007, 21:10

OpenVPN unter Debian - Virtuelles Device (TUN)

Hallo zusammen,

ich bin gerade mit einem Freund dabei OpenVPN auf meiner NSLU2 zu installieren. Leider scheint es da aber ein paar Unterschiede zur Einrichtung auf anderen Linuxbasierenden Systemen zu geben.

Hat denn jemand von euch schon Erfahrung in diesem Bereich gesammelt? Ganz speziell würde uns im Augenblick helfen, wenn jemand wüsste wie wir das notwendige TUN Device angelegt bekommen.

Danke schon mal vorab!

Grüße
Baddok

Anzeigen

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

2

Donnerstag, 8. März 2007, 16:33

hi welches image isn installiert

debian installer
oder der alte weg über n bootstrap ?

Anzeigen

3

Freitag, 9. März 2007, 07:15

Hallo Eiffel,

ich habe per Bootstrap das unstable Release installiert. Das sollte dann die Version 3.10 Beta sein, richtig?
Ich denke inzwischen, dass das Problem darin liegt, das TUN Device mit dem ARM Prozessor zum laufen zu bekommen. Auf der OpenVPN Seite steht diesbezüglich nur, dass es wohl schon einer geschafft hat den Dienst auf dieser Plattform zum Laufen zu kriegen. Was tun sprach Zeus?

Grüße
Baddok

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

4

Freitag, 9. März 2007, 11:47

ok ich denke dann bist du auch so weit gekommen das sich zwar alles installieren lässt aber wenn man es mit modprobe versucht zuladen geht nix
weil das kernel module nicht gefunden wird

habe das nicht weiter verfolgt da es unter unslung auf meiner 2. box auf anhieb ging
aber ich denke das liegt daran das der eigentliche Kernel unterbau openslug ist
evtl könnte es klappen wenn du ohne platte bootest dann landeste im openslug part dort dann das openvpn kernel modul (tun) integrieren
hoffentlich reicht der platz im Flash dazu aus
und dann nach nem reboot mit platte könnte es dann unter Debian evtl gehen

aber wirklich sicher bin ich mir da auch nich ob es das sein könnte

trapperjohn

Fortgeschrittener

Beiträge: 558

Wohnort: Bremen

Beruf: SW-Entwickler

  • Nachricht senden

5

Freitag, 9. März 2007, 13:47

Was ist denn mit dem TUN Modul für Debianslug:
http://ipkgfind.nslu2-linux.org/details.…12884&official=

Wie immer, installieren per 'dpkg -i --force-architecture moduldatei.ipk'

Die Meldungen/Warnungen/Fehler bezüglich falschem Kernel und fehlendem module-update sind großzügig zu ignorieren. Hinweise auf fehlende weitere Kernelmodule einfach durch manuelles Installieren derselbigen befolgen.
Gruß,
Flo

6

Samstag, 10. März 2007, 20:50

Hallo Trapperjohn,

danke für den Tip! Das könnte es doch sein. Ich hab den Befehl ausgeführt und wie prophezeit erhielt ich Fehlermeldungen bezüglich update-modules und kernel-image-2.6.16. Kann ich wunderbar ignorieren, nur die Aussage "Abhängigkeitsprobleme - lasse es unkonfiguriert" deutet doch eigentlich darauf hin, dass die Installation nicht vollständig abgeschlossen wurde, richtig? Wie bekomme ich das TUN Device jetzt konfiguriert? Ich werde es noch mit dem OpenVPN How-to versuchen, vielleicht klappt das jetzt ja. Hinweise auf andere Kernelmodule wurden nicht angezeigt.
Muss ich jetzt noch ein Kernelupdate durchführen? Ich meine ich habe das richtige apt-get paket für das Kernelupdate gefunden (http://packages.debian.org/unstable/admi…age-2.6-ixp4xx).

Ich hoffe ich habe soweit alles richtig verstanden ;)

trapperjohn

Fortgeschrittener

Beiträge: 558

Wohnort: Bremen

Beruf: SW-Entwickler

  • Nachricht senden

7

Samstag, 10. März 2007, 20:55

Ne ne, kein Kernelupdate, das geht in die Hose ...

Mach mal 'depmod -a' um die Modulabhängigkeiten etc. zu aktualisieren und dann lade das Modul per 'modprobe tun'.

'dmesg' müsste dir dann Infos über das erfolgreiche Laden des Moduls geben.
Gruß,
Flo

8

Montag, 12. März 2007, 07:05

Hat alles prima funktioniert! Vielen Dank noch mal.
Nach einem mkdir /dev/net konnte ich mir mknod das Device erfolgreich anlegen. OpenVPN startet und ich denke mal heute abend kann gepingt werden :)

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

9

Montag, 12. März 2007, 13:45

cool muss ich auch mal ausprobieren mitm openvpn ausm apt-get hats halt nicht geklappt gehabt damals

Social Bookmarks