Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 28. Januar 2007, 21:47

[gelöst] Zu viele primäre Partitionen - keine Partitionierung oder Crash

Hallo Gemeinde,

ich versuche grad' das inoffizielle Debian/NSLU2 ( von http://www.slug-firmware.net/ ) zu installieren. Ich habe Debian schon oft auf anderen Systemen installiert. Es funktionierte bisher fast, eine ext3-Partition ( / ) und dazu 200mb swap zu erstellen, beim Write-on-disk verlor ich bei 50% allerdings die SSH-Verbindung. (PuTTY) Bei Neuaufbau einer SSH-Connection kann ich wieder bei der Partitionierung einsteigen - allerdings konnte ich noch keine funktionierende Kombination von Partitionen finden. :-)

Versuche ich die Guided-Partitionierung, heißt es, es gäbe bereits zu viele primäre Partitionen. In der Partitionstabelle (die mir das Setup zeigt), stehen neben meinen USB-Stick noch:

/dev/mtdblock0 - 262kb unknown
/dev/mtdblock1 - 131.1kb unknown
/dev/mtdblock2 - 131.1kb unknown
/dev/mtdblock3 - 1.4mb unknown
/dev/mtdblock4 - 6.3mb unknown
/dev/mtdblock5 - 131.1kb unknown
SCSI (0.0.0) (sda) - 2.1 GB USB DISK

Erstelle ich im freien Speicher des USB-Sticks eine Partition (ob swap oder mount) steht in der ausgegebenen Tabelle neben dem verbleibenden Speicher unusable.

Die /dev/mtdblocks habe ich nicht angelegt, will sie (deshalb) aber auch nicht löschen - ohne euch zu fragen. :) Kommt die NSLU2 ohne diese mountblock(?) devices klar - und wo koennte mein Problem (Verbindungsverlust bei 50%) liegen?

Vielen Dank fuer eure Zeit.

Anzeigen

2

Sonntag, 28. Januar 2007, 22:11

Hi,

dein Problem ist (glaub ich mal) bekannt. Es liegt (wahrscheinlich) daran, dass der Debian Installer beim ext3-Formatieren zuviel RAM benötigt. Abhilfe schafft da eigentlich nur, zuerst (vielleicht an einem normalen Linux PC) auf der Festplatte alle Partitionen anzulegen oder beim Debian-Installer zuerst eine Swap Partition anzulegen und zu aktivieren, bevor du die Dateisysteme anlegen lässt.
Die /dev/mtdblock (Memory Technology Device = mtd) Partitionen würde ich nicht antasten, das ist nämlich der interne Flash Speicher, wo der Bootloader (entspricht dem BIOS eines PCs) usw drinsteht.
Also auf garkeinen Fall löschen!

Gruss,
EvilDevil

Anzeigen

3

Sonntag, 28. Januar 2007, 22:14

Vielen, vielen Dank, ausreichend Informationen.

Social Bookmarks