Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 26. Januar 2007, 17:07

(gelöst) scp haengt

hi,
ich habe folgendes problem:
ich kann von/zur nslu in meinem heimnetz (192.168.***.***) ohne probleme daten mit scp austauschen. wenn ich jedoch daten zu einem anderen computer (nicht in meinem heimnetz, z.B. server in einer anderen stadt) von der nslu versenden will (scp) dann haengt die verbindung (ssh haengt machmal auch). daten auf die nslu zu kopieren funktioniert ohne probleme.
dieses problem tritt nur bei der nslu auf, nicht bei andren computern im netzwerk.
habe zur zeit:
OpenSSH_4.3p2 Debian-8, OpenSSL 0.9.8c 05 Sep 2006

gruesse
frostie

Anzeigen

2

Samstag, 27. Januar 2007, 00:03

Hi,

falls du Debian/NSLU2 verwendest (das Image mit dem Debian-Installer), ist das Problem bekannt und liegt am Opensource-Ethernet Treiber.
Die Abhilfe besteht darin, wieder den proprietären Ethernet Treiber zu installieren, siehe auch
http://www.nabble.com/How-to-revert-to-o…r-t2931297.html

Gruss,
EvilDevil

Anzeigen

3

Samstag, 27. Januar 2007, 09:27

hi evildevil,
vielen dank fuer deine antwort. ja, ich habe den installer benutzt. mein kernel ist: Linux anaNAS 2.6.18-3-ixp4xx #1 Tue Dec 5 16:52:07 UTC 2006 armv5tel GNU/Linux
ich habe auch schon in /lib/modules nachgeschaut und folgendes gefunden:
2.6.17-2-ixp4xx, 1970 2.6.18-3-ixp4xx
habe auch das image: http://snapshot.debian.net/archive/2006/….6.17-9_arm.deb
nun wollte ich es mit:
dpgk --install linux... installieren und bekam eine meldung
anaNAS:~# dpkg --install linux-image-2.6.17-2-ixp4xx_2.6.17-9_arm.deb
(Reading database ...
dpkg: serious warning: files list file for package `linux-image-2.6.17-2-ixp4xx'
missing, assuming package has no files currently installed.
16236 files and directories currently installed.)
Preparing to replace linux-image-2.6.17-2-ixp4xx 2.6.17-9 (using linux-image-2.6
.17-2-ixp4xx_2.6.17-9_arm.deb) ...
The directory /lib/modules/2.6.17-2-ixp4xx still exists. Continuing as directed.

Done.
Unpacking replacement linux-image-2.6.17-2-ixp4xx ...
Setting up linux-image-2.6.17-2-ixp4xx (2.6.17-9) ...

Hmm. The package shipped with a symbolic link /lib/modules/2.6.17-2-ixp4xx/sour
ce
However, I can not read the target: No such file or directory
Therefore, I am deleting /lib/modules/2.6.17-2-ixp4xx/source

Running depmod.
Finding valid ramdisk creators.
Using mkinitramfs-kpkg to build the ramdisk.
Running postinst hook script /usr/sbin/flash-kernel.
Flashing kernel:
Flashing kernel: done.
Flashing initramfs: done.
nun: shutdown -r now
und die nslu hat auch neu gestartet.
und ich kann wieder verschicken!!!
SUPER !!!!
vielen dank!
muss ich jetzt noch etwas mit dem anderen kernel machen?
und wie mache ich ein apt-get update / apt-get upgrade ohne den neuen kernel/opensource-ethernet trieber zu installieren?
VIELEN DANK
frostie

4

Samstag, 27. Januar 2007, 09:48

neues problem: disconnect from ---.+++.###.***: 2: Corrupted MAC on input
mmhhh, was mag das wohl nun sein?
gruesse
frostie

5

Samstag, 27. Januar 2007, 12:40

Hi,

zu deinem 2. Problem weiss ich leider nichts. Vielleicht schreibst du da am Besten an die nslu2-linux Mailingliste ( http://tech.groups.yahoo.com/group/nslu2-linux/ )
Aber das Problem mit dem Beibehalten bestimmter Paketversionen funktioniert mit dem "pinning" bestimmter Paketversionen. Siehe auch
http://www.debian.org/doc/manuals/apt-ho…t.de.html#s-pin

Gruss,
EvilDevil

6

Sonntag, 28. Januar 2007, 14:09

Hi,

hab das gerade in der nslu2-linux Mailingliste gelesen:

Zitat


--- In nslu2-linux@yahoogroups.com, "Dean J" <yahoo@...> wrote:
At some point the kernel starts generating wrong TCP header checksums
(apparently when the connection cue is large enough) and it is all
downhill from there (packets get dropped at destination, they are sent
again with the wrong checksum, etc). I will not even begin to describe
what it took me to reach this conclusion (and in the end I was blaming
the hardware as it was still happening with the original kernel).
This also explains very well why the problems are limited to
situations where NSLU2 is trying to put more packets out than the
bandwidth via a slow network (wifi, dsl).

However I am incredibly pleased to report that I've been testing (as
in just installing, I'm not involved in any way in the actual work)
2.6.18-4 and it appears to be fixed or at least incredibly better. You
can get it from:

http://packages.debian.org/unstable/admi…2.6.18-4-ixp4xx
(standard disclaimers apply: it can kill your cat,burn your house, etc).
Gruss,
EvilDevil

7

Sonntag, 28. Januar 2007, 23:16

COOL!
vielen dank!
frostie

jannes

Anfänger

Beiträge: 14

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

8

Mittwoch, 31. Januar 2007, 13:31

hi leute,

ich habe dieses problem mit der hängenden verbindung über internet und wlan auch. nun habe ich deswegen auch das update auf 2.6.18-4-ixp4xx installiert. nun ist aber die übertragung per lan von 5 mb/s gesunken. sie pendelt jetzt immer zwischen 150 kb/s bis zu 5 MB/s. warum und wieso? ist das bei euch auch so?

gruß jannes

EDIT: entwarnung. die langsame übertragungsrate war nur, da gerade ein verzeichnis mit 3.000 1 - 5 kb datein kopiert wurde. bei großen dateien klappt es ohne probleme.

9

Donnerstag, 1. Februar 2007, 18:19

hi all,
yep, mit 2.6.18-4-ixp4xx haben ische meine probleme geloest!
gruesse
frostie

Social Bookmarks