Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 4. Januar 2007, 10:34

kann NSLU2 kein ping / ssh

[LEFT]hi,
ich bin recht neu hier und habe auch nicht viel erfahrung mit linux. trotzdem habe ich debian auf der nslu2 installiert und kann sagen, dass es ueber eine sehr lange zeit auch sehr gut gelaufen ist. ich muss daher ein lob aussprechen, echt super! habe auch "move /dev and /var to ram" gemacht, klappte super mit dem spinn down.


nun zu meinem problem: nach einem gestrigen update:
apt-get update
apt-get upgrade
und einem anschliesenden reboot (shutdown -r now) startet die box nicht mehr richtig.
ich kann die box nicht pingen (statische ip) und ssh(open-ssh) klappt natuerlich auch nicht. ich habe es auch schon ohne hdd versucht, jedoch kann ich auch nichts gutes berichten, ping klappt nicht und ssh auch nicht.
des weiteren sehe ich mit und ohne hdd die selbe abfolge der leds.
zum schluss habe ich folgende lampen brennen:
ready gelb orange
network gruen (blinked etwas wenn ich versuche es zu pingen)

es scheint, als ob etwas auf der nslu2 nicht ganz stimmt
.

hat jemand ne idee? ich moechte wenn es geht nicht an der nslu2 loeten. ich habe auch schon versucht etwas in /var/log/boot auf der festplatte zu schreiben oder zu finden, jedoch ist diese leer.
HILFE!
frostie
[/LEFT]

Anzeigen

2

Donnerstag, 4. Januar 2007, 11:59

Hallo frostie77,

Die Datei, die möglicherweise die möglicherweise einen Hinweis auf den Fehler enthält heißt "/var/log/messages".

Interessant wären die letzten, sagen wir mal 30 Zeilen.

Gruß

vofiwg
nslu2@266MHz; Kernel 2.6.18-4-ixp4xx; wlan: Siemens Gigaset USB Stick 54 (zd1211), HDD: 2,5" 60GB Samsung MP0603H in Fujitsu Handydrive-Gehäuse

Anzeigen

3

Donnerstag, 4. Januar 2007, 12:08

/var/log/messages

hi,
hier die datei messages:
1 Dec 3 06:47:12 anaNAS syslogd 1.4.1#18: restart.
2 Dec 3 07:10:27 anaNAS -- MARK --
3 Dec 3 07:30:28 anaNAS -- MARK --
4 Dec 3 07:50:28 anaNAS -- MARK --
5 Dec 3 08:10:29 anaNAS -- MARK --
6 Dec 3 08:30:29 anaNAS -- MARK --
7 Dec 3 08:50:29 anaNAS -- MARK --
8 Dec 3 09:10:30 anaNAS -- MARK --
9 Dec 3 09:30:30 anaNAS -- MARK --
10 Dec 3 09:50:31 anaNAS -- MARK --
11 Dec 3 10:10:31 anaNAS -- MARK --
12 Dec 3 10:30:32 anaNAS -- MARK --
13 Dec 3 10:50:32 anaNAS -- MARK --
14 Dec 3 11:10:33 anaNAS -- MARK --
.
.
.
71 Dec 4 06:10:55 anaNAS -- MARK --
72 Dec 4 06:25:24 anaNAS syslogd 1.4.1#18: restart.
73 Dec 4 06:50:56 anaNAS -- MARK --
74 Dec 4 07:10:57 anaNAS -- MARK --
75 Dec 4 07:30:57 anaNAS -- MARK --
76 Dec 4 07:50:57 anaNAS -- MARK --
77 Dec 4 08:10:58 anaNAS -- MARK --
78 Dec 4 08:30:58 anaNAS -- MARK --
79 Dec 4 08:50:59 anaNAS -- MARK --
80 Dec 4 09:10:59 anaNAS -- MARK --
81 Dec 4 09:30:59 anaNAS -- MARK --
82 Dec 4 09:51:00 anaNAS -- MARK --
83 Dec 4 10:11:00 anaNAS -- MARK --
84 Dec 4 10:31:01 anaNAS -- MARK --
85 Dec 4 10:51:01 anaNAS -- MARK --
86 Dec 4 11:11:01 anaNAS -- MARK --
87 Dec 4 11:31:02 anaNAS -- MARK --
88 Dec 4 11:51:02 anaNAS -- MARK --
89 Dec 4 12:11:03 anaNAS -- MARK --
90 Dec 4 12:31:03 anaNAS -- MARK --
91 Dec 4 12:51:03 anaNAS -- MARK --
92 Dec 4 13:11:04 anaNAS -- MARK --
93 Dec 4 13:31:04 anaNAS -- MARK --
94 Dec 4 13:51:05 anaNAS -- MARK --
95 Dec 4 14:11:05 anaNAS -- MARK --
96 Dec 4 14:31:05 anaNAS -- MARK --
97 Dec 4 14:51:06 anaNAS -- MARK --
98 Dec 4 15:11:06 anaNAS -- MARK --
99 Dec 4 15:31:07 anaNAS -- MARK --
100 Dec 4 15:36:18 anaNAS shutdown[11950]: shutting down for system reboot
101 Dec 4 15:36:26 anaNAS kernel: Kernel logging (proc) stopped.
102 Dec 4 15:36:26 anaNAS kernel: Kernel log daemon terminating.
103 Dec 4 15:36:27 anaNAS exiting on signal 15

kann man dort was erkennen?
gruesse und vielen dank
frostie

4

Donnerstag, 4. Januar 2007, 13:35

Hallo frostie77,

Dein System ist am 4. Dezember gg. 15:36 Uhr heruntergefahren.

Ist die Kiste seitdem nicht mehr gelaufen oder ist nur das Datum falsch eingestellt gewesen?

Wie genau bist Du an die Datei gekommen? Hast Du die Platte an Deinen PC angestöpselt? Welches Betriebssystem?


vofiwg
nslu2@266MHz; Kernel 2.6.18-4-ixp4xx; wlan: Siemens Gigaset USB Stick 54 (zd1211), HDD: 2,5" 60GB Samsung MP0603H in Fujitsu Handydrive-Gehäuse

5

Donnerstag, 4. Januar 2007, 13:51

datum

hi,
ja, das datum ist absolut falsch (hatte es jedoch schon mal richtig eingestellt). vielleicht sollte ich auch noch sagen, dass die nslu2 lange ausgeschaltete war.
ich hab nen linux rechner und hab dort die platte angeschlossen.
gruesse
frostie

trapperjohn

Fortgeschrittener

Beiträge: 558

Wohnort: Bremen

Beruf: SW-Entwickler

  • Nachricht senden

6

Donnerstag, 4. Januar 2007, 13:52

Du müsstest mal das eigentliche boot.log aktivieren, auf die Schnelle konnte ich aber nicht finden, wo das konfiguriert wird.

Weißt du denn noch, welche Paket beim Upgrade installiert wurden? Evtl. wurden irgendwelche Konfigurationen von dir überschrieben, sodass die Box jetzt (bspw.) mit einer anderen IP startet o.ä.
Gruß,
Flo

7

Donnerstag, 4. Januar 2007, 14:05

Die ip steht in /etc/network/interfaces
nslu2@266MHz; Kernel 2.6.18-4-ixp4xx; wlan: Siemens Gigaset USB Stick 54 (zd1211), HDD: 2,5" 60GB Samsung MP0603H in Fujitsu Handydrive-Gehäuse

8

Donnerstag, 4. Januar 2007, 14:11

danke fuer die antworten.
das mit dem bootlog habe ich schon probiert. leider schreibt er nit in diese datei
/var/log/boot:
(Nothing has been logged yet.)
klappt also leider nicht. meine /etc/network/interfaces:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.77
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.1.1
dns-search example.org

scheint auch ok zu sein.
ausserdem befindet diese datei sich auf der platte. ohne die platte kann ich die nslu2 auch nicht erreichen. zumindest nicht nem ping.
gruesse
frostie

9

Donnerstag, 4. Januar 2007, 14:16

Ich hatte neulich auch das Problem, dass meine nslu2 nach einem Stromausfall nicht mehr neu neu von der Platte bootete. Ich hab die Platte dann an meinen PC angestöpselt und e2fsck drüber laufen lassen. Es lagen mehrere Dateisystemfehler vor, die behoben wurden. Danach funktionierte es auch wieder an der nslu2.

vofiwg
nslu2@266MHz; Kernel 2.6.18-4-ixp4xx; wlan: Siemens Gigaset USB Stick 54 (zd1211), HDD: 2,5" 60GB Samsung MP0603H in Fujitsu Handydrive-Gehäuse

10

Donnerstag, 4. Januar 2007, 14:19

vofiwg:
konntest du die nslu2 ohne platte ansprechen? ich habe hier schon ein paar mal gelsen, dass man die nslu2 auch ohne platte anpingen kann, oder sich sogar auf ihr einloggen kann. dabei meine ich nicht den redboot oder update-mode.
danke

11

Donnerstag, 4. Januar 2007, 14:23

Muss ich erst ausprobieren. Ist schon ziemlich lange her, dass ich mich ohne Platte auf die nslu2 eingeloggt habe.

Dauert ein Weilchen.

vofiwg
nslu2@266MHz; Kernel 2.6.18-4-ixp4xx; wlan: Siemens Gigaset USB Stick 54 (zd1211), HDD: 2,5" 60GB Samsung MP0603H in Fujitsu Handydrive-Gehäuse

12

Donnerstag, 4. Januar 2007, 14:52

Sorry frostie77,

Ich kriegs derzeit überhaupt nicht hin. Muss erst nochmal in den HOWTOs graben. Habe aber den Verdacht, dass es überhaupt nicht geht, da auf meinem Gerät durch ein update APEX als Bootloader geflasht wurde.
Dadurch kann man den Kernel per "apt-get" austauschen und muss nicht neuen kernel auf die nslu2 flashen.

vofiwg
nslu2@266MHz; Kernel 2.6.18-4-ixp4xx; wlan: Siemens Gigaset USB Stick 54 (zd1211), HDD: 2,5" 60GB Samsung MP0603H in Fujitsu Handydrive-Gehäuse

13

Donnerstag, 4. Januar 2007, 14:55

vielen dank fuers nachschauen!
das mit dem bootloader von dir, ist das auch bei mir der fall?
gruesse
frostie

14

Donnerstag, 4. Januar 2007, 15:02

Ich hatte zunächst das Image von Evil-Devil installiert und später dann nach den "upgrade instructions" auf http://www.cyrius.com/debian/nslu2/ umgestellt.
Erst bei dieser Umstellung wird der Bootloader ausgetauscht.

vofiwg

PS: Der bootlogd lässt sich in der Datei /etc/default/bootlogd aktivieren:
# Run bootlogd at startup ?
BOOTLOGD_ENABLE=Yes
nslu2@266MHz; Kernel 2.6.18-4-ixp4xx; wlan: Siemens Gigaset USB Stick 54 (zd1211), HDD: 2,5" 60GB Samsung MP0603H in Fujitsu Handydrive-Gehäuse

15

Donnerstag, 4. Januar 2007, 15:23

hi,
das mit dem bootlogd hab ich schon probiert. ich glaube die nslu2 bootet nicht soweit, daher habe ich auch keinen eintrag in /var/log/boot.
die upgrade instructions sind interessant, habe jedoch rc1 benutzt.
gruesse
frostie

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

16

Donnerstag, 4. Januar 2007, 16:35

N'Abend,

kurze Anmerkung, der Bootloader wird nicht ausgetauscht, Apex ist als 2nd Stage Loader installiert, Redboot startet immer noch zuerst.

bye
JrB
"Supporting joe users worldwide" <- that's our motto


17

Donnerstag, 4. Januar 2007, 16:56

danke jrb.
bin mir jedoch nicht sicher wie mir das weiterhilft.
gruesse
frostie

18

Samstag, 6. Januar 2007, 10:55

hi,
hat keiner eine idee wie ich die nslu2 wieder zum laufen bekomme?
muss ich alles neu instllieren?
danke
frostie

Social Bookmarks