Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

ifish

Schüler

  • »ifish« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

1

Mittwoch, 25. Oktober 2006, 18:28

Probleme mit nfs-kernel-server

Hallo zusammen,
nfs funktioniert bei mir nicht. Gestartet habe ich mit /init.d/nfs-kernel-server start. Die Datei exports ist in Ordnung. Folgende Ausgabe kommt bei exportfs -a:

Quellcode

1
2
3
4
Exporting directories for NFS kernel daemon...exportfs: No options for /home/export *: suggest *(sync) to avoid warning
exportfs: /etc/exports [2]: Neither 'subtree_check' or 'no_subtree_check' specified for export "*:/home/export".
  Assuming default behaviour ('subtree_check').
  NOTE: this default will change with nfs-utils version 1.1.0


Der Eintrag der Fehler liefert ist nur für die Fehlersuche, meine exports sieht wie folgt aus:

Quellcode

1
2
/home/dbox2     *(rw,async,no_root_squash,no_subtree_check,anongid=1001,anonuid=1001) 
/home/export    *


Beim Versuch des mounts kommt folgende Fehlermeldung:

Quellcode

1
2
 mount -t nfs 192.168.178.8:/home/export /mnt/horus
mount to NFS server '192.168.178.8' failed.


Portmap ist installiert, leider liefert ein tail -f /var/log/messages auch keine weiteren Anhaltspunkte.
Der nfsd läuft jedenfalls.

Hat jemand Tipps für eine Fehlersuche??

Schöne Grüße
Ifish

Anzeigen

trapperjohn

Fortgeschrittener

Beiträge: 558

Wohnort: Bremen

Beruf: SW-Entwickler

  • Nachricht senden

2

Mittwoch, 25. Oktober 2006, 19:35

Schwer zu sagen, deine Fehlermeldungen scheinen nur Warnings zu sein, die du ignorieren kannst.

Funktioniert der Zugriff auf die dbox2 Freigabe denn?
Gruß,
Flo

Anzeigen

ifish

Schüler

  • »ifish« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

3

Mittwoch, 25. Oktober 2006, 20:12

@trapperjohn,
nein auch nicht, aber der Zugriff erfolgt mit der Dbox2, was nicht immer so ganz einfach ist, daher der "Test" mit einer anderen NFS-Freigabe.

Was mich irritiert, sind auch die fehlenden Einträge in der syslog, womöglich läuft nfs gar nicht richtig...

Bei unslung hatte ich nfs nach einigen kleineren Hürden problemlos am laufen...

4

Mittwoch, 25. Oktober 2006, 20:21

Servus
hast du alle Kernel-Module installiert? Und nach welcher Anleitung bist du vorgegangen?

Gruss,
EvilDevil

Spooky

CO-Admin

Beiträge: 355

Firmwareversion / your current Firmware: V2.3R25-uNSLUng-able-4.2-alpha

  • Nachricht senden

5

Mittwoch, 25. Oktober 2006, 20:22

@ifish,

mach bitte mal ein "ps -ax" und poste hier die Ausgabe.

Die export Meldung (Warnings) dürfte so ok sein. Taste Dich erstmal langsam ran und versuche es ohne die Parameter "no_subtree_check,anongid=1001,anonuid=1001" in Deiner /etc/exports. Manche NFS Server reagieren auch giftig auf den World Parameter "*". Gib stattdessen mal direkt die IP Adresse der dbox2 an.

Spooky
Unmögliches wird sofort erledigt, Wunder dauern etwas länger.

6

Mittwoch, 25. Oktober 2006, 20:32

Hi,

ich hatte ähnliche Probleme, nachdem Anfang Oktober zunächst nfs-kernel-server und ein paar Tage später portmap per dist-upgrade "aktualisiert" wurden.

Erst nach einem Neustart (restart) des nfs-kernel-server konnte ich von der DBox wieder auf die Freigaben zugreifen.

Habe mit nem Kollegen dann einiges probiert, aber half nichts. Schließlich bin ich umgestiegen auf Runlevel 3 und lasse beim hochfahren den nfs-kernel-server erneut starten.

Ist zwar nicht die eleganteste Variante, aber es läuft wieder :-)

Gruss
2be3

ifish

Schüler

  • »ifish« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

7

Mittwoch, 25. Oktober 2006, 21:36

Hallo @spooky,
ich poste mal, wie ich nfs-kernel-server gestartet habe, dann die Ausgabe von ps -ax, dann noch eine Ausgabe von "status":



Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
Starting NFS kernel daemon: nfsd.
Horus:~# /etc/init.d/nfs-kernel-server status
nfsd not running
Horus:~# ps -ax
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
  PID TTY      STAT   TIME COMMAND
    1 ?        S      0:05 init [2] 
    2 ?        SN     0:00 [ksoftirqd/0]
    3 ?        S<     0:00 [events/0]
    4 ?        S<     0:00 [khelper]
    5 ?        S<     0:00 [kthread]
   16 ?        S<     0:00 [kblockd/0]
   19 ?        S<     0:00 [khubd]
   62 ?        S      0:00 [pdflush]
   63 ?        S      0:00 [pdflush]
   65 ?        S<     0:00 [aio/0]
   64 ?        S      0:00 [kswapd0]
   83 ?        S<     0:00 [ata/0]
   85 ?        S<     0:00 [scsi_eh_0]
   88 ?        S      0:00 [mtdblockd]
   89 ?        S      0:00 [nftld]
  131 ?        S<     0:00 [scsi_eh_1]
  132 ?        S<     0:00 [usb-storage]
  135 ?        S<     0:00 [scsi_eh_2]
  136 ?        S<     0:00 [usb-storage]
  202 ?        S      0:00 [kjournald]
  426 ?        S      0:00 [kjournald]
  474 ?        D      0:00 [IxOsal 1]
  477 ?        S<     0:00 [ixp400_eth]
  480 ?        S<     0:00 [ixp400_eth]
  482 ?        S<     0:00 [ixp400_eth]
  486 ?        S      0:00 [ixp400 eth0]
  500 ?        Ss     0:00 /sbin/portmap
  596 ?        Ss     0:00 /sbin/syslogd
  606 ?        Ss     0:00 /sbin/klogd -x
  619 ?        S      0:00 /usr/sbin/lighttpd -f /etc/lighttpd/lighttpd.conf
  643 ?        Ss     0:00 /usr/sbin/inetd
  646 ?        Ss     0:00 /usr/sbin/nmbd -D
  648 ?        Ss     0:00 /usr/sbin/smbd -D
  657 ?        S      0:00 /usr/sbin/smbd -D
  661 ?        Ss     0:00 /usr/sbin/sshd
  685 ?        Ss     0:00 /sbin/rpc.statd
  695 ?        Ss     0:00 /usr/sbin/rpc.idmapd
  712 ?        Ss     0:00 /usr/sbin/cron
  752 ttyS0    Ss+    0:00 /sbin/getty 115200 ttyS0
  756 ?        Ss     0:01 sshd: root@pts/0 
  760 pts/0    Ss     0:00 -bash
  781 pts/0    R+     0:00 ps -ax



Komisch, erst startet NFS, dann läuft nfsd doch nicht, hatte ich bisher nicht gesehen, bin nach dem Start von einem laufenden nfsd ausgegangen:

Quellcode

1
Starting NFS kernel daemon: nfsd.

..war wohl falsch die Annahme.

@evilDevil
Ich bin nach der Anleitung vorgegangen:
http://wiki.nslu2-info.de/pmwiki.php/How…anSlugNFSServer

Ich nahm an, dass die Module schon beim Kernel bzw. Image vorhanden sind, vermutlich sollte ich noch das entsprechende Modul für nfs herunterladen??

Was mach ich damit (Endung ipkg), ..bei einem "normalen" Debian landen die im Verzeichnis /lib/modules/kernelversion..

Schon mal vielen Dank
Schöne Grüße
Ifish

8

Donnerstag, 26. Oktober 2006, 20:34

@iFish:
wenn bei dir ein lsmod nicht die folgenden Module anzeigt, musst du sie nachinstallieren:

Quellcode

1
2
3
4
5
nfs
nfsd
exportfs
lockd
sunrpc

Wie man die installiert ist übrigens auch in der Anleitung beschrieben:

Quellcode

1
dpkg --force-architecture -i kernel-module-*

danach noch ein

Quellcode

1
2
depmod -a
/etc/init.d/nfs-kernel-server restart

und es sollte laufen, falls nicht, probier mal modprobe -v nfsd und dann erneut /etc/init.d/nfs-kernel-server restart

Gruss,
EvilDevil

ifish

Schüler

  • »ifish« ist der Autor dieses Themas

Beiträge: 57

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

9

Freitag, 3. November 2006, 14:42

Asche auf meine Haupt --> ich hatte die Anleitungen nicht richtig gelesen. Nach installieren der entsprechenden Module und modprobe funktioniert auch NFS Kernelserver einwandfrei.

Vielen Danke für die Antworten und das geniale Debian auf der Slug (macht jedenfalls mehr Spaß als unslung)

Schöne Grüße
Ifish

Social Bookmarks