Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

tobschne

Anfänger

  • »tobschne« ist der Autor dieses Themas

Beiträge: 3

Firmwareversion / your current Firmware: Debian

Wohnort: Bamberg

Beruf: Student

  • Nachricht senden

1

Dienstag, 12. September 2006, 21:25

webcam PCVC680k mit pwc nur graue Bilder

Hallo,
ich habe ein Problem mit meiner Philips Webcam PCVC680K und dem pwc-Treiber. Ich bekomme immer nur graue Bilder.

Ich habe schon vieles ausprobiert, u.a. nslu2 mehrmals komplett neu installiert, sowohl mit Unoffizielle DebianSlug Images (pre DebianSlug 3.10beta) von http://www.student-zw.fh-kl.de/~pasc0010/debianslug, als auch mit Modifizierte DebianSlug 3.10beta Images(+Quota +DVB +PWC +Coda +NTFS-3g) von http://www.student-zw.fh-kl.de/~pasc0007/, aber nichts wollte klappen.

Habe auch alles durchprobiert wie im bereits gelösten Thema: webcam PCVC740 graue Bilder
http://www.nslu2-info.de/showthread.php?t=4296.

Was soll ich tun, bzw. woran kann es liegen.

Werde die nslu2 nochmal neu flashen und debain per debootstrap neu installieren.

Welches image sollte ich am besten verwenden und debian sid oder eher etch oder sarge?

Webcam funktioniert unter Windows, also nicht defekt.

LG tobschne

Anzeigen

2

Mittwoch, 13. September 2006, 15:21

Wahrscheinlich liegt es eher an den Einstellungen...
Hast du setpwc schon installiert und ausprobiert?

Gruss,
EvilDevil

Anzeigen

tobschne

Anfänger

  • »tobschne« ist der Autor dieses Themas

Beiträge: 3

Firmwareversion / your current Firmware: Debian

Wohnort: Bamberg

Beruf: Student

  • Nachricht senden

3

Mittwoch, 13. September 2006, 22:22

setpwc habe ich auch schon installiert und verwendet, trotzdem keine besseren Ergebnisse.

Quellcode

1
2
3
modprobe pwc
setpwc
vidcat -d /dev/video0 -p y -s 640x480 -o test.jpg



Alles ohne Fehlermeldungen, aber das Bild test.jpg ist eben nur grau und immer gleich 5425 Byte groß.

Was ist eigentlich besser, die unoffiziellen Debian 3.10beta Images oder die neueren modifizierten?

Was könnte ich noch ausprobieren? Bei meinem Bruder funktioniert die Webcam einwandfrei mit dem pwc Treiber, allerdings auf x86 und unter Debian Sarge.

LG tobschne

4

Donnerstag, 14. September 2006, 06:52

Hi,
also

Quellcode

1
2
setpwc 
vidcat -p y -s 640x480 -o datei.jpg

bringt in etwa solche Bilder:
http://nu.linuxdienstleister.de/gallery/index.php?108
Die Webcam wird wie folgt erkannt:

Quellcode

1
2
3
4
5
6
7
8
Linux video capture interface: v1.00
pwc: Philips webcam module version 10.0.12-rc1 loaded.
pwc: Supports Philips PCA645/646, PCVC675/680/690, PCVC720[40]/730/740/750 & PCVC830/840.
pwc: Also supports the Askey VC010, various Logitech Quickcams, Samsung MPC-C10 and MPC-C30,
pwc: the Creative WebCam 5 & Pro Ex, SOTEC Afina Eye and Visionite VCS-UC300 and VCS-UM100.
pwc: Philips PCVC675K (Vesta) USB webcam detected.
pwc: Registered as /dev/video0.
usbcore: registered new driver Philips webcam

Das System ist DebianSlug 3.10beta (original) mit per bitbake kompilierten pwc-modul, sollte also äquivalent zu meinem Image sein mit Debian Sid.
Mal ne andere Frage:
Hast du das hier benutzt
http://www.student-zw.fh-kl.de/~pasc0007….4_ixp4xxle.ipk
(was veraltet ist)
oder das hier:
http://www.student-zw.fh-kl.de/~pasc0007…r0_ixp4xxle.ipk
(was relativ neu ist und auch auf der oben genannten NSLU2 läuft)
?

Gruss,
EvilDevil

tobschne

Anfänger

  • »tobschne« ist der Autor dieses Themas

Beiträge: 3

Firmwareversion / your current Firmware: Debian

Wohnort: Bamberg

Beruf: Student

  • Nachricht senden

5

Samstag, 16. September 2006, 10:25

Hallo,

habe nochmal komplett alles neu installiert und bin wieder von der modifizierte DebianSlug 3.10beta Images Variante auf die unoffizielle DebianSlug Images (pre DebianSlug 3.10beta) Variante umgestiegen.

Und nach ein paar Versuchen hats endlich geklappt, komisch ist nur, dass ich diese Konstellation auch schonmal hatte, ohne Funktion.

Ok, wunderbar, trotzdem vielen Dank.

Ich werde hier dann nochmal genau beschreiben, was ich wie wo gemacht habe und dann kann ich das Thema auf gelöst setzen.

Nochmal so allgemein, ich nutze die Images von http://www.student-zw.fh-kl.de/~pasc0010/debianslug und http://www.student-zw.fh-kl.de/~pasc0007/
Was ist denn nun besser, die unoffizellen von http://www.student-zw.fh-kl.de/~pasc0010/debianslug oder die modifizierten vo http://www.student-zw.fh-kl.de/~pasc0007/, die neuer sind?

LG Tobias

6

Samstag, 16. September 2006, 15:07

Unterschiede zwischen den DebianSlug Firmware Versionen

Hi,
hab deine Frage mal in einem gesonderten Thread beantwortet, da sie vielleicht auch für andere ganz interessant sein könnte: http://www.nslu2-info.de/showthread.php?p=18837

Gruss,
EvilDevil

Social Bookmarks