Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 12. September 2006, 14:07

[gelöst] Platten mal /dev/sda und mal /dev/sdb

Hallo zusammen,

bei mir läuft DebianSlug problemlos bis auf kleine Ausrutscher. Ich habe eine Festplatte mit dem Debian drauf un den Rest für Samba Freigabens. Auf eine zweit soll Nachts per Rsync alles mit der Backupfunktion und 7 Tages rückblick gesichert werden, was auch kein Problem ist.

Allerdings scheint die NSLU2 nicht unterscheiden zu können welche Platte welche ist. Daher ist manchmal die Hauptplatte sda und dann wieder sdb wonach das booten natürlich fehlschlägt.

Weiß jemand wie das zu vermeiden ist?

Gruß und Danke im Voraus,
Dpuppy

Anzeigen

2

Dienstag, 12. September 2006, 14:43

Hi, Zum Einen wäre da: http://www.pro-linux.de/news/2003/5938.html Zum Anderen steht in der /initrd/linuxrc irgendwo eine Zeile mit UUID="XXXXXXXX" exec /boot/... Du solltest die UUID mit der UUID der Hauptplatte vergleichen (dumpe2fs /dev/sda1) und, falls verschieden, korrigieren. Fange am Besten mit dem 2. Ansatz an, der erfordert den geringsten Aufwand bei größerer Problemlösungswahrscheinlichkeit ;) Gruss, EvilDevil

Anzeigen

3

Dienstag, 12. September 2006, 15:40

Hi EvilDevil,

erstmal danke für die ultraschnelle Antwort. Die UUID stand allerdings schon richtig drinn.

Ich hab dann mal versucht Labels zu vergeben und bislang funktioniert alles. Ich warte mal noch einige boots ab und falls nix mehr schief läuft bis dahin ist der Thread gelöst.

Danke nochmal.

Jetzt muss ich nur noch rausfummeln wie ich in der SSH Konsole genauso Umlaute sehen kann wie im Samba. :)

Gruß,
Dpuppy

5

Donnerstag, 14. September 2006, 08:18

Ok um das Themas sinnvoll abzuschließen: Es scheint jetzt zu funktionieren. Da die UUID Einträge in der /initrd/linuxrc gestimmt haben habe ich versucht den Festplatten Labels zu geben. In meinem fall war das:

Quellcode

1
2
3
4
5
[COLOR=#660000]tune2fs -L root /dev/sda1
tune2fs -L data1 /dev/sda5
tune2fs -L data2 /dev/sdb5
tune2fs -L data3 /dev/md0
[/COLOR]


Danach habe ich meine fstab modifiziert damit mit den Labels gearbeitet wird.

Quellcode

1
2
3
4
5
6
[COLOR=#660000]/dev/hda2    none       swap    sw         0 0
LABEL=root   /          ext3    defaults   0 1
LABEL=data1  /mnt/data1 ext3    defaults   0 2
LABEL=data2  /mnt/data2 ext3    defaults   0 2
LABEL=data3  /mnt/data3 ext3    defaults   0 2
[/COLOR]


Das wars auch eigentlich schon. In meinem fall musste ich für das raid noch einen link im rc2.d verzeichniss auf das mdadm-raid Startscript machen.

Gruß und Danke nochmal,

Dpuppy

6

Donnerstag, 14. September 2006, 08:49

Also das HowTo (http://wiki.nslu2-info.de/pmwiki.php/HowTo/DebianSlugUmlaute) wegen den Umlauten hat auch funktioniert.

Quellcode

1
[/FONT]export LC_ALL=de_DE@euro


in die /root/.bashrc und /etc/profiles eingetragen und in Samba einfach

Quellcode

1
2
unix charset = iso-8859-15
display charset = iso-8859-15


eingegeben. Leider war die Platte schon ziemlich voll sodaß ich die Umlaute nochmal per Hand korrigieren musste. Ging aber. Ich kann jetzt endlich in Samba, Login per SSH sowie ber SCP die Umlaute richtig sehen.

Gruß,
Dpuppy

Social Bookmarks