Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Angels

Anfänger

  • »Angels« ist der Autor dieses Themas

Beiträge: 5

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

1

Freitag, 18. August 2006, 00:32

Weden DebianSlug noch DebianInstaller gehen - Festplatten/Bootproblem

Langsam verzweifele ich. Ich bekomme einfach kein Debian mehr auf den NSLU2 drauf. Ich hatte vor 2-3Monaten Debian mittels Installer ohne Schwierigkeiten installiert, leider brauchte ich die Festplatte für was Anderes und wollte jetzt wieder Debian draufinstallieren.

Mit DebianSlug kann ich die Festplatte ansprechen und die komplette Installation vollziehen. Nach dem Reboot kann der NSLU2 nicht mehr via Netzwerk angesprochen werden. Alle Punkte der Installation wurden gemacht und alles wurde peinlichst genau beachtet und überprüft. Ich habe mir jetzt (noch nicht) die Mühe gemacht und die Logfiles ausgewertet.

Mittels DebianInstaller hatte ich damals den Slug mit genau der gleichen Hardware installiert. Nach dem Flashvorgang und login mittels installer/install kommeich in das configmenu. Nach Auswahl des Mirrors (ist der Mirror eigentlich egal?) und Herunterladen der Startpakete bekomme ich die Fehlermeldung dass, das Kernelimage nicht mit der zu installierenden Version zusammenpasst (eventuell falsche Auswahl des Mirrors?).

Bei der Festplattenauswahl sehe ich lediglich /dev/mtdblock0 bis 4 (ist der interne Speicher vermute ich?). Die angeschlossene Festplatte taucht nicht auf (weder an Port1 noch an Port2, weder diese noch eine andere Festplatte)

Mit dem Standardimage von Linksys wird die Platte auch sauber erkannt.

Eventuell hat jemand ja eine Idee in die richtige Richtung. Entschuldigt bitte komische Formulierungen oder Fehler: Ich bin etwas sehr angeschlagen zu dieser Stunde und sollte etwas Schlaf nachholen :)

Anzeigen

Angels

Anfänger

  • »Angels« ist der Autor dieses Themas

Beiträge: 5

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

2

Freitag, 18. August 2006, 16:06

Ein neuer Tag, ein neuer Versuch. Wie gehabt, nichts klappt :)

- debianslug-nslu2-20060525185051.flashdisk.img vom EvilDevil installiert

- sid nach Installationsanleitung versucht zu installieren.
- http://ftp.debian.org/ hat die Pakete nicht
- ftp://ftp.nl.debian.org hat die Pakete, aber sind corrupt.
- gibt es eine Liste der Server, welche die Pakete für den Slug haben?

- sarge nach Installationsanleitung versucht zu installieren.
- Pakete werden einwandfrei von http://ftp.debian.org geholt.
- Probleme fangen mit der Installation von nslu2-utils und modutils an:

Zitat

The following packages have unmet dependencies:
devio: Depends: libc6 (>= 2.3.5-1) but 2.3.2.ds1-22sarge3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

- wenn ich "apt-get -f install" ausführe werden logischerweise die pakete wieder deinstalliert...

Irgendwie komme ich nicht weiter... Wenn jemand Lösungsansätze hat, immer her damit.

Anzeigen

Eiffel

Profi

Beiträge: 619

Beruf: SAP Anwendungsbetreuer

  • Nachricht senden

3

Freitag, 18. August 2006, 16:17

http://ftp-stud.fht-esslingen.de/debian

probiers mit dem server mal

habe sid damit am laufen

Angels

Anfänger

  • »Angels« ist der Autor dieses Themas

Beiträge: 5

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

4

Freitag, 18. August 2006, 23:08

Zitat von »Eiffel;18053«

http://ftp-stud.fht-esslingen.de/debian

probiers mit dem server mal

habe sid damit am laufen



Danke dir, werde ich doch gleich mal ausprobieren :) - Ich melde mich.

Angels

Anfänger

  • »Angels« ist der Autor dieses Themas

Beiträge: 5

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

5

Samstag, 19. August 2006, 04:34

Mit dem Mirror lässt sich SID installieren. Hatte Zwischendurch ein paar timeouts (habe glaube gerade die Spiegelungszeit erwischt). Letztendlich hat er aber soweit ich gesehen habe alle Pakete gezogen und installiert.

Nach Abarbeitung der ganzen Anleitung bleibt der Erfolg aus. Ich kann den Slug nicht anpingen (auch nicht nach 5-10min Wartezeit!).

Danach habe ich den Slug nochmals geflashed, chrooted und in den logfiles gewühlt. Nichts! - die boot.log ist leer, die bootstrap.log gibt nichts aussagekräftiges her.

Da die boot.log leer ist vermute ich das die Platte garnicht als Bootplatte genommen wird. (turnup disk /dev/sda1 -t ext3 wurde gemacht!)

Noch jemand eine Idee, warum es genau nach Tutorial nicht funktioniert?

6

Samstag, 19. August 2006, 16:50

Zitat von »Angels;18052«

Ein neuer Tag, ein neuer Versuch. Wie gehabt, nichts klappt :)

- sarge nach Installationsanleitung versucht zu installieren.
- Pakete werden einwandfrei von http://ftp.debian.org geholt.
- Probleme fangen mit der Installation von nslu2-utils und modutils an:

The following packages have unmet dependencies:
devio: Depends: libc6 (>= 2.3.5-1) but 2.3.2.ds1-22sarge3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Hast Du auch beachtet dass:
nslu2-utils is not in the stable feed, so get it and it's dependencies directly from the pool:
wget http://debian.planetmirror.com/debian/po…0+r58-2_all.deb
dpkg -i slugimage_0.10+r58-2_all.deb
wget http://debian.planetmirror.com/debian/po…o_1.2-1_arm.deb
dpkg -i --force-depends devio_1.2-1_arm.deb
wget http://debian.planetmirror.com/debian/po…0+r58-2_arm.deb
dpkg -i nslu2-utils_0.10+r58-2_arm.deb


Die Fehlermeldung besagt eindeutig, dass das gewählte devio-Paket nicht für Sarge generiert ist.

Angels

Anfänger

  • »Angels« ist der Autor dieses Themas

Beiträge: 5

Firmwareversion / your current Firmware: anderes

  • Nachricht senden

7

Sonntag, 20. August 2006, 01:35

Zitat von »debiano;18078«

Hast Du auch beachtet dass:
nslu2-utils is not in the stable feed, so get it and it's dependencies directly from the pool:
wget http://debian.planetmirror.com/debian/po…0+r58-2_all.deb
dpkg -i slugimage_0.10+r58-2_all.deb
wget http://debian.planetmirror.com/debian/po…o_1.2-1_arm.deb
dpkg -i --force-depends devio_1.2-1_arm.deb
wget http://debian.planetmirror.com/debian/po…0+r58-2_arm.deb
dpkg -i nslu2-utils_0.10+r58-2_arm.deb


Die Fehlermeldung besagt eindeutig, dass das gewählte devio-Paket nicht für Sarge generiert ist.


Ja habe ich. Kann es aber gerne nochmal probieren :) - Ich bin nach Installationsanleitung OHNE apt-get dist-upgrade durchzuführen nachgegangen und habe die entsprechenden Punkte der sarge Installation durchgeführt. Abgesehen davon funktioniert die sid Installation auch nicht :)

uxtuner

Anfänger

Beiträge: 1

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

8

Freitag, 25. August 2006, 09:20

liegt am udev ...
Ich mußte es deinstallieren, damit er wieder von Platte bootet

Social Bookmarks