Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Poelchen1337« ist der Autor dieses Themas

Beiträge: 136

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Weinstadt

Beruf: Technischer Zeichner

  • Nachricht senden

1

Freitag, 2. Juni 2006, 15:06

APACHE - anderer DOCUMENT ROOT - ERROR 403

so hej

jetzt hab ich alle probleme von der welt geschaffen ..


APACHE läuft SAMBA ebenfalls


ich hab meine EXTENDET (/dev/sda3/)

auf /mnt/filez

gemountet bzw in die FSTAB eingetragen...

alles klappt


blos wenn ich auf den apache zugreife ( hab document root) auf /mnt/filez gelegt

zeigt er mir am FORBIDDEN error 403 ..


also d.h. die berechtigungen stimmen nicht ..


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
<Directory /mnt/filez>
    Allow fom All 
</Directory>
 
<Directory /mnt/filez>
 
    Options Indexes Includes FollowSymLinks MultiViews
 
    AllowOverride All
 
    Order allow
    Allow from all 
</Directory>


stimmt was hier nicht =??


danke für antwort..

gruß Robert

Anzeigen

2

Freitag, 2. Juni 2006, 18:47

Hi!

Wahrscheinlich stimmen die Zugriffsrechte im Filesystem nicht.
Stichwort chown / chmod.
Was gibt denn

Quellcode

1
ls -la /mnt/

aus?

Gruss,
EvilDevil

Anzeigen
  • »Poelchen1337« ist der Autor dieses Themas

Beiträge: 136

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Weinstadt

Beruf: Technischer Zeichner

  • Nachricht senden

3

Samstag, 3. Juni 2006, 01:56

FTP:~# ls -la /mnt/
total 12
drwxr-xr-x 3 root root 4096 Jun 2 02:02 .
drwxr-xr-x 22 root root 4096 Jun 1 18:44 ..
drwxr-xr-x 7 root root 4096 Jun 2 02:41 filez

4

Samstag, 3. Juni 2006, 14:11

Hi,

hmm.. sieht eigentlich in Ordnung aus.
Was mir gerade eben noch aufgefallen ist:
In dem von dir geposteten Apache-config Ausschnitt ist die

Quellcode

1
 <Directory /mnt/filez>
Direktive zweimal vorhanden. Vielleicht stört apache sich daran. Bringt es etwas, wenn du die erste <Directory> Direktive rausnimmst?

Gruss,
EvilDevil

  • »Poelchen1337« ist der Autor dieses Themas

Beiträge: 136

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Weinstadt

Beruf: Technischer Zeichner

  • Nachricht senden

5

Samstag, 3. Juni 2006, 21:16

was ist mit


Quellcode

1
DocumentRoot "/mnt/filez"


des hab ich mal umgeändet.. ist es nicht so dass ich da doch ein anderes verzeichniss haben muss wo die ganzen account sachen drin sind ?



P.s. nachdem ich das erste directory root ausgenommen hab ist nichts passiert >_<
danke bis dahin..


gruß Robert

  • »Poelchen1337« ist der Autor dieses Themas

Beiträge: 136

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Weinstadt

Beruf: Technischer Zeichner

  • Nachricht senden

6

Sonntag, 4. Juni 2006, 12:45

oh noch ne frage.. wäre es möglich XAMPP auf der NSLU zum laufen zu bekommen ?

mein kumpel meinte der apache läuft unter seinem windowz rechner hervorragend.. aber unter linux hatte er ein wenig probleme..
ich meine wenn ich xampp drauf laufen hab ist der apache ja sowieso des gleiche..


hab mal des ding installiert ---- und es hat geheißen er kann den apache nicht starten... die NSLU hat ne diagnose durchgeführt. und sich bei mir entschuldigt weil sie den fehler nicht angeben konnte ^^ hat mich auch richtig weitergebracht .. aber gut..

was ist deiner meinung nach besser. . .oder kennst du vllt noch andere HTTP server welche einfach meine gehosteten dateien anzeigen ..
..

gruß Robert

7

Sonntag, 4. Juni 2006, 19:57

xampp linuX Apache Mysql Php Perl?
hmm... wenn du wirklich nur statische dateien anzeigen lassen willst, wäre xampp der absolute overkill.
Auf der NSLU2 gilt: Je kleiner desto besser. theoretisch würde der busybox httpd reichen (wenn er standardmäßig aktiviert wäre...) Ansonten gibt es noch cherokee und andere:
siehe auch

Quellcode

1
apt-cache search httpd


Gruss,
EvilDevil

  • »Poelchen1337« ist der Autor dieses Themas

Beiträge: 136

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Weinstadt

Beruf: Technischer Zeichner

  • Nachricht senden

8

Sonntag, 4. Juni 2006, 23:45

so hi :O)
erstmal danke ..

hab jetzt cherokee installiert funktioniert problemlos
blos jetzt kommt mein problem welches mich tierisch aufregt..


ich hab ja meine /sda/sda3 auf /mnt/filez gemountet

samba eingerichtet und dem cherokee


kannst ja ma schaun http://poelchen1337.kicks-ass.org


suuper dacht ich mir ..
und ich wollte graed noch nen video draufhaun .. und da ssteht nicht genügend speicherplat wobei noch 246 GB frei sein sollten >_<

was ich vermute dass er keine sda3 gemountet hat

wenn ich mount /dev/sda3 /mnt/filez eingebe will er ein dateisystem haben

probiere ich es mit mount -t vfat /dev/sda3 /mnt/filez dann sagt er mir dass das dateisyste nicht stimmt
probiere ich es mit mount -t FAT32 /dev/sda3 /mnt/filez dann sagt er mir dass ich vfat benutzen soll >_<


mach ich es mit FSTAB .

/dev/sda3 /mnt/filez vfat defaults 0 0

und wenn ich MOUNT eingebe erscheint :

FTP:~# mount
/dev/sda2 on / type ext3 (rw)
proc on /proc type proc (rw,dafaults)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
tmpfs on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
FTP:~#


wenn ich mount -a ausführe

FTP:/# mount -a
mount: wrong fs type, bad option, bad superblock on /dev/sda3,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
FTP:/#






also er hat keinen sda3 >_<

was ich dabei sagen muss :

sda1 = 512 M
sda2 = 3 GB <<< scheint ja jetzt voll zu sein >_<
sda3 = rund 246 GB <<< scheint ja jetzt leer zu sein >_<


was muss ich umstellen damit ich meien sda3 auf das /mnt/fiilez verzeichniss lege .. damit ich samba und so nicht umstellen muss

ist doch nur ein mount problem oder ?


oh und wie kann ich jetzt alle daten die was weiß ich wo auf der platte sind auf die SDA3 übertragen ?

und wie kann ich den speicherplatz anzeigen lassen von allen partitionen..



gruß Robert..
ich hoff ich hab nicht zuviel auf einmal gefragt >_< .

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

9

Montag, 5. Juni 2006, 11:01

Moin,

Ist Deine "sda3" eine primäre, oder eine erweiterte Partition?
Wenn letzteres zutrifft, ist es nicht "sda3" sondern "sda5"...
Wie sieht die Ausgabe von fdsik -l /dev/sda aus ?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


  • »Poelchen1337« ist der Autor dieses Themas

Beiträge: 136

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Weinstadt

Beruf: Technischer Zeichner

  • Nachricht senden

10

Montag, 5. Juni 2006, 12:25

FTP:~# fdisk -l /dev/sda
Disk /dev/sda: 250.0 GB, 250059350528 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot Start End Blocks Id System
/dev/sda1 1 63 506016 82 Linux swap / Solaris
/dev/sda2 64 429 2939895 83 Linux
/dev/sda3 430 30401 240750090 83 Linux
FTP:~#


oder soll ich die sda3 als erweiterte sda5 formatieren ? ich hab jetzt zwiscchenzeitlich verschiedene dateiformate ausprobiert bei der sda3 deshalb ist sie jetzt auf -t 83 ...


gruß Robert

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

11

Montag, 5. Juni 2006, 13:17

Tach,

Nach einem mkfs.ext3 /dev/sda3, kannst Du die Partition mounten ?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


  • »Poelchen1337« ist der Autor dieses Themas

Beiträge: 136

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Weinstadt

Beruf: Technischer Zeichner

  • Nachricht senden

12

Montag, 5. Juni 2006, 20:40

danke hat geklappt :)

freut mich wirklich :)
endlich bin ich happy ..^^ (mal sehn wie lange bis ich ne neue idee hab)


gruß Robert:D

  • »Poelchen1337« ist der Autor dieses Themas

Beiträge: 136

Verwendetes NAS-Device: NSLU2

Firmwareversion / your current Firmware: Debian

Wohnort: Weinstadt

Beruf: Technischer Zeichner

  • Nachricht senden

13

Montag, 5. Juni 2006, 23:05

so dies alles hat ja mal wunderbar geklappt.


nur noch ne frage.. wie muss ich die platte /dev/sda3 in die fstab eintrage damit sie als /mnt/filez gemountet wird ??

keine lust nach jedem neustart die platte neu zu mounten


Quellcode

1
/dev/sda3      /mnt/filez      ext3     defaults     0  0



geht schonmal nicht >_<


ansonsten schon DAAAAANKE für alles :)

14

Dienstag, 6. Juni 2006, 15:30

Quellcode

1
/dev/sda3       /mnt/filez  ext3    defaults        1  1


die zeile muss ans ENDE der fstab
bzw zumindest nach dem eintrag für /
Gruss,
EvilDevil

Social Bookmarks