Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

1

Freitag, 7. April 2006, 23:21

Möchte OpenDebian Installieren

Hallo ,

habe Gestern mein NSLU bekommen. Habe es jetzt angeschlossen
an mein Netzwerk ohne eine Modifikation.
Möchte nun gerne Debian installieren die fertigen images von evil devil
nur ich weiss nicht wie ich anfangen soll ?:confused:
Verstehe die Englischen und deutschen anleitungen nicht so sehr.
Was muss ich jetzt tun ? muss ich vorher openSlug installieren ?
Wer glücklich über eine Hilfe wenn mir jemand erklären könnte wie ich vorgehen müsste.
Danke im vorraus für die Antworten

Anzeigen

2

Samstag, 8. April 2006, 00:17

Hi,

also wenn du meine Images installieren willst, installierst du DebianSlug.
Die Installation der Images ist eigentlich sehr gut dokumentiert.
Am besten probierst du es erst einmal aus und falls irgendwelche Probleme auftauchen, melde dich nochmal hier.

Gruss,
EvilDevil

Vorgehensweise:
DebianSlug Image flashen
Bootstrap Anleitung folgen
Fertig

Anzeigen

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

3

Sonntag, 9. April 2006, 12:55

Hallo,

ich komme nicht klar !
ich habe im moment die original firmware drauf wie gehe ich jetzt vor ?
Wie bringe Debian von evil devil drauf.
1. Lade ich mir die images von evil devil runter
2. Wie flashe ich dann die nslu mit dem image ?
3. Bootstrap durchführen ?

:confused:

Wäre dankbar für eine Hilfe:(

4

Sonntag, 9. April 2006, 13:27

Hi,
also runterladen wird wohl das geringste Problem sein. Einfach die aktuellste Version von meiner Seite downloaden.

Flashen bei Originalfirmware mit dem Webinterface

Bootstrap per SSH (Putty) wie in den Anleitungen beschrieben.

Gruss,
EvilDevil

PS: Ich würde dir empfehlen, statt DebianSlug das Unslung Flashimage zu nehmen, denn wenn du jetzt schon Probleme hast, wird es dir bei Debian wahrscheinlich nicht besser ergehen.
Bei Unslung bleibt die Funktionalität des Webinterface erhalten, bei DebianSlug muß man alles per SSH (also Linux-Shell) erledigen.

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

5

Sonntag, 9. April 2006, 15:17

Das komische ist das ich bei meiner original firmware auf der webkonfi keine
menü oder funktionen habe die auf das flashen zeigen ?

Ich gebe die IP von der nslu im browser an bekomme ein menü wo fast gar nichts machen kann !

Wieso ?

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

6

Montag, 10. April 2006, 12:00

Hallo ,

flashen hat geklappt ! ( danke an Evil Devil :))
Jetzt bin ich beim Deboostrap will es vom ftp server runterladen
nur wir haben im netzwerk einen proxy wo gebe ich jetzt im system den
Proxyeintrag mit dem port an ?

damit wget klappt :confused:

Danke im vorraus für die Antworten.

trapperjohn

Fortgeschrittener

Beiträge: 558

Wohnort: Bremen

Beruf: SW-Entwickler

  • Nachricht senden

7

Montag, 10. April 2006, 12:27

Du kannst bspw. die Umgebungsvariable "http_proxy" setzen:

Quellcode

1
export http_proxy=http://proxyserver:8080

(Namen und Portnummer des Proxyserver natürlich anpassen...)
Gruß,
Flo

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

8

Montag, 10. April 2006, 12:36

Tach,

wie auf jeden *x System in 2 Environment Variablen, http_proxy und ftp_proxy...

Außerdem startest Du wget ggfs. mit den Optionen --proxy-user=bla und --proxy-password=blu, oder einem Adress-String der etwa so aussieht:

http://user:password@proxy.de:8001/

bye
JrB
"Supporting joe users worldwide" <- that's our motto


trapperjohn

Fortgeschrittener

Beiträge: 558

Wohnort: Bremen

Beruf: SW-Entwickler

  • Nachricht senden

9

Montag, 10. April 2006, 13:01

Sollte das Skript allerdings in einer eigenen Shell laufen, kann es sein, dass wget die Umgebungsvariablen nicht "sieht". Wenn das passiert, kannst du die Konfiguration von wget auch in der Datei .wgetrc (im Home Verzeichnis des jeweiligen Users, bei dir wohl root) angeben.
(weitere Info: http://www.editcorp.com/personal/lars_appel/wget/wget_8.html)
Gruß,
Flo

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

10

Montag, 10. April 2006, 14:23

Hallo ,

bin jetzt in der Bootstrap anleitung wo man in die chroot wechselt
klappt nicht ! ich gehe so vor:
Jetzt gehts per chroot in die neue Debian-Umgebung. Hierzu ist anzumerken, dass man wenn man beim boostrap manche Dinge wiederholen möchte, beachten sollte ob dies innerhalb des chroot oder ausserhalb machen muss.

cd /
chroot /mnt/debinst
Ich bekomme : Segmentation fault


Wieso ?

caplink811

Forensupporter

Beiträge: 2 200

Verwendetes NAS-Device: 64X2/8GB/Ubuntu10.04LTS

Firmwareversion / your current Firmware: anderes

Wohnort: Berlin

Beruf: TK/IT Consulting and Engineering

  • Nachricht senden

11

Montag, 10. April 2006, 15:43

Tach,

Du hast proc an die richtige Stelle montiert?

bye
JrB
"Supporting joe users worldwide" <- that's our motto


jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

12

Montag, 10. April 2006, 15:53

So habe ich es gemacht laut anleitung ( die deutsche übersetzung)


mount -t proc proc /mnt/debinst/proc



Was läuft schief ?:confused:

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

13

Montag, 10. April 2006, 18:33

Ich komme irgendwie nicht weiter !

Was kann ich den jetzt machen ? was passiert eigentlich wenn ich die
nslu jetzt resete ist alles dann so wie vorher mit original firmware ?
und kann das Prozedere mit debian von neuem beginnen ?

Wäre dankbar für Hilfe :confused:

14

Montag, 10. April 2006, 19:20

Wenn du jetzt resettest, hast du keine original-firmware, sondern im prinzip little endian openslug.
Du kannst dich danach immer noch per ssh einloggen und die installation nochmal von vorne beginnen.

Gruss,
EvilDevil

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

15

Montag, 10. April 2006, 19:34

@Evil Devil

weisst du was für ein problem das ist mit dem chroot
und der
segmentation fault fehlermeldung ?

16

Montag, 10. April 2006, 19:46

Ich nehme einfach mal an, dass einer der vorhergehenden Schritte nicht/falsch ausgeführt wurde/Fehler ignoriert wurden.
Einfach mal rebooten, Festplatte frisch partitionieren und nochmal mit doppelter Aufmerksamkeit alles durchführen.

Gruss,
EvilDevil

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

17

Mittwoch, 12. April 2006, 09:05

Hallo ,

ich habe das Gerät jetzt resetet danach habe laut dieser anleitung http://wiki.nslu2-info.de/pmwiki.php/How…anSlugBootstrap
wieder von vorne begonnen mit dem partitionen !
alle partitionen vorher gelöscht neu angelegt aber beim befehl :
swapon /dev/sda1 bekomme ich die fehlermeldung :swapon: /dev/sda1: Device or resource busy

Wieso klappt das nicht ? :confused::(

Würde mich über eine Hilfe freuen

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

18

Mittwoch, 12. April 2006, 11:11

Probel gelöst : swapon war schon aktiv !:)

jackherer

Anfänger

  • »jackherer« ist der Autor dieses Themas

Beiträge: 28

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

19

Mittwoch, 12. April 2006, 11:53

Wollte die packete anacron popularity-contest nslu2-utils sowie openssh
installieren bekomme folgende meldung :


ed
libgnutls12: Depends: libtasn1-2 (>= 0.2.13) but it is not going to be install ed
libtasn1-2-bin: Depends: libtasn1-2 (>= 0.3.1) but it is not going to be insta lled
openssh-server: Depends: libkrb53 (>= 1.4.2) but it is not going to be install ed
Depends: openssh-client (= 1:4.2p1-8) but it is not going to b e installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a s olution).
root@LKG65AC52:/# apt-get install openssh-server
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libgnutls11: Depends: libtasn1-2 (>= 0.2.13) but it is not going to be installed
Depends: libtasn1-2 (>= 0.2.10) but it is not going to be installed
libgnutls12: Depends: libtasn1-2 (>= 0.2.13) but it is not going to be installed
libtasn1-2-bin: Depends: libtasn1-2 (>= 0.3.1) but it is not going to be installed
openssh-server: Depends: libkrb53 (>= 1.4.2) but it is not going to be installed
Depends: openssh-client (= 1:4.2p1-8) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



Was klappt da nicht ?:confused:

snowmann

Anfänger

Beiträge: 15

Firmwareversion / your current Firmware: Unslung 3.18

  • Nachricht senden

20

Mittwoch, 12. April 2006, 13:07

Hast du mal ein "apt-get update" versucht?

-f bedeutet:
-f versuchen fortzufahren, wenn dir Integritätsüberprüfung fehlschlägt

Social Bookmarks