Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

61

Freitag, 17. März 2006, 23:47

Du meinst die Anleitung auf http://www.nslu2-linux.org/wiki/DebianSlug/Bootstrap ?
Hast du auch die Befehle zwischen debootstap --arch arm sarge ....
und apt-get update gemacht?

Gruss,
EvilDevil

62

Freitag, 17. März 2006, 23:54

Ja, habe ich.
Muss ich bei :
Edit /etc/inittab to disable the tty[1-6] entries and add the following serial console entry:
"S0:2345:respawn:/sbin/getty 115200 ttyS0" nur die Zeile in "" in die erste Zeile der inittab schreiben?

Beste Grüße
Nick

Ps. Auch mein gestern installierter "mc" oder fdisk läßt sich nicht mehr aufrufen :(
Netz:
NSLU2 auf 266 mhz mit Firmware: Debian by EvilDevil
HP e-pc 933 mhz 256 MB inkl. 400 GB Samsung mit WinXP Pro
Dreambox 7000s mit Gemini
extern 1x 200GB Maxtor Icy Box ,1x 160GB Maxtor Metal Gear Box,
Router Siemens SE 515, Fritz Box Fon Wlan 7050,

63

Samstag, 18. März 2006, 00:01

Hmm...
boote mal ohne Festplatte und poste den Inhalt von /linuxrc
Hast du Zeit für IRC?
irc.freenode.org #nslu2-german

Gruss,
EvilDevil

64

Samstag, 18. März 2006, 00:12

root@xxxx:~# /linuxrc
Usage: init 0123456SsQqAaBbCcUu
root@xxxx:~#

Mit IRC kenne ich mich leider auch nicht aus:o , werde mich schnell mal
schlaulesen. Ist ja net so umfangreich wie Linux... :D

Danke für Deine Hilfsbereitschaft

Nick
Netz:
NSLU2 auf 266 mhz mit Firmware: Debian by EvilDevil
HP e-pc 933 mhz 256 MB inkl. 400 GB Samsung mit WinXP Pro
Dreambox 7000s mit Gemini
extern 1x 200GB Maxtor Icy Box ,1x 160GB Maxtor Metal Gear Box,
Router Siemens SE 515, Fritz Box Fon Wlan 7050,

65

Samstag, 18. März 2006, 02:39

Hi,

sorry, hab dich im IRC verpasst.
Du hast leider nur die Ausgabe von /linuxrc gepostet. Ich wollte eigentlich den Inhalt ;)

Quellcode

1
cat /linuxrc


Gruss,
EvilDevil

66

Samstag, 18. März 2006, 03:20

@wilddog wegen debian installer image:

Zitat


note: currently (as of 2006-03-17) the installation is broken due to a bug in the cron package in the archive. A fix has been uploaded and the installation will work again in a day or two. Please hold on for a day!


(Quelle http://www.nslu2-linux.org/wiki/DebianSlug/HomePage)

Gruss,
EvilDevil

67

Samstag, 18. März 2006, 10:20

Hi EvilDevil,

sry, aber ich habe echt no Plan von Linux. Habe mir gerade über VM Ware
Debian neben XP zum Testen installiert.

Hier der Auszug aus linuxrc :

login as: root
root@192.168.1.77's password:
Host name: xxxxx
Domain name: ARBEITSGRUPPE
Host MAC: 00:xx:x6:x4:x6:25 Network boot method: dhcp
Use 'turnup init' to reset the configuration
Use 'turnup preserve' to save the configuration permanently
Use 'turnup restore' to restore a previously saved configuration
Use 'turnup disk|nfs -i <device> options to initialise a non-flash root
Use 'turnup help' for more information
root@xxxxx:~# cat /linuxrc
#!/bin/sh
# boot from the current (flash) root partition
# nothing need be done apart from setting the
# system LED status correctly
leds beep
. /etc/default/functions
leds boot system
test -x /sbin/init && exec /sbin/init
# fallback if /sbin/init has been deleted (bad!)
leds boot system panic
exec <>/dev/console >&0 2>&0
test -x /sbin/sulogin && exec /sbin/sulogin
test -x /bin/sh && exec /bin/sh
exit 1
root@xxxxx:~#


Besten Dank...

MfG
Nick
Netz:
NSLU2 auf 266 mhz mit Firmware: Debian by EvilDevil
HP e-pc 933 mhz 256 MB inkl. 400 GB Samsung mit WinXP Pro
Dreambox 7000s mit Gemini
extern 1x 200GB Maxtor Icy Box ,1x 160GB Maxtor Metal Gear Box,
Router Siemens SE 515, Fritz Box Fon Wlan 7050,

68

Samstag, 18. März 2006, 11:26

Hi,
sieht aus, als ob du noch kein

Quellcode

1
turnup disk

gemacht hast.
Bei mir steht ne Zeile mit

Quellcode

1
.... exec '/boot/disk' ....


Gruss,
EvilDevil

69

Samstag, 18. März 2006, 18:00

Hallo EvilDevil,

das ist richtig. Der Befehl "turnup disk" kommt in der Anleitung
erst nach dem "apt-get update" :(
Noch eine Idee?

MfG
Nick
Netz:
NSLU2 auf 266 mhz mit Firmware: Debian by EvilDevil
HP e-pc 933 mhz 256 MB inkl. 400 GB Samsung mit WinXP Pro
Dreambox 7000s mit Gemini
extern 1x 200GB Maxtor Icy Box ,1x 160GB Maxtor Metal Gear Box,
Router Siemens SE 515, Fritz Box Fon Wlan 7050,

wilddog1806

Schüler

Beiträge: 103

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

70

Samstag, 18. März 2006, 21:16

Hi,

hab mir die anleitung grad noch mal angesehen.

evtl. hast du das hier vergessen:

Zitat


Mount the proc filesystem:
mount -t proc proc /mnt/debinst/proc

Chroot into your new Debian environment:
cd /chroot /mnt/debinst


damit änderst du meines wissens das aktuelle root verzeichniss und verweist auf die festplatte.

in diesem abschnitt kommt dann auch das apt-get an die reihe.

hoffe ich konnte weiterhelfen.

gruß

wilddog

71

Sonntag, 19. März 2006, 00:48

Hi wilddog,

danke für den Tip. Ich habe aber nichts vergessen. Bin wirklich Schritt für
Schritt vorgegegangen. Das ein oder andere Mal habe ich nur im Netz nach
den aktuellen Paketen (ich glaube u.a. die lib.modules!?? - hatte schon
von 21:45 - 7:30 an der Sache gesessen + ein bis zwei Becks) gesucht,
da auf der angegebenen homepage das Paket nicht angelegt oder gar die
page net erreichbar war.
... und meine fstab bzw. meine Partitionen sahen halt anders aus (siehe
Tread oben). Außerdem hatte ich die Platte schon vor dem Flashen
von EvilDevil`s Image angehangen...

Snüff, komme wohl nicht um ein erneutes Flashen mit jungfräulicher Hdd
drumrum...

Wenn ich die Platte an einem Hub betreiben möchte, brauche ich diesen
dann nur zwischenhängen und die bootstrap- Anleitung befolgen?

Vielen Dank für Eure Hilfe

MfG
Nick
Netz:
NSLU2 auf 266 mhz mit Firmware: Debian by EvilDevil
HP e-pc 933 mhz 256 MB inkl. 400 GB Samsung mit WinXP Pro
Dreambox 7000s mit Gemini
extern 1x 200GB Maxtor Icy Box ,1x 160GB Maxtor Metal Gear Box,
Router Siemens SE 515, Fritz Box Fon Wlan 7050,

wilddog1806

Schüler

Beiträge: 103

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

72

Sonntag, 19. März 2006, 01:28

moin,
hab auch schon stunden mit der inst. verbracht, aber mit kaffee :D

mit hub während der inst. hab ich noch keine erfahrung, sollte aber gehen wenn du den einfach dazwischenhängst.

neu flashen brauchst du eigentlich nicht, so nun ne kleine anleitung, habs nämlich selbst grad hinter mich gebracht.

- erst mal gehst du so vor wie bei bootstrap beschrieben, d. h. erst mal die slug ohne platte booten und einloggen (user=root; pw=opeNSLUg)
- platte anhängen und die partitionen einrichten mit fdisk /dev/sda, so wie beschrieben
- bootstarp herunterladen, ich hab den hier benutzt: wget http://ftp.nl.debian.org/debian/pool/mai…_0.3.3_arm.udeb
- export DEBOOTSTRAP_DIR=/mnt/debinst/work/usr/lib/debootstrap
- ./usr/sbin/debootstrap --verbose --arch arm sarge /mnt/debinst http://ftp.debian.org/
- dann erst mal weiter nach anleitung, ganz wichtig ist das chroot, dadurch wird die angehängte platte temporär zum rootverzeichniss gemacht
- die fstab erstellen, meine sieht so aus (ich habe insgesamt 3 partitionen)

Zitat


/dev/sda1 / ext3 defaults 1 1
/dev/sda2 swap swap defaults 0 0
/dev/sda3 /data ext3 defaults 1 1
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs defaults 0 0


- die inittab und interfaces erstellen
- /etc/apt/sources.list ergänzen, hier ist meine:

Zitat



- apt-get update
- apt-get dist-upgrade

- dann habe ich die nslu2-utils installiert:
cd /tmp
wget http://ftp.nl.debian.org/debian/pool/mai…_0.10-3_arm.deb
dpkg -i nslu2-utils_0.10-3_arm.deb

anschliessend zurück auf die root cd /

weiter nach anleitung zu debian sarge:

Zitat


Replace modutils with module-init-tools (being in the chroot) :
dpkg -P modutils
rm /etc/rcS.d/S20modutils
apt-get install module-init-tools


jetzt soll noch udev installiert werden, ich hab auch gleich die recommended packages installiert
- apt-get install udev ifrename usbutils pciutils
- nun statt "apt-get install openssh-server", "apt-get install ssh"

soweit bin ich nun.

hoffe es hilft dir weiter

gruß

wilddog

wilddog1806

Schüler

Beiträge: 103

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

73

Sonntag, 19. März 2006, 02:38

iergenwas funt noch nicht. nach reboot spricht er zwar die platte an, bleibt aber dann hängen und die status led blinkt gelb/rot.
die slug ist auch nicht anzupingen. ohne platte geht's. vielleicht hat ja jemand ne idee.


gruß

wilddog

74

Sonntag, 19. März 2006, 19:58

Zitat von »wilddog1806«

iergenwas funt noch nicht. nach reboot spricht er zwar die platte an, bleibt aber dann hängen und die status led blinkt gelb/rot.
die slug ist auch nicht anzupingen. ohne platte geht's. vielleicht hat ja jemand ne idee.


gruß

wilddog


Hi wilddog,

vielen Dank für Deine Unterstützung. Mache mich gleich ans Werk.
Dein letzter Beitrag klingt aber nicht gut.
Ich sagte ja bereits, dass es bei meinem ersten Versuch alles soweit
funzte, bis zum apt-get update, doch
leider erkennt auch meine Slug -nach dem reboot- die Hdd nicht mehr.
Ist der Server bzw. sind die Pakete wieder erreichbar?

Beste Grüße

Nick
Netz:
NSLU2 auf 266 mhz mit Firmware: Debian by EvilDevil
HP e-pc 933 mhz 256 MB inkl. 400 GB Samsung mit WinXP Pro
Dreambox 7000s mit Gemini
extern 1x 200GB Maxtor Icy Box ,1x 160GB Maxtor Metal Gear Box,
Router Siemens SE 515, Fritz Box Fon Wlan 7050,

wilddog1806

Schüler

Beiträge: 103

Firmwareversion / your current Firmware: originale Firmware 2.3r24

  • Nachricht senden

75

Sonntag, 19. März 2006, 22:42

hallo nick,

ich hab das mit dem sarge erst mal aufgegeben, zum glück hatte ich ein image von ner älteren inst. die habe ich auf die platte gebügelt und das passende image von EvilDevil auf die slug.

es gibt auch einen neues thema hier im board unter debian slug betreffs der debian arm geschichte. müssen wir halt mal abwarten was das gibt.

gruß

wilddog

76

Sonntag, 19. März 2006, 22:45

HI wilddog,

Sinclair hilft mir gerade im Chat (irc). Mal sehen wie weit wir kommen...

Viel Erfolg...

Nick
Netz:
NSLU2 auf 266 mhz mit Firmware: Debian by EvilDevil
HP e-pc 933 mhz 256 MB inkl. 400 GB Samsung mit WinXP Pro
Dreambox 7000s mit Gemini
extern 1x 200GB Maxtor Icy Box ,1x 160GB Maxtor Metal Gear Box,
Router Siemens SE 515, Fritz Box Fon Wlan 7050,

77

Montag, 20. März 2006, 01:39

Zitat von »wilddog1806«

iergenwas funt noch nicht. nach reboot spricht er zwar die platte an, bleibt aber dann hängen und die status led blinkt gelb/rot.
die slug ist auch nicht anzupingen. ohne platte geht's. vielleicht hat ja jemand ne idee.


gruß

wilddog



Hi wilddog,

bin jetzt (leider) genau so weit wie Du... die Kiste lässt sich mit Platte nicht mehr starten.
Einziger Fehler, der zwischendurch auftrat war bei:"killall syslogd anacron". Da kam: "killall: anacron: no prozess killed"
Ein Ping auf die Slug mit angeschl. Hdd funktioniert aber!

Shit, und nu?

Beste Grüße

Nick
Netz:
NSLU2 auf 266 mhz mit Firmware: Debian by EvilDevil
HP e-pc 933 mhz 256 MB inkl. 400 GB Samsung mit WinXP Pro
Dreambox 7000s mit Gemini
extern 1x 200GB Maxtor Icy Box ,1x 160GB Maxtor Metal Gear Box,
Router Siemens SE 515, Fritz Box Fon Wlan 7050,

78

Montag, 20. März 2006, 12:04

hmmm
Was bringt ein portscan?
Eventuell ist der ssh-server nicht installiert und/oder startet nicht beim system-start.
Da hilft nur
* ohne hd booten
* per ssh einloggen
* hd mounten
* chroot auf hd
* versuchen, den ssh-server zu konfigurieren
* neustart mit hd

Gruss,
EvilDevil

hermei

Anfänger

Beiträge: 5

Firmwareversion / your current Firmware: originale Firmware 2.3r29

  • Nachricht senden

79

Dienstag, 21. März 2006, 05:41

bin mitten in der Installation von Debian und lese diesen Thread.
Geht es nun oder nicht?

ich habe gerade versucht wget ... durchzuführen. Mein SLUG kann abder den Namen ftp.debian.org nicht ausloesen. woran liegt das?

Gruß
hermei

trapperjohn

Fortgeschrittener

Beiträge: 558

Wohnort: Bremen

Beruf: SW-Entwickler

  • Nachricht senden

80

Dienstag, 21. März 2006, 07:17

a) Deine Internetverbindung scheint auf der NSLU nicht korrekt eingerichtet zu sein. Prüfe mal die /etc/resolv.conf und versuche einen ping auf sonst funktionierende Server (bspw. freenet.de o.ä.)

b) Nimm statt ftp.debian.org direkt
ftp://ftp.de.debian.org/debian
Gruß,
Flo

Social Bookmarks