Sie sind nicht angemeldet.

Anzeigen

**Wir werden in den kommenden Tagen einen Umzug auf einen neuen Server durchführen. Im Rahmen dieser Maßnahme wird das Forum ca. 1 Stunde nicht erreichbar sein.** nslu2-info.de ist ein privates Projekt von mir, welches jeden Monat aus eigener Tasche finanziert wird. Mit einer freiwilligen Spende wird der Erhalt und der weitere Ausbau dieses Forums unterstützt. Um mich beim Erhalt des Forums zu unterstützen, kannst Du entweder via Flattr oder Paypal spenden. Ich bedanke mich schon jetzt bei allen Unterstützern.

Lieber Besucher, herzlich willkommen bei: Die NSLU2 Community****wenns ums speichern und streamen geht****. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 21. März 2009, 22:02

QNAP TS-509 - Samba und Cups

Hallo,

ich habe mal eine kurze Frage und zwar:
Ich habe auf der QNAP TS-509 mittels ipkg cups installiert und Samba und Cups so eingerichtet, dass ich auch über Samba drucken können (ich weiß dies ist nicht notwendig, wegen IPP, aber ich würde doch eher Samba bevorzugen, da bei unserem alten Server alles über die Netzwerkfreigaben ging und ich somit nicht bei jedem PC den Port umstellen muss).
Soweit habe ich das auch zusammengebracht.
ALLERDINGS: Im Gegensatz zu dem was in Windows eingerichtet ist (und zwar dass der Druckauftrag sofort startet, also Spool aktiviert und Sofort beginnen) bzw. ich erwaretet habe, wartet er zuerst bis alle Seiten im Spool sind bevor er mit dem Drucken anfängt und ich weiß einfach nicht wieso.
Meine Vermutung ist zurzeit, dass es allerdings einfach damit zusammenhängt, dass man bei Samba die printcap verwenden muss und nicht einfach eine mit Cups-Support kompilierte Version zur Verfügung hat.
Aber selbst wenn dem so ist, kann man dies irgendwie umgehen?
Vor allem bei Serienbriefe wäre es recht praktisch - weswegen mir das Ganze auch erst später überhaupt erst aufgefallen ist.

EDIT: Das Problem scheint an Cups selbst zu liegen, weil auch wenn ich über IPP drucke, habe ich dieses Problem. Habe Cups aber auch schon komplett neu installiert mittlerweile und das Problem habe ich weiterhin. Außerdem: Ich kann die Option "Share published printers connected to this system" bzw. auf Deutsch "Verteile publizierte Drucker welche mit diesem System verbunden sind" nicht aktivieren. Jedes Mal wenn ich das versuche ist meine cupsd.conf danach unbrauchbar.

EDIT2:
Ich habe jetzt einmal bei Cups nachgesehen bzw. nachgefragt im Forum und das scheint bei Cups generell so zu sein, dass darauf gewartet wird bis der Druckjob komplett gespoolt wurde, bevor mit dem Druck begonnen wird.

Anzeigen

Verwendete Tags

Cups, ipkg, QNAP, Samba

Social Bookmarks